Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

AMD Crimson Driver Doesn't Detect Radeon R9 380


  • Please log in to reply
7 replies to this topic

#1 FredDee

FredDee

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:California, United States
  • Local time:10:11 AM

Posted 03 April 2016 - 03:55 PM

I tried installing this XFX Radeon R9 380 into my computer, but apparently AMD's Crimson driver does not detect my video card. What I Tried: I used Display Driver Uninstaller (DDU) in Safe Mode to remove the drivers beforehand. Then I installed the card. Booted up computer and ran the Crimson Driver setup. The specific file name of the Crimson Driver I used is: radeon-crimson-16.3.2-minimalsetup_web.exe

 

Here are my Specs:

Operating System: Windows 10 Home 64-bit (10.0, Build 10586) (10586.th2_release_sec.160223-1728)
System Manufacturer: LENOVO
System Model: 10080
BIOS: ETKT14AUS
Processor: AMD A6-3650 APU with Radeon™ HD Graphics (4 CPUs), ~2.6GHz
Memory: 8192MB (8 GB) RAM
PSU: 500W
 
Some help would be appreciated, thanks guys!
 
*Note: The attached thumbnail is the prompt that shows up when I run the Crimson Driver setup.

Attached Files


Edited by FredDee, 03 April 2016 - 03:57 PM.


BC AdBot (Login to Remove)

 


#2 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:03:11 AM

Posted 03 April 2016 - 04:39 PM

I would think the issue may be with the APU using HD Graphics mate.

So basically you already have a GFX chipset on the CPU and that would be the 6530 and then you are installing a GFX card along side.

I have not had much to do with APU's but there should be an option to disable the onboard APU Graphics in the bios some where?

That way you could use the GFX card 380



#3 the_patriot11

the_patriot11

    High Tech Redneck


  • BC Advisor
  • 6,763 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wyoming USA
  • Local time:11:11 AM

Posted 03 April 2016 - 09:21 PM

youve made it farther then me, I cant even get the crimson driver to install on my system. But, I agree with Johnny, try and disable the APU graphics, there should be a setting in the BIOS somewhere, different manufacturers put it in different spots and name it differently in their BIOSes.


picard5.jpg

 

Primary system: Motherboard: ASUS M4A89GTD PRO/USB3, Processor: AMD Phenom II x4 945, Memory: 16 gigs of Patriot G2 DDR3 1600, Video: AMD Sapphire Nitro R9 380, Storage: 1 WD 500 gig HD, 1 Hitachi 500 gig HD, and Power supply: Coolermaster 750 watt, OS: Windows 10 64 bit. 

Media Center: Motherboard: Gigabyte mp61p-S3, Processor: AMD Athlon 64 x2 6000+, Memory: 6 gigs Patriot DDR2 800, Video: Gigabyte GeForce GT730, Storage: 500 gig Hitachi, PSU: Seasonic M1211 620W full modular, OS: Windows 10.

If I don't reply within 24 hours of your reply, feel free to send me a pm.


#4 FredDee

FredDee
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:California, United States
  • Local time:10:11 AM

Posted 03 April 2016 - 09:31 PM

I fixed it! I actually ended up fixing it by first restarting the computer in Safe Mode and using DDU to clean everything again. Then I went on AMD's website and found a list of old drivers (specific to my card, here's the link http://support.amd.com/en-us/download/desktop/previous?os=Windows%207%20-%2064). I disabled my anti-virus, then I installed an older version of the driver (it was Win7 compatible only, so I used compatibility mode on my computer to compensate) and it worked! I guess there was something wrong with the detection aspect of the newest driver update. Thanks anyways for the help guys!


Edited by FredDee, 03 April 2016 - 09:35 PM.


#5 the_patriot11

the_patriot11

    High Tech Redneck


  • BC Advisor
  • 6,763 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wyoming USA
  • Local time:11:11 AM

Posted 03 April 2016 - 11:42 PM

awesome fix! glad you got it figured out! I may have to try something similar to that on my system. :D


picard5.jpg

 

Primary system: Motherboard: ASUS M4A89GTD PRO/USB3, Processor: AMD Phenom II x4 945, Memory: 16 gigs of Patriot G2 DDR3 1600, Video: AMD Sapphire Nitro R9 380, Storage: 1 WD 500 gig HD, 1 Hitachi 500 gig HD, and Power supply: Coolermaster 750 watt, OS: Windows 10 64 bit. 

Media Center: Motherboard: Gigabyte mp61p-S3, Processor: AMD Athlon 64 x2 6000+, Memory: 6 gigs Patriot DDR2 800, Video: Gigabyte GeForce GT730, Storage: 500 gig Hitachi, PSU: Seasonic M1211 620W full modular, OS: Windows 10.

If I don't reply within 24 hours of your reply, feel free to send me a pm.


#6 Diogosupremo

Diogosupremo

  • Members
  • 2 posts
  • OFFLINE
  •  

Posted 25 July 2016 - 11:35 PM

Oh man, ur my savior. I am just testing the driver versions right now, if you can help: witch driver version worked for you? I just got the same problem that you did. Help me plz T_T



#7 Diogosupremo

Diogosupremo

  • Members
  • 2 posts
  • OFFLINE
  •  

Posted 25 July 2016 - 11:37 PM

I mean, I did what you did, but i don't have any idea of the version. Will 14.4 do ok?


Edited by Diogosupremo, 25 July 2016 - 11:39 PM.


#8 FredDee

FredDee
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:California, United States
  • Local time:10:11 AM

Posted 26 July 2016 - 07:32 AM

I don't quite remember what version I used I'm sorry! Try some of the drivers that are only Win 7 compatible and use compatibility mode for them.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users