Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Lenovo M91p Desktop not booting with new graphics card (Blank screen no BIOS)


  • Please log in to reply
No replies to this topic

#1 unclechad

unclechad

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 01 April 2016 - 04:10 AM

Hi all

 

I have recently bought a Lenovo M91p thinkcenter Desktop as an upgrade to my old i3 PC.

 

Old Spec is as follows:

  • Coolermaster Thunder 600W power supply
  • Intel DH55HC motherboard
  • i3 CPU
  • Radeon HIS HD 7950 Graphics card
  • 8GB RAM
  • 500GB HDD

I have transferred my old 500GB HD and Power supply to the new Lenovo desktop and everything booted fine.

Then I installed 2x 2GB extra into the Lenovo M91p (Making it 8GB), and upgraded the 500GB HDD to a 1TB.

 

So my new spec is as follows:

  • Coolermaster Thunder 600W power supply
  • Lenovo Q67 motherboard
  • i7 2600 3.4 Ghz CPU
  • 8GB RAM
  • 1TB and 500GB HDD

Everything Booted fine. Then I tried to install my old Graphics card (The Radeon HIS HD 7950 Graphics card). All i got was a blank screen, no beeps, no BIOS... Nothing.

At first, i thought my power supply wasn't enough... So i tested a 750W power supply in the pc. Still nothing.

Then I thought the motherboards BIOS was outdated... Updated it... Still nothing. I even tried updating the firmware of the graphics card. Nothing.

The graphics card definitely works because I tested it in my old machine and it worked 100%.

However, I took my graphics card to my supplier, and he tested it on another one of his PCs... Didn't work there either.

My PC's BIOS doesn't have support for secure boot, in case anyone wants to know.

I have run out of ideas now... Any one able to help?

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users