Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WPAD BYPASS OPENVPN?


  • Please log in to reply
No replies to this topic

#1 killmasta93

killmasta93

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:07:38 PM

Posted 27 March 2016 - 03:27 PM

Hi,

I was wondering if someone else has this setup and has experience the same issue as me.

My setup Im using pfSense 2.2.4 with OpenVPN server and squid and squidguard everything is fine on that part. I then implemented WPAD on my windows server which gives the DHCP and the proxy PAC is hosted on pfSense. Everyone on the LAN gets forced into the Proxy automatically no issue here. Here is where it gets nasty....So if site 1 has pfSense with WPAD and the user wants to connect to the VPN using OpenVPN to site 2 which it does not have WPAD it will connect and you can navigate and such. But you cannot access the webGUI of pfSense or any other device in the the LAN of site 2 for some odd reason WPAD forces the users ONLY for OpenVPN i tried the same setup with PPTP works flawless I also tried with L2TP also works perfectly its only with OpenVPN not sure why? Also side note if i disable "automatic detect proxy settings" i can access the webGUI with OpenVPN but it defeats the purpose whats odd is how come It can work with PPTP and L2TP

Thank you

function FindProxyForURL(url, host) 
{ 
    if (isPlainHostName(host) ||
        shExpMatch(host, "*.local") ||
        isInNet(dnsResolve(host), "192.168.3.0",  "255.255.255.0"))
        return "DIRECT";
 
    return "PROXY 192.168.3.254:3128";
}

Attached Files


Edited by killmasta93, 27 March 2016 - 09:34 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users