Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Normal Users Can't Print to USB Printer That Uses Virtual Port


  • Please log in to reply
2 replies to this topic

#1 jtphenom

jtphenom

  • Members
  • 251 posts
  • OFFLINE
  •  
  • Local time:04:04 PM

Posted 19 March 2016 - 01:24 PM

Hello Friends,

I am running Point-Of-Sale software called RecTrac on Windows 7. My local User is locked down because of the nature of the software. The receipt printer runs over USB with a virtual port, COM3. This is set up using a printer utility that runs using 2 services that are set to start automatically. My Admin user can print to this printer fine. But the POS has to run under a normal User account and that account cannot print to this printer. It CAN print to standard USB printers with no problem.

I've tried setting the two services to log on with admin rights. That doesn't fix it.

I'm thinking this has got to be a registry setting and/or a group policy setting, but I can't find one that seems related. I've tried just guessing and changing different gp settings that are configured, to no avail.

Please help if you are able; this is pretty urgent! Thank you for reading!!



BC AdBot (Login to Remove)

 


#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:04 PM

Posted 19 March 2016 - 02:44 PM

Hi,

 

I have only some suggestions...

 

Give the normal user temporary admin permissions. Doing that it works? them most likely there is a permissions problem somewhere

 

If it doesn't work maybe there is something installed/configured only on the Admin account, try to reinstall the software on the user account and them remove the admin permissions.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 jtphenom

jtphenom
  • Topic Starter

  • Members
  • 251 posts
  • OFFLINE
  •  
  • Local time:04:04 PM

Posted 19 March 2016 - 08:32 PM

Hi,

 

I have only some suggestions...

 

Give the normal user temporary admin permissions. Doing that it works? them most likely there is a permissions problem somewhere

 

If it doesn't work maybe there is something installed/configured only on the Admin account, try to reinstall the software on the user account and them remove the admin permissions.

Thanks. I'll try these things. :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users