Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

QoS and VoIP packet marking for EF


  • Please log in to reply
No replies to this topic

#1 beardtx

beardtx

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:06 PM

Posted 15 March 2016 - 12:43 PM

I have a 400 user network spread across several branches across the U.S.  We have two NOCs, one at Corporate and on at a DR facility.  Corporate has over 100 employees while the branches have anywhere from 4 to 50.  Corporate and DR have Cisco routers managed by our WAN provider.  Branches have bridges in lieu of routers so as to reduce costs and take advantage of their "cloud firewall and routing" service.  We use HP ProCurve switches throughout the org.  Our WAN has two planes:  Normal and Priority, where Priority is only for voice-related packets.

 

We use two VLANs, one for Voice traffic (200) and one for everything else (50).  We use an Avaya IP Office setup with voice servers at Corporate and DR.  Within the phone system configuration I can say, definitively, that all voice and signaling traffic is configured to be marked for Expedited Forwarding (46).  All branch offices connect to the DR phone server and use Corporate's only for backup.  All traffic from the voice servers to phones is properly marked for EF, including both voice (UDP/RTP) and Signaling (TCP).  However, only voice (UDP/RTP) is being marked and prioritized properly.  Signaling (TCP) is not being marked EF, though it should be.  I know this because a Wireshark packet capture made at a ProCurve switch port for a specific phone confirms this.  

 

I have seen the documentation specific to configuring HP ProCurve switches for interoperability with an Avaya phone system.  I believe I have followed it properly.  Still, question I have is this, "Do I have my switches configured properly to mark all traffic as EF for switch ports enabled the Voice VLAN 200?"  I have reviewed so much information that I am starting to believe this might be a problem or even a bug within the phones or phone system itself.  We are having sporadic problems with phones continuing to ring even after they've been answered and phones slow to get dial-tone, which all related to Signalling.  I do have some other statements I implemented for attempting to prioritize traffic for certain IP addresses.  It is not working properly and probably will not as our WAN provider doesn't have anything setup for such prioritization.  Still, removing these entries does not remedy the problems I just described.

 

Here is one of my switch configs.  They all look virtually identical with the except of unique identifiers.  On this particular switch I am monitoring port 18 via port 1 with Wireshark so as to capture packets for a phone.

 

My HP ProCurve 2610 config (and yes, startup and running configs are identical and the switch was rebooted after last config modification):

 

hostname "OLB-ProCurve2610B"
time timezone -360
time daylight-time-rule Continental-US-and-Canada
mirror-port 1
no web-management
web-management ssl
no telnet-server
interface 2
name "SWOBFILE"
exit
interface 23
name "OLB-ProCurve2610C Uplink"
exit
interface 25
name "OLB-ProCurve2610A Uplink"
exit
interface 26
name "MIB Uplink"
speed-duplex 100-full
exit
ip default-gateway 10.16.200.1
timesync sntp
snmp-server community xxxxxxxx
snmp-server community xxxxxxxx
vlan 1
name "DEFAULT_VLAN"
untagged 25,27-28
no ip address
tagged 1
no untagged 2-24,26
exit
vlan 50
name "Data"
untagged 1-22,24
ip address 10.16.50.3 255.255.255.0
qos priority 5
tagged 23,25
exit
vlan 200
name "Voice"
untagged 26
ip address 10.16.200.3 255.255.255.0
qos dscp 101110
tagged 1-14,16-25
voice
exit
interface 18
monitor
exit
qos device-priority 172.20.2.120 dscp 101110  **primary phone server**
qos device-priority 10.1.200.2 dscp 101110  **secondary phone server**
qos device-priority 10.1.10.2 priority 5 
qos device-priority 10.1.10.3 priority 5
qos device-priority 172.20.2.102 priority 3
qos device-priority 10.1.10.102 priority 5
qos device-priority 10.1.20.161 priority 5
qos device-priority 10.1.10.170 priority 5
qos device-priority 172.20.2.180 priority 5
qos device-priority 10.1.10.5 priority 3
qos device-priority 10.16.50.10 priority 3
qos device-priority 10.1.10.17 priority 3
qos type-of-service diff-services
sntp unicast
sntp 30
sntp server 10.1.10.2
ip ssh
 
 
 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users