Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Guild Wars 2 freezing at resolutions > 1920x1200 fullscreen


  • Please log in to reply
3 replies to this topic

#1 ScathEnfys

ScathEnfys

    Bleeping Butterfly


  • Members
  • 1,375 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Deep in the Surface Web
  • Local time:04:37 PM

Posted 15 March 2016 - 11:30 AM

So this bug has been bothering me for quite some time now. I know it's not virus related as I have reformatted my SSD once while trying to fix it (so please no MTB log requests... I know what I have installed :P)

Description of System:
Processor: AMD FX-8350 @ stock (was overclocked but dropped back to stock after a bluescreen and RAM issues)
Memory: 16GB DDR3-2400 11-13-13-35t (running at DDR3-2133 due to AMD limitations... I think) ADATA XPGv2
Storage: Crucial M500 SSD (with plenty of space)
PSU: Antec HCG 850W
Graphics: (2x) XFX R9 290X 4GB "Double Dissipation" @ stock (crossfire)
Monitor: (2x) QNIX QX2710 Evolution II (don't remember if they are second or first edition models) (one matte, one glossy) 2560x1440 @ 60Hz (not overclocking yet) (NOT in a screenspan because eyefinity seems to have issues with spanning only 2 monitors)
OS: Windows 10 Pro (upgraded from win7 pro and clean installed), fully patched.


Problematic Game: Guild Wars 2 (gw2.exe/gw2-64.exe), both 32bit and 64bit clients.

Gaming peripheral software (listed due to possibility of conflicts): Logitech Gaming Suite, AZiO keyboard software, Cooler Master CM Storm Sirus software.


Description of problem: The game's video will hang upon loading into a map with a screen resolution greater than 1920x1200, in full screen mode. This started occurring when I replaced my GTX770 with a pair of R9 290Xs. It freezes at the map load step READY_WAIT, where the loading screen is about to be removed. Audio such as ambient noises, music, and players running by continues, but the display does not appear within 5 minutes of waiting. A black flicker can briefly be seen when the screen freezes.

What helps: switching to native sampling, disabling reflections, disabling AO, and enabling VSync can help to some degree. The problem will still emerge in one to two loads though, even with these tweaked settings. Switching to resolutions equal to or less than 1920x1200 fixes the problem, but seriously degrades visual quality. Switching to windowed fullscreen also fixes the problem, but appears to disable crossfire or at least limit it severely (GPU_2 never clocks above 50% clock or reaches more than 25% utilization under windowed fullscreen).

What I am looking for:
either a) a way to stop the freezing in fullscreen mode without reducing resolution, or B) a way to force crossfire for windowed fullscreen mode. I am comfortable with making registry edits if necessary.

P.S: I have contacted gw2 support before, but they were only able to find these workarounds for me.
Proud system builder, modder, and watercooler.

GitHub | SoundCloud | Keybase

BC AdBot (Login to Remove)

 


#2 Captain_Chicken

Captain_Chicken

  • BC Advisor
  • 1,363 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:37 PM

Posted 24 March 2016 - 09:30 AM

Hey Scath!

 

Which display drivers are you using? Does this thread on guild wars 2 forums seem similar?


Computer Collection:

Spoiler

Spoiler

Spoiler

Spoiler

#3 ScathEnfys

ScathEnfys

    Bleeping Butterfly

  • Topic Starter

  • Members
  • 1,375 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Deep in the Surface Web
  • Local time:04:37 PM

Posted 24 March 2016 - 09:47 AM

I'm using latest AMD Crimson stable release drivers. The thread you linked sounds different due to his freezes occurring "randomly" where mine always occur at a map loading screen, and at the exact same point in loading (figured that out by setting a flag to show map loading debug info), and he is using a NVidia card (my PC ran fine til the AMD + win10 changes). I have opened a ticket with the developers and they have suggested I try running it in compatibility mode... which I will try as soon as a get a chance to play again lol.
Proud system builder, modder, and watercooler.

GitHub | SoundCloud | Keybase

#4 ScathEnfys

ScathEnfys

    Bleeping Butterfly

  • Topic Starter

  • Members
  • 1,375 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Deep in the Surface Web
  • Local time:04:37 PM

Posted 27 March 2016 - 02:28 PM

As an update: the issue appears to be resolved. I was accidentally running the game in compatibility mode, which appears to have been the cause of the issue.
Proud system builder, modder, and watercooler.

GitHub | SoundCloud | Keybase




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users