Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Error iphlpapi.dll Not Allowing Programs Start


  • Please log in to reply
2 replies to this topic

#1 cmdr2005

cmdr2005

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:28 PM

Posted 10 March 2016 - 01:35 AM

Windows 7 Ultimate x64 on Samsung 850 EVO SSD

After struggling for two weeks with a corrupted MBR, I have finally brought the system to boot and log into my user account. However, once logged in, all programs are unable to launch, instead opening a window headed "bdwtxag.exe - Bad Image". It further says:

"C:\Windows\system32\iphlpapi.dll is either not designed to run on Windows or it contains and error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support."

 

I have searched and tried the most common fixes, such as elevated commands in normal boot and safe mode:

sfc /scannow

&

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows

Each time the commands return:

"Windows Resource Protection could not perform the requested operation."

 

Previously, I had this error which I was able to resolve by deleting the problem files in C:\Windows\winsxs.
"There is a system repair pending which requires a reboot to complete. Restart windows and run sfc again."

 

Unfortunately, through all my scouring, I was unable to find a fix for the WRP error. I have tried to run the sfc offbootdir/offwindir command on the drive in question as a D:\ on another machine to the exact same error. Are there any other ways to attack this?



BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,756 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:28 AM

Posted 10 March 2016 - 07:57 AM

With the troublesome drive in the second system...I would first run the chkdsk /r command on the troubled partitition as it appears in the second system.  You can accomplish this by clicking on the Properties tab of the troubled Windows partition in the second system...then electing to run chkdsk and putting check marks in both the Scan and Fix options.

 

Using Chkdsk The GUI Way

 

I would then move that drive back to its home...and try to run the sfc /scannow command.

 

Louis



#3 cmdr2005

cmdr2005
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:28 PM

Posted 12 March 2016 - 10:09 PM

Just tried... and no cigar. It's the same "Windows Resource Protection could not perform the requested operation." error.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users