Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disk errors with Windows 95


  • Please log in to reply
2 replies to this topic

#1 LazyBonesLocker

LazyBonesLocker

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 06 March 2016 - 11:49 PM

I recently got a hold of a Compaq Armada 1750 laptop, running Windows 95, that I plan to use for legacy gaming. The previous owner had it in a cabinet for years untouched, so I spent time cleaning up all the files and programs left behind. I had already gone through many reboots before it failed to boot and instead gave me "Invalid system disk. Replace the disk and press any key to continue." The last thing I did before this happened was rename the CD-ROM drive letter from D: to E:

 

I've figured out a few things. First, there's only about 4GB of the full 6.4GB of space in the C: drive. The rest appears to be partitioned for Compaq Utilities running in DOS 6, which can be booted to by hitting F10, despite not being able to boot to the BIOS. Second, the hard drive makes a very faint 'tick tickety-tock' sound when trying to boot (I went through Datacent's archives of failing hard drive sounds, but nothing sounded familiar, so I hoping that's not it). When I get to the "Invalid system disk" prompt and hit enter, it makes this noise but comes right back to the prompt.

 

What I've tried so far:

*Taking about the battery several times to see if that would resolve it, but no luck

*Two unsuccessful attempts at booting from CDs burned from Windows 95 boot images

*Opening up the underside to ensure the HDD was connected properly; all seemed in order

*Using F10 to get to Compaq Utilities to change the boot order and disable QuickBoot, but to no avail

 

It crossed my mind that maybe the boot sector in the C: partition went bad. Is this plausible? If so, I wouldn't know how to go about fixing it. As soon as I can, I'll try to get a hold of Win95 boot floppy. In the mean time, has anyone had a similar experience with this? Is there a solution?



BC AdBot (Login to Remove)

 


#2 ranchhand_

ranchhand_

  • Members
  • 1,651 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest
  • Local time:11:00 PM

Posted 16 March 2016 - 10:36 PM

This will sound stupid, but if it has a floppy drive, make sure there is no floppy disk in the drive. That used to be (wayyyy back in the dark ages) a common mistake users' made, leaving an unbootable floppy in the drive when attempting to boot, and that was the exact message that the BIOS generated.

4gigs of space left on the HDD is fine for Win95.

 

Check your hard drive for failure:

 

Go here and download Seatools For DOS (free)
http://www.seagate.com/support/downloads/seatools/

Accept the EULA and download the ISO file.
When download is complete burn the ISO to a CD or DVD.
Make sure your BIOS is set to:   1st Boot Device = CD drive, 2nd Boot Device = Hard Drive.
When the program opens, click the upper left corner for the Long Test.
> Note: if you get a pop-up window telling you that SMART has tripped and asking if you want to continue, choose Yes. Be sure to post that in your next reply along with the result of the test.
At the end of the test, you will get either a Pass or Fail notice. Post the result in your next reply.
Be sure to have your hard drive directly installed internally to the motherboard, not in an external case

 

 

not being able to boot to the BIOS

Are you saying that you cannot boot into the BIOS by tapping an F-key or DELETE while booting?


Help Requests: If there is no reply after 3 days I remove the thread from my answer list. For further help PM me.


#3 LazyBonesLocker

LazyBonesLocker
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 16 March 2016 - 10:58 PM

My mistake... it turns out I can get to the BIOS. However, Compaq's BIOS isn't really a BIOS at all, just that cruddy setup utility that lets you change certain system settings, such as the boot order, or run certain system tests, but it doesn't contain any command line and thus I can't use any of the usual DOS commands.

 

I checked the floppy drive, and no disk. I even tried removing it, but it didn't really change anything. My first attempt to boot from the CD drive let me know that the drive was failing, so I replaced that. The new drive spins up like it should, but the machine still doesn't want to recognize bootable CDs.

 

I did, however, get a CMOS checksum error after a while. Thankfully, the battery is easy to get to, so I've ordered a replacement. In the mean time, I'll keep trying with the CD drive.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users