Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Laptop internet works on 5.0, but 2.4 connection randomly loses internet.

  • Please log in to reply
1 reply to this topic

#1 Yoga2Newbie


  • Members
  • 3 posts
  • Local time:06:20 AM

Posted 21 February 2016 - 10:28 AM

Just got a new router, and everything is working great except for my laptop, which randomly loses internet access on the 2.4 connection, however I can connect to the 5.0 no problems. Iphones and Sonos are on same network with no problems. My internet status still says connected.

screenshot of what my browser shows

screenshot of wireless status

Restarting my laptop gets it working again, but it still loses internet connectivity randomly. Any help or tips are greatly appreciated! Let me know if I can provide anything else. Thanks!

Router was given free from T Mobile ASUS RT-AC68U Wireless-AC1900 Dual Band Gigabit Router IEEE 802.11ac

Lenovo Yoga 2 Intel i5 1.60 GHz 4 GB RA Windows 10

Qualcomm Atheros AR956x Wireless Network Adaptor

BC AdBot (Login to Remove)


#2 sflatechguy


  • BC Advisor
  • 2,255 posts
  • Gender:Male
  • Local time:06:20 AM

Posted 21 February 2016 - 11:59 AM

2.4 GHz has a longer range, but it tends to be slower and doesn't have as much spectrum available, so connections are more likely to drop.


Here's a good explanation of the difference: http://www.linksys.com/us/support-article?articleNum=134478


You should set the wireless adapter on the laptop to prefer the 5 Ghz connection. Open the Network and Sharing section, select Change adapter settings on the left rail, right-click the wifi adapter and select Properties, click the Configure button on the Properties window, and select the Advanced tab. In the drop-down menu, there should be options to prefer 5 Ghz.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users