Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

The Boot Configuration Data file doesn't contain valid information...


  • Please log in to reply
3 replies to this topic

#1 IR15H

IR15H

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:59 AM

Posted 20 February 2016 - 12:35 PM

Hi,

 

When launching my Microsoft Surface 3 with Windows 10, I get a blue screen as below;

 

Recovery

 

Your PC/Device needs to be repaired

 

The Boot Configuration Data file doesn't contain valid information for an operating system.

 

File: \BCD

Error code: 0x0000098

 

You'll need to use recovery tools. If you don't have any installation media (like a disc or USB device), contact your PC administrator or PC/Device manufacturer.

 

 

 

If I hold the volume down key on boot up, I can get into some sort of setting screen where I have set the below settings;

 

Trusted Platform Module (TPM)                                                          [Enabled]

 

Secure Boot Control                                                                             [Disabled]

 

Device Information

 

Configure Alternate System Boot Order                 [Network -> USB -> SSD]

 

Administrator Password

 

Exit Setup

 

 

 

I downloaded MediaCreationTool.exe file from Microsoft's website and installed it on a USB. With that inserted, if I hold the volume up key, I can get to a Troubleshooting section.

 

I am trying to restore/repair without wiping everything and have tried the following options; 

 

Reset this PC -> Keep my Files -> The drive where Windows is installed is locked. Unlock the drive and try again.

 

System restore -> To use System restore, you must specify which Windows installation to restore. Restart this computer, select an operating system, and then select System Restore.

 

System Image Recovery -> "Windows cannot find a system image on this computer". I can get to a explorer type screen where I can seemingly browse The C drive, my USB and a "Boot" X drive, but don't know what to choose.

 

Start Up Repair -> Start-up Repair couldn't repair your PC.

 

Command Prompt -> Launches in X:\Sources but don't know what to do.

 

UEFI Firmware Settings -> Just says "Restart to change UEFI firmware settings" and then takes me to the volume down screen as described above.

 

Go back to the previous build -> We ran into a problem and won't be able to take you to the previous build.

 

If I use the USB and select the "Install" option (rather than "Repair your computer") then choose Advanced install I can get to the following screen but again don't know what to do.

 

Attached File  IMG_0823.JPG   109.81KB   1 downloads

 

 

 

Any help much appreciated.


Edited by IR15H, 20 February 2016 - 12:36 PM.


BC AdBot (Login to Remove)

 


#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:10:59 AM

Posted 20 February 2016 - 01:37 PM

Hi :welcome: to BleepingComputer

 

Access the Command Prompt like you did before and try the following:

 

- Type Bootrec /RebuildBcd, and then press ENTER.

If the Bootrec.exe tool runs successfully, it presents you with an installation path of a Windows directory.
To add the entry to the BCD store, type Yes. A confirmation message appears that indicates the entry was added successfully.

If the Bootrec.exe tool cannot locate any missing Windows installations, you must remove the BCD store, and then you must re-create it.
To do this, type the following commands in bold in the order which they are presented:
- Bcdedit /export C:\BCD_Backup
- ren c:\boot\bcd bcd.old
- Bootrec /rebuildbcd


Edited by SleepyDude, 20 February 2016 - 01:37 PM.

• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 IR15H

IR15H
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:59 AM

Posted 20 February 2016 - 04:27 PM

Hi,

 

 

Thank you for your response.

 

 

I was able to successfully run the command prompt lines you provided.

 

 

I then restarted the tablet and managed to get to the Windows Icon / white circular dots screen but unfortunately after that it crashed to a blue screen with error code 0xc00021a - it then restarted again and attempted an automatic repair but this kept failing.

 

 

I then tried  the Reset this PC -> Keep my Files option, which appeared to be working, then left it to run for a while. However, this still didn't solve the issue and I'm getting the same 21a error.

 

Repeating the original bootrec /rebuildbcd command you gave, it now says there's no installed Windows directory any more and one the three further ones you provided it says invalid syntax on the second; ren c:\boot\bcd bcd.old. 

 

I've now gone for the "Recover from the cloud" option which it says will wipe all the files (only had it since Christmas so won't lose too much) as I'd just like to get it working in some capacity now. I'll reply back again when it's finished as to whether it's successful or not.

 

EDIT: Doing a "Recover from cloud" option worked for me and I'm now able to use the tablet as before.


Thanks again for your help.


Edited by IR15H, 20 February 2016 - 06:33 PM.


#4 CSchwarz

CSchwarz

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:59 PM

Posted 03 November 2016 - 07:42 PM

Hi :welcome: to BleepingComputer

 

Access the Command Prompt like you did before and try the following:

 

- Type Bootrec /RebuildBcd, and then press ENTER.
 

 

This worked for me! Thanks.  On a HP Envy Touchsmart






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users