Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HyperX cloud microphone problems


  • Please log in to reply
1 reply to this topic

#1 Fearme99

Fearme99

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:06 PM

Posted 18 February 2016 - 02:02 PM

My friend just bought a "HyperX cloud" headset. Usually, these microphones are quite good,

But his, his sounds like this: https://www.youtube.com/watch?v=ZbXJ...ature=youtu.be

Anyone got any ideas? I've checked so many settings for him, microphone boost is off.

If you need any more information, just write what you need!



BC AdBot (Login to Remove)

 


#2 Fearme99

Fearme99
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:06 PM

Posted 18 February 2016 - 02:22 PM

Specs :
GeForce GTX 960 (EVGA) - gpu
Intel Core i5 4430 @ 3.00GHz - cpu
ASUSTeK COMPUTER INC. B85M-G - motherboard






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users