Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem accessing external hard drive via Rocketfish enclosure


  • Please log in to reply
24 replies to this topic

#1 Jasor31385

Jasor31385

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 06:05 PM

Hello.

 

I recently went through a bout with the javaws.exe virus and, with the help of people on this forum, I was able to cleanse my computer and get it back to running the way it was running before the virus was noticed -- with the exception of one thing: my external hard drive. 

 

The hard drive was pulled from an old laptop and put into a RocketFfsh 2.5" USB 2.0 Hard Drive Enclosure Kit (Model Number RF-PHD25) and I have been using it for a number of years as a storage spot to keep all of my mp3s from all of my CDs and digital downloads, etc. 

 

It was working fine three days ago when I noticed the virus, and I know that it was fine because I was actually in the process of trying to delete an incomplete album from the files when I suddenly got an error message that was something to the effect of "you don't have permission to modify this file" or something like that. 

 

I found it really strange so I ran a quick test to see if the main drive "C:" was able to access the external hard drive "E:" -- I opened up my iTunes library and tried to play a few songs. They worked. 

 

I tried to delete the files a couple more times before the drive stopped allowing me access altogether and that's when I noticed the virus thing and got off onto the adventure that lasted all weekend -- cleaning the computer of the javaws.exe virus. 

 

OK, so now we're up to date and the problem is still there. Everything else on my computer seems fine, all of my malware scanners aren't picking anything up, but I still can't access the external hard drive!

 

Here's the error message I receive when I try to open the drive: "Location is not available", "E:\ is not accessible.", "Access is denied."

 

Another odd thing is that when I would click on "computer" from the start menu I would be able to see both my C: drive and my E: drive and how much space was left on each -- but now the E: drive icon no longer tells me that -- it just says NTFS where the little bar used to be that said how much space I had left on the drive.

 

If anyone can provide any assistance I would greatly appreciate it. 

 

Thanks!



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 06:49 PM

In Disk Management is your External listed without a drive letter assigned? If there is no letter then assign one to the external drive.


Edited by JohnC_21, 15 February 2016 - 06:49 PM.


#3 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 07:23 PM

John, thanks for the advice -- I checked the Disk Management settings and yes, it is listed with a drive letter assigned -- the letter is "E:" -- also, I should note that I checked under the properties tab for the drive and went to the security tab and made sure that both the group or username: "SYSTEM" and "Administrators (Jason-PC/Administrators)" are both given "Full Control" for the permissions. Still no dice.



#4 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 07:32 PM

Try the following commands at an elevated command prompt

 

For Windows 7 type CMD in the Search Box. Right Click Run as Administrator.

 

For Windows 8 and later press the windows key + X  cmd  as admin

takeown /F E:\ /r /d y      
icacls "E:\" /reset /t

After entering the above commands do you have access to E:?  If not can you access E: if you create a new user account.



#5 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 08:04 PM

John, thanks for the response. 

 

I tried those commands -- the first one took about 5 minutes and it said "SUCCESS: The file <or folder>: "E:\..." for like, thousands of files... "now owned by user "Jason-PC\Jason"

 

But then the other one didn't seem to work. 

 

It gave me this line:

 

E:" /reset /t: The filename, directory name, or volume label syntax is incorrect.

 

Successfully processed 0 files; Failed processing 1 files

 

I can try to make a new account and try it. I will let you know.



#6 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 08:07 PM

Update: No, making a second admin account didn't seem to work. It still gave me the same error message.



#7 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 08:07 PM

If you typed the command as shown in your post you used the wrong syntax

 

Copy and paste my command:  include the quotes shown

icacls "E:\" /reset /t


#8 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 08:15 PM

It won't let me copy it to the command line, but I am certain that it's typed exactly as you've given it to me. I took a screenshot but it won't let me attach it.


Oops, there it is.


Attached File  cmdline.png   56.9KB   0 downloads



#9 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 08:19 PM

Does the following command work?

icacls e:\*.* /reset /t


#10 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 08:25 PM

OK, that seemed to work.

 

It is currently slowly processing files now. I will try to open E: when it finishes. 



#11 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 08:29 PM

If this does not work then we can copy the files from the external to the internal hard drive offline using a bootable disk. Then delete the partition(s) on the external, create a new partition, and copy the files back to the external.


Edited by JohnC_21, 15 February 2016 - 08:29 PM.


#12 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 08:32 PM

Well, I think that's what may need to happen next because it just finished and that still didn't work. What's the first step to do that?



#13 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 08:35 PM

What is the make and model of the computer and did it come pre-installed with Windows 8.1?



#14 Jasor31385

Jasor31385
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:06:51 AM

Posted 15 February 2016 - 08:46 PM

The computer that I am on right now is a Dell Latitude E6420 and no, it came with (and still has) Windows 7.



#15 JohnC_21

JohnC_21

  • Members
  • 23,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:51 AM

Posted 15 February 2016 - 08:58 PM

Download Puppy linux Tahrpup here. Burn the iso file to CD by right clicking the iso file and selecting Burn Disk Image. Boot the Puppy Disk. When you get to the Puppy Desktop you will see your hard drive partitions labeled sda1..sda2..sda3  depending on how many partitions are on the hard drive. For Windows 7 your Windows partitions is likely sda2. 

 

Click once on sda2. The partition will mount and a File Manager will open. If you do not see your Windows files then close the File Manager and click on another sdaX partition until you see your Windows files. Attach your external drive. A USB icon will appear on the desktop labeled sdb1. If your external drive has more than one partition then you have a partition labeled sdb2. Click once on the USB icon and another File Manager will open. Drag and resize the two File Managers are side by side. You can resize by left-clicking on a corner of the window and dragging. You can move the window like in Windows by left-clicking the title bar and dragging. In Puppy you only need to click once on a folder to open it.

 

You can highlight the files of the USB external by left-clicking while holding the Ctrl key. You can also left-click and drag a window around the files/folders to highlight them. Once the files are highlighted drag them from the USB File Manager to the Hard Drive File Manager. A small dialog window will open. Click Copy and check the quiet box. I would recommend you only copy a few files. Exit out of Puppy. It will prompt if you want to save settings. Select No. Reboot into Windows and see if you can access the files  you copied. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users