Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Driver question


  • Please log in to reply
2 replies to this topic

#1 harkcomp

harkcomp

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:02:27 AM

Posted 14 February 2016 - 08:44 PM

I have a Dell OptiPlex 980 computer. A year ago I took it to the Geek at Best Buy and they did a tune up on my system and up until now it has been working fabulously.

Six months ago or so I downloaded Windows 10 and it too has been working fantastically. Zero problems at all.

 

However, a couple of days ago I turned on my computer and as usual the screen took me to the Windows 10 sign in screen and it was then I discovered that neither my mouse or my keyboard were working. There was no mouse pointer at all on the screen and none of the lights on my keyboard would work.

 

Out of frustration, I disconnected my computer and took it to the Geek at Best Buy. The tech connected the computer and found exactly the same situation. After trying several mouse's and keyboards the tech discovered that the only mouse and keyboard that would work was the old PS2 plug-in types. None of the USB port mouse's or keyboards worked at all. With the PS2 units plugged in the computer worked just fine.

 

The tech stated that this indicated to him that this was a Universal Serial Bus driver issue that was causing this to happen. The tech then did several searches for driver updates, both on-line and with Microsoft, and each search resulted in no updated drivers being available for my system. I then asked the tech what I could do to fix this problem and he asked me if I had any old PS2 mouse's or keyboards lying around and he said I would have to use those to make my computer work.

 

My question is this: Why was my computer working just fine with the USB connected mouse and keyboard one day and then not working just fine the next morning? Is it possible that a middle of the night Windows 10 update messed up my system?

And why with today's modern technology with optical mouse's and better keyboards do I have to revert back to dinosaur PS2 equipment in order to make my system work? Why is Windows 10 so great if one has to go back to the old "Roller Ball" mouse and cave man keyboard in order to use it? Certainly I would think there must be a better fix than fixing the problem by going backwards in technology. I would think that today's technology would produce some kind of updated driver that can remedy this problem.

 

I look forward to your thoughts.


Edited by harkcomp, 14 February 2016 - 08:45 PM.


BC AdBot (Login to Remove)

 


#2 Demonslay335

Demonslay335

    Ransomware Hunter


  • Security Colleague
  • 3,493 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:27 AM

Posted 14 February 2016 - 10:36 PM

I am willing to bet it is a filter driver from something that has installed recently. What antivirus do you have? I've seen this with antivirus such as Kaspersky many times.

 

If you feel comfortable with regedit, check this key real quick.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96B-E325-11CE-BFC1-08002BE10318}\UpperFilters

You should ONLY see this value.

kbdclass

2016-02-14_2137.png

 

Similarly, for the mouse.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}\UpperFilters

You should ONLY see this value.

mouclass

logo-25.pngID Ransomware - Identify What Ransomware Encrypted Your Files [Support Topic]

ransomnotecleaner-25.png RansomNoteCleaner - Remove Ransom Notes Left Behind [Support Topic]

cryptosearch-25.pngCryptoSearch - Find Files Encrypted by Ransomware [Support Topic]

If I have helped you and you wish to support my ransomware fighting, you may support me here.


#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:04:27 AM

Posted 16 February 2016 - 07:50 AM

I see this quite often at work.  Usually it's only the USB3 ports that are affected, but it can be all the USB ports.

The "fix" is usually to update the chipset and the USB drivers.

If you have the latest version, then the "fix" is to remove (uninstall) them and install a fresh copy.


My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users