Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Problem with AmiPro & AmiPro (xxx.sam) file

  • Please log in to reply
1 reply to this topic

#1 rreynard


  • Members
  • 3 posts
  • Local time:05:25 AM

Posted 04 December 2004 - 03:32 PM

In 1994 I wrote the first book in my Secret Code Breaker series using AmiPro.

I saved the file (many copies) and I am considering making some small revisions before 'converting' it into a PDF file (using PDF955). It worked very well except that the file had no images.

When I opened the xxx.sam file I had saved, I discovered that all the images were 'gone' and AmiPro gave me a message that said -

"Cannot find a library for frame. Frame contents will not be displayed."

Can anyone tell me what I can do to fix this problem?

Since I didn't know what to do to fix this problem directly, I tried deleting the entire frame/image and creating a new one. However, AmiPro will only allow me to 'use' image files with a .sdw extension. The original images were .pcx files and I can't remember how I got them into the frames when I wrote the book. If I could figure out how to do that I would be able to 'restore' the images in that manner.

In the meantime, I tried importing the file to WordPro so I could edit it that way. Every time I did that the last thing WordPro (or maybe it was Windoze ME) would do as it completed the import process (I could see the file in the WordPro space on my screen) was give me an error message - "WordPro has caused an error in (unknown) and it will close now." Of course, my only choice was to click on OK and that would shut down WordPro. It suggested that if this condition persists, which it does, that I reboot, which I have, more than once.

(Expletives deleted)

What can I do to restore the xxx.pcx images to the xxx.sam file of my book?

Also, any idea why WordPro (or Windoze ME) won't let me import the file?

Bob (Reynard)

BC AdBot (Login to Remove)



#2 rreynard

  • Topic Starter

  • Members
  • 3 posts
  • Local time:05:25 AM

Posted 05 December 2004 - 03:16 PM

I realize one should not reply to their own posting, but (ah...the big but) I think I found the problem.

The problem is the incompatibility of Windows ME and both WordPro 9.5 and AmiPro 2.0.

You can decide which is at fault.

I installed both WordPro 9.5 and AmiPro 2.0 on my wife's ThinkPad which is running Windoze 95.

Both application programs performed as expected. I opened my book file (xxx.sam) and it had the images imbedded. I tried an import of that file to WordPro and it handled it with no problem.

Now I'm free to press on and find other problems while using my Bleeping Computer.

Rock on,

Bob (Reynard)

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users