Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem ejecting USB Mass Storage Device


  • Please log in to reply
No replies to this topic

#1 rockpilez

rockpilez

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:14 PM

Posted 09 February 2016 - 05:17 PM

This has been an issue for a long time. I backup numerous files on a 1TB WD Elements external HDD. The issue I am finding is that if I access any of my photos via Win7 Photogallery or MediaCenter, I get the following:

 

Problem ejecting USB Mass Storage Device

This device is currently in use.

Close any programs or windows that might be using the device, and then try again. 

 

At first I looked in Task Manager in Applications and Processes to see what could be the culprit. Nothing surfaced so I googled quite a bit and read forums talking about registry problems but I found an app called Unlocker (V 1.9.2) which identified Windows Media Player (wmpnetwk.exe)as the culprit.

From what I understand, this is for sharing files over a network which is not something I need.  

Unlocker will free up the exHDD but this has to be done every time I access the drive.

Unlocker offers Kill Process , Unlock, Unlock All and a drop down menu of other items(Delete, move, copy) but to date I just go with unlock. 

Is there a better solution or process to get this under control?

 

Edit : I found the problem in that Windows Media Center Streaming was set to local network which I blocked.

and here is what I did (quoted from Windows 7 Help)

  1. Click the Start button , click All Programs, and then click Windows Media Player.

    If the Player is currently open and you’re in Now Playing mode, click the Switch to Library button  in the upper-right corner of the Player.

  2. Click Stream, and then click More streaming options.

     

  3. On the Media streaming options page, do any of the following:

    • If you want to stream media to all computers and devices on your network, click Allow All.

    • If you don't want to stream media to any computers or devices on your network, click Block All.

    • If you want to stream media to some computers and devices, click either Allowed or Blocked on the menu next to each item in the list of computers and devices.

  4. Click OK.

I suspect that one of Windows updates changed that setting because this only occurred in the past 6-8 months or so and I have never changed the Media Center settings.

Funny how making a post like this makes one's thinking process get the juices flowing.

 

I am going to post regardless in case someone has the same issue and needs to figure it out.  

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users