Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Coby Kyros mid1126 blank screen

  • Please log in to reply
No replies to this topic

#1 Tinroad


  • Members
  • 44 posts
  • Local time:06:59 AM

Posted 05 February 2016 - 11:25 AM

Trying to get anything to appear on the screen.  When I hit the power button the "M" and "back" led's light up at the bottom and go off within seconds.  If I hold the power button the led's stay lit and you can see a wave of light go from top to bottom but nothing ever comes on the screen then the led's go out when I let go of the power button.  I've tried pressing the power and home buttons at the same time but nothing happens except for the wave of light.  I've pressed the reset button as well with nothing happening.  Is this a screen issue?  Any ideas?






BC AdBot (Login to Remove)



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users