Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 File Explorer Desktop Shortcut Icon Broken.


  • Please log in to reply
24 replies to this topic

#1 Robo11

Robo11

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 21 January 2016 - 11:09 PM

Hello. So the desktop shortcut icon, in the Quick access area of File Explorer is broke for me. Instead of showing the icon of the desktop, its displaying as the default folder icon. I first noticed this about two weeks ago, and while not being a big issue, its been bugging me  :angry: .

 

So far, I've tried the following to fix this: System File Checker - didn't find any corrupted filed; Reset icon cache - didn't fix it; Reset thumbnail cache - didn't fix it;

 

I have no idea what caused this, and I can't seem to find a fix online. I've attached a screenshot of the problem. Thanks for your help.

Attached Files



BC AdBot (Login to Remove)

 


#2 PuReinSAniTY

PuReinSAniTY

  • Members
  • 432 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:in a basement
  • Local time:04:29 PM

Posted 22 January 2016 - 12:17 AM

Try making a new desktop shortcut with the image you want, and then cutting the faulty icon and then replace it with the new shortcut.


they call me te java mayster


#3 Robo11

Robo11
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 22 January 2016 - 02:52 AM

Try making a new desktop shortcut with the image you want, and then cutting the faulty icon and then replace it with the new shortcut.

Still the same issue. I tried removing the shortcut from quick access, then going to my Personal/User folder, and pinning the Desktop folder to Quick access again; but the default folder icon returns. However, this did give me some more insight on the problem. The actual Desktop folder itself has the broken icon, not just the shortcut (instead of the folder icon having a picture of a desktop in the bottom right, its just a plain folder).



#4 PuReinSAniTY

PuReinSAniTY

  • Members
  • 432 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:in a basement
  • Local time:04:29 PM

Posted 22 January 2016 - 03:16 AM

so what your saying is that the icon in itself is broken?


they call me te java mayster


#5 Robo11

Robo11
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 22 January 2016 - 03:38 AM

so what your saying is that the icon in itself is broken?



Sorry, I apparently didn't make the issue vary clear; I'll attempt to sum it up. The icon of the Desktop Folder (located in your user folder, alongside your documents folder, pictures folder, etc.) is not displaying its specialized icon (the default), and is instead displaying the generic folder icon.

#6 PuReinSAniTY

PuReinSAniTY

  • Members
  • 432 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:in a basement
  • Local time:04:29 PM

Posted 22 January 2016 - 03:42 AM

Well...This could be an intended feature as this shouldn't happen normally, wish I could help you :/


they call me te java mayster


#7 Robo11

Robo11
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 22 January 2016 - 04:10 AM

Well...This could be an intended feature as this shouldn't happen normally, wish I could help you :/


I'm sure this isn't an intended feature; I have two other systems that have the correct icon. But that's alright, it's not a big issue. Thankyou for trying to help.

#8 PuReinSAniTY

PuReinSAniTY

  • Members
  • 432 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:in a basement
  • Local time:04:29 PM

Posted 22 January 2016 - 04:16 AM

sorry that i couldn't be of more assistance.


they call me te java mayster


#9 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:09:59 AM

Posted 22 January 2016 - 07:42 AM

Desktop.ini file for Desktop folder could be missing or corrupted. Desktop.ini files control things like the icon used for that folder and its localized name. The Desktop.ini files aren't always visible and most Windows users never see them. However, if you've set Windows to display both hidden and protected files, they will show up on your Desktop. Opening the Folder Options window can be done in many ways. Open the Control Panel and go to "Appearance and Personalization -> Folder Options". In the Advanced settings section of the View tab, check "Show hidden files, folder, or drives" and uncheck "Hide protected operating system files". When done, click OK button. Navigate to "C:\Users\Your Username\Desktop" folder and replace the Desktop.ini file within Desktop folder with Desktop.ini file i uploaded. Open Command Prompt as a administrator and type Cd %userprofile%\Desktop press Enter key. Type Attrib +h +s Desktop.ini  press Enter key. Clear icon cache with  batch file i uploaded make sure to save and close all programs as you will need to restart your computer. After you restart your computer Desktop folder should be restored to its original icon.


Edited by FreeBooter, 22 January 2016 - 07:52 AM.

Posted Image


#10 Robo11

Robo11
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 22 January 2016 - 04:25 PM

Desktop.ini file for Desktop folder could be missing or corrupted. Desktop.ini files control things like the icon used for that folder and its localized name. The Desktop.ini files aren't always visible and most Windows users never see them. However, if you've set Windows to display both hidden and protected files, they will show up on your Desktop. Opening the Folder Options window can be done in many ways. Open the Control Panel and go to "Appearance and Personalization -> Folder Options". In the Advanced settings section of the View tab, check "Show hidden files, folder, or drives" and uncheck "Hide protected operating system files". When done, click OK button. Navigate to "C:\Users\Your Username\Desktop" folder and replace the Desktop.ini file within Desktop folder with Desktop.ini file i uploaded. Open Command Prompt as a administrator and type Cd %userprofile%\Desktop press Enter key. Type Attrib +h +s Desktop.ini  press Enter key. Clear icon cache with  batch file i uploaded make sure to save and close all programs as you will need to restart your computer. After you restart your computer Desktop folder should be restored to its original icon.

 

Thanks for trying to help. However, after I do your steps, the icon remains the same. Thanks for trying though, it was worth a shot  :thumbup2:



#11 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:09:59 AM

Posted 22 January 2016 - 05:52 PM

Your very welcome, i'm not finnish yet lets start round two.
After deleting the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\explorer\Shell Icons registry key [/size]Windows system files icons restore to there default icon.[/size] [/size]But before deleting the Shell Icons key click File, choose Export and save the key to a REG file. [/size] If you have 64-bit Windows installed then delete HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\explorer\Shell Icons key as well.


Edited by FreeBooter, 22 January 2016 - 06:17 PM.

Posted Image


#12 Robo11

Robo11
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 23 January 2016 - 03:11 AM

Your very welcome, i'm not finnish yet lets start round two.
After deleting the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\explorer\Shell Icons registry key [/size]Windows system files icons restore to there default icon.[/size] [/size]But before deleting the Shell Icons key click File, choose Export and save the key to a REG file. [/size] If you have 64-bit Windows installed then delete HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\explorer\Shell Icons key as well.

 

There isn't a Shell Icons registry value in either location (I do have a 64-bit system).



#13 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:01:59 AM

Posted 23 January 2016 - 03:22 AM

Maybe you can try to re add the shortcut. Unpin the shortcut from quick access by right clicking it and selecting "unpin from quick access"

After that go to "My PC" and open that side menu up, right click the "desktop" shortcut and re add it by right clicking.

Of course I have no idea if the other icon was borked but this is worth a try


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

8spxh0-6.png


#14 Robo11

Robo11
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:U.S.
  • Local time:07:59 AM

Posted 23 January 2016 - 03:36 AM

Maybe you can try to re add the shortcut. Unpin the shortcut from quick access by right clicking it and selecting "unpin from quick access"
After that go to "My PC" and open that side menu up, right click the "desktop" shortcut and re add it by right clicking.
Of course I have no idea if the other icon was borked but this is worth a try


I've already tried that :-/. Oddly enough though, the icon under the This PC tab is fine.

#15 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:01:59 AM

Posted 23 January 2016 - 03:44 AM

Maybe you can try to re add the shortcut. Unpin the shortcut from quick access by right clicking it and selecting "unpin from quick access"
After that go to "My PC" and open that side menu up, right click the "desktop" shortcut and re add it by right clicking.
Of course I have no idea if the other icon was borked but this is worth a try


I've already tried that :-/. Oddly enough though, the icon under the This PC tab is fine.
huh weird

You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

8spxh0-6.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users