Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

IE 11 Install Issues


  • Please log in to reply
5 replies to this topic

#1 Quaechelm

Quaechelm

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:01:42 AM

Posted 03 December 2013 - 04:44 PM

Mod Edit:  Split from http://www.bleepingcomputer.com/forums/t/515456/windows-7-problem-installing-internet-explorer-11/page-0 - Hamluis.

 

I have been having a problem updating to IE 11 as well, not the same issue, but here it is:

http://www.bleepingcomputer.com/forums/t/516250/using-win-7-ie-11-wont-work/

 

I tried some of the things that people responded with here, but it's not the same problem, so it didn't sort me out.


Edited by hamluis, 20 January 2016 - 08:23 AM.


BC AdBot (Login to Remove)

 


#2 BluRayofDeath

BluRayofDeath

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:42 PM

Posted 09 January 2014 - 10:27 PM

We deploy IE 10 via SCCM 2007 and had the same issue so hopefully its the same for IE 11. The problem is caused by IE setup only allowing 10 seconds for the WMI query to finish, but WMI could take up 20 seconds to complete so it fails on a random number of machines. The next step taken by IE is to get the patch from the Internet and if your like most businesses the computer system account won't have proxy access to get out so the installation fails.

 

The fix or I should say workaround is to run the following script before the installation, which will then cache the result and will typically allow the IE install to complete as the query will for us anyway respond in about 5 seconds. We depoly this script about 5 minutes before the maintenance window for patch installation which opens at 11:00PM which gives us much better success. 

 

So if your a deploy unattended another way or manually just run the script before installation.

 

Hope that helps

 

On Error Resume Next 
strComputer = "." 
SET objWMIService = GETOBJECT("winmgmts:\\" & strComputer & "\root\cimv2") 
SET colItems = objWMIService.ExecQuery("Select HotFixID from Win32_QuickFixEngineering where HotFixID='KB2729094'") 
 
FOR EACH objItem in colItems 
Wscript.Echo objItem.HotFixID 
NEXT 
 
WSCRIPT.ECHO "DONE!" 
WSCRIPT.QUIT 
 


#3 MatthewKilt

MatthewKilt

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:42 AM

Posted 26 January 2014 - 06:53 AM

My little Windows 7 Starter Netbook had downloaded and tried to update Internet Explorer 11 about fifty times, always failing with the WMI error that can be seen in the log example.  I knew that WMI is a bit leaky so I restarted the WMI service and immediately tried the IE11 install interactively from Windows Update.  To my great surprise it worked.

 

I also checked the query that times out in the testing tool - wbemtest and it executed a bit faster after the restart of WMI.  Probably if I had just tried the update immediately after a system restart that would also have worked. 

 

Try it.  :clapping:



#4 Union_Thug

Union_Thug

    Bleeps with the fishes...


  • Members
  • 2,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is everything
  • Local time:04:42 AM

Posted 02 February 2014 - 07:06 PM

My little Windows 7 Starter Netbook had downloaded and tried to update Internet Explorer 11 about fifty times, always failing with the WMI error that can be seen in the log example.  I knew that WMI is a bit leaky so I restarted the WMI service and immediately tried the IE11 install interactively from Windows Update.  To my great surprise it worked.

 

I also checked the query that times out in the testing tool - wbemtest and it executed a bit faster after the restart of WMI.  Probably if I had just tried the update immediately after a system restart that would also have worked. 

 

Try it.  :clapping:

Good info, tyvm!



#5 barrtrek

barrtrek

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:42 AM

Posted 23 December 2015 - 03:22 PM

 

We deploy IE 10 via SCCM 2007 and had the same issue so hopefully its the same for IE 11. The problem is caused by IE setup only allowing 10 seconds for the WMI query to finish, but WMI could take up 20 seconds to complete so it fails on a random number of machines. The next step taken by IE is to get the patch from the Internet and if your like most businesses the computer system account won't have proxy access to get out so the installation fails.

 

The fix or I should say workaround is to run the following script before the installation, which will then cache the result and will typically allow the IE install to complete as the query will for us anyway respond in about 5 seconds. We depoly this script about 5 minutes before the maintenance window for patch installation which opens at 11:00PM which gives us much better success. 

 

So if your a deploy unattended another way or manually just run the script before installation.

 

Hope that helps

 

On Error Resume Next 
strComputer = "." 
SET objWMIService = GETOBJECT("winmgmts:\\" & strComputer & "\root\cimv2") 
SET colItems = objWMIService.ExecQuery("Select HotFixID from Win32_QuickFixEngineering where HotFixID='KB2729094'") 
 
FOR EACH objItem in colItems 
Wscript.Echo objItem.HotFixID 
NEXT 
 
WSCRIPT.ECHO "DONE!" 
WSCRIPT.QUIT 
 

 

This little bit of code saved me a ton of time.  We used it in our IE11 upgrade autoit script and no longer have issues with the install!  Thanks BluRayofDeath!!



#6 Ben1989

Ben1989

  • Members
  • 2 posts
  • OFFLINE
  •  

Posted 07 January 2016 - 04:36 AM

I find the solution with screenshots. I hope it can help you easy to understand and fix the IE 9C47 issue.http://www.sthshare.com/wordpress/how-to-fix-internet-explorer-11-error-code-9c47.html


Edited by Ben1989, 07 January 2016 - 04:37 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users