Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

FireFox clogs very quickly


  • Please log in to reply
13 replies to this topic

#1 bsloan1960

bsloan1960

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 19 January 2016 - 07:30 PM

Hi,

 

Folks. You know exactly what I'm going to say- and you already know the answers. But let me explain. I have a Toshiba Satellite laptop approx 2 years old. My preferred browser has always been FireFox.

 

First- The computer: For the first year when I started it it sprang to life instantly- I'd push the power button and in a matter of a couple of seconds I was signing onto my desktop. For the past year or so it now behaves like my desktops always did... push the button- listen to clicks and noises, after a minute the logo came up, etc.... about a 2 minute process. So- Why did I go from a 10 second startup to a 2 minute startup?

 

Now FireFox. After noticing that firefox was clogging up and bogging down and sometimes just grinding to a halt very quickly (15 minutes or so) I downloaded one of their add ons. Its a green dot that sits up at the top of the page that turns red when FF thinks the browser is getting too full. You hit the button- FF restarts- the button is green again and you're good for another 15 minutes. If you mouse over it it displays a number. When it was red that number was 520 mb. Once I came to this site the thing turned green by itself and the number is 481mb. I was on Face book simply typing replies to posts when it turned red. I usually have just one or 2 windows open.

 

I spent all day reading "How do I fix slow Firefox" posts on the Mozilla page- there are a lot of them. Numerous suggestions were given ranging from disabling some sort of "acceleration" whose default is always active, getting rid of add ons, tweaks to about:config, and on and on. I have opened the task manager 100 times to see what is running. most of it is turned off, and those that are turned on say they are using very little resources. By the way I checked the CPU setting and it showed a spike to 100 from a few minutes earlier.

 

Sorry for the long post- I believe in answering questions before they are asked to keep the ball rolling. Any thing you tell me to do can not be in general terms- I must know exactly what to do and where to do it because generalized talk about computers is Greek to me.

 

Thank You!!!!!!!!!!!!!!!!!!!!!!!! 



BC AdBot (Login to Remove)

 


#2 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 20 January 2016 - 09:39 AM

How much memory is Firefox using when it's in Safe Mode (all extensions and plugins disabled), compared with when it's in Normal Mode? The amount of memory Firefox seems to be using on your computer seems pretty standard to me.

 

How to Start Firefox in Safe Mode



#3 bsloan1960

bsloan1960
  • Topic Starter

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 20 January 2016 - 01:10 PM

OK. Cleared cache, etc. Restarted in safe mode with all add on s disabled. You told me to check the memory- but as I said I need to be told exactly how to do things- all I knew was to open the Task Manager and look under the Memory tab. That figure was 29%. What's next?

 

You said what I described seemed normal. The experiences I described in my initial post are no where near the normal I was experiencing. I could use some information on why my laptop went from a 10 second open to desk top to 2 minutes and when firefox went from clogging up in 45 minutes to 15 minutes.

 

Thanks



#4 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 20 January 2016 - 01:50 PM

You didn't say what was your operating system. Windows XP, Vista, 7, 8, 10?

 

As for memory, in the task manager, instead of looking at the CPU, what's the memory usage for the firefox.exe process?

 

j1sOITK.png

 

 

It's normal for WIndows to take more time to load 2 years later. That's because you've installed programs. Programs are also getting more and more resource-hungry. You may also have too many programs loading with Windows. Many programs, if not most, have the bad habit of adding themselves to the Startup directory, even without asking. Some do need to be there, like your antivirus or firewall for instance. But most don't need to. And that inevitably slows down startup.

 

As for Firefox, the more tabs are open, and the more you have add-ons, the more it uses memory. In Firefox Safe Mode, you're running without the add-ons.


Edited by Phantom010, 20 January 2016 - 01:51 PM.


#5 bsloan1960

bsloan1960
  • Topic Starter

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 20 January 2016 - 04:41 PM

Thanks for staying with me. Here is what I got in FireFox Safe Mode right after I started the browser. (plus I found what kind of specs are installed in the computer and have them listed here in case it helps. (I have Windows 10- and it just occurred to me that since installing Win 10 this crap may have stared to happen- can't be sure though.)

 

Task Manager:

 

firefox (32 bit ... cpu- 1.6 ... memory- 145.2mb ... disc- omb/s ... network- 0mbps
''''''''''''''''''''''''''''''''''''''''''''''''''''''

Stuff about my system

 

Processor: Intel® Core i3-3120 cpu @ 2.50 GHz
Installed Memory (RAM) 6.00 GB (5.88 usable)
System  type: 64-bit Operating, x64- based processor
Pen and touch: No Pen or Touch is available for this Display
 



#6 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 20 January 2016 - 04:51 PM

In Safe Mode, Firefox is only using 145 MB of memory on your computer.

 

 

Please type about:support in the Firefox address bar.

Press Enter.

Click Copy text to clipboard.

Paste the entire content into Notepad and upload the file HERE.

 

 

1- Browse to the location of your file (like the desktop). Select your text file.

 

4sEfTzD.png

 

 

2- Upload the file.

 

9doSpYO.png

 

A link will be created for us to download the file. Please copy/paste the link into your next reply.


Edited by Phantom010, 20 January 2016 - 04:52 PM.


#7 bsloan1960

bsloan1960
  • Topic Starter

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 20 January 2016 - 05:02 PM

OK- Here is the Link:

 

http://www106.zippyshare.com/v/W46IAAMg/file.html

 

(BTW) I noticed when I went to clean the cache before restarting in safe Mode the Cache read.... 0

The setting right underneath that one was set at ...0

 

Just in case this info help


Edited by bsloan1960, 20 January 2016 - 05:06 PM.


#8 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 20 January 2016 - 05:13 PM

The report was generated while you were in Safe Mode. Just a reminder to let you know you cannot run Firefox in Safe Mode indefinitely. Otherwise, no add-ons will work.

 

You don't have many add-ons either. So, there's not much you can do to make Firefox use less memory than that. I wouldn't worry about it though. It's not using that much memory even with the add-ons enabled.

 

I tried the many tweaks available on the Internet claiming to speed up Firefox. Sadly, none of them make a significant difference.

 

You may want to add the Adblock Plus extension. It will cut down on a lot of clutter (ads) on websites, making browsing faster, and safer.


Edited by Phantom010, 20 January 2016 - 05:24 PM.


#9 bsloan1960

bsloan1960
  • Topic Starter

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 20 January 2016 - 05:29 PM

OK- Thanks so much.

 

Is the cache being set at 0 OK?



#10 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 20 January 2016 - 05:32 PM

Is the cache being set at 0 OK?

 

Actually no. Cache is there to help speed up browsing. It keeps information about the websites you visit, so every time you go back, they can load a lot faster.



#11 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 21 January 2016 - 04:40 PM

Just thought of this.

 

When you're saying "Is the cache being set at 0 OK?", which of these are you referring to as set at 0? 1 or 2?

 

If it's 1, it means you've cleared the cache completely. If it's 2, the default is 350.

 

And the "Override automatic cache management" box shouldn't be selected.

 

RtyHQQH.png


Edited by Phantom010, 21 January 2016 - 04:40 PM.


#12 bsloan1960

bsloan1960
  • Topic Starter

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 21 January 2016 - 05:40 PM

Thanks. The zero was as you guessed. and i just unchecked the override on the 2nd one.



#13 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 21 January 2016 - 10:01 PM

Thanks. The zero was as you guessed. and i just unchecked the override on the 2nd one.

 

Yup. Noticed that after asking the question. It was showing in the about:support report from post #7:

 

WfbjtVS.png

 

:)



#14 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:12 AM

Posted 03 February 2016 - 10:36 AM

A couple more tricks to reduce Firefox's memory usage:

 

http://www.trishtech.com/2015/12/how-to-quickly-free-up-memory-claimed-by-firefox/

 

https://addons.mozilla.org/firefox/addon/free-memory-button/

 

http://lifehacker.com/5161563/prevent-firefox-from-hogging-memory-when-minimized

 

https://addons.mozilla.org/firefox/addon/memory-fox-next/

 

You can also disable the Adobe Flash Player (Shockwave Flash) plugin until you need it again.


Edited by Phantom010, 04 February 2016 - 09:49 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users