Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Samba Share


  • Please log in to reply
17 replies to this topic

#1 DefaultGateway

DefaultGateway

  • Members
  • 187 posts
  • OFFLINE
  •  
  • Local time:11:12 AM

Posted 17 January 2016 - 05:53 AM

From my Windows OS, I can't access my Samba Share.

If I do \\[IP Address of Server]\[Full Path of Samba Share] it won't work.



BC AdBot (Login to Remove)

 


#2 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:12 AM

Posted 18 January 2016 - 09:13 AM

You should only have to do

\\192.168.1.1\share

Of course substituting the "192.168.1.1" for your server IP. 


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#3 DefaultGateway

DefaultGateway
  • Topic Starter

  • Members
  • 187 posts
  • OFFLINE
  •  
  • Local time:11:12 AM

Posted 19 January 2016 - 07:21 AM

Thank you for replying.

I think some network settings aren't correct, and it would be a hassle to post many information like IP addresses.

So I'll think I am going to ask my teacher.

 

Cheers,

DefaultGateway



#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:12 AM

Posted 19 January 2016 - 09:16 AM

Post your samba share config file, something in there could be wrong as well.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#5 DefaultGateway

DefaultGateway
  • Topic Starter

  • Members
  • 187 posts
  • OFFLINE
  •  
  • Local time:11:12 AM

Posted 26 January 2016 - 04:37 PM

Sorry, but I still need help with this.

With the command "sudo testparm", I checked my Samba Config File.

There are no errors.

 

My Samba Server = VM

My Client = VM

My Host OS = not VM

 

I can access Samba Server from Client.

But I can't access Samba Server from Host OS.



#6 Guest_GNULINUX_*

Guest_GNULINUX_*

  • Guests
  • OFFLINE
  •  

Posted 26 January 2016 - 05:34 PM

...

My Samba Server = VM

My Client = VM

My Host OS = not VM

 

I can access Samba Server from Client.

But I can't access Samba Server from Host OS.

Are all systems on the same (192. vs 10.) subnet?  :wink:

 

Greets!



#7 DefaultGateway

DefaultGateway
  • Topic Starter

  • Members
  • 187 posts
  • OFFLINE
  •  

Posted 27 January 2016 - 03:31 AM

Thank you for replying.

 

Both the Client and the Samba Server is on the 172.16.0.0 network.

My Host OS is at 192.168.2.0 network.



#8 Guest_GNULINUX_*

Guest_GNULINUX_*

  • Guests
  • OFFLINE
  •  

Posted 27 January 2016 - 04:14 AM

I don't know what VM-software you use but change the VM connection to "bridged connection" so they all are on the same (192.) internal network. Recreate the share(s), this might not be necessary but do it anyway to be sure, and give it another try.
 
Use the command DeimosChaos suggested to connect!  :wink:
Make sure your firewall doesn't block the connection, you could disable it just for testing...
 
Greets!



#9 DefaultGateway

DefaultGateway
  • Topic Starter

  • Members
  • 187 posts
  • OFFLINE
  •  
  • Local time:11:12 AM

Posted 27 January 2016 - 07:14 AM

Thank you for your reply again. :)

By setting it to "Bridged Connection", it works, I can access the Samba Server from Windows OS.

But can it also work if I don't use "Bridge Connection"?



#10 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware

Posted 27 January 2016 - 08:09 AM

I believe you have to keep it on the bridged connection setting. Though you if you take it off the bridged connection, you could try and manually set the IP addresses so they are all on the same network, and see if that works.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#11 DefaultGateway

DefaultGateway
  • Topic Starter

  • Members
  • 187 posts
  • OFFLINE
  •  
  • Local time:11:12 AM

Posted 27 January 2016 - 08:34 AM

Thanks for replying.

What I mean is, if the Samba Server and the Host OS are purposely not on the same network, how can I get the Host OS to be able to Access the Samba Server? :wink:



#12 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:12 AM

Posted 27 January 2016 - 09:16 AM

Ah, got you.

That is kind of the purpose of separate networks... to keep things separate. I can't think of any way to let them access each other. You would need a firewall, or switch type device that works with VLANs and allows you to set up ACL rules. In other words, just keep them on the same network. :)

 

*edit*

 

Or I guess in your case, not physical hardware, but some kind of virtual type of hardware since you are on the same host PC for all of this.


Edited by DeimosChaos, 27 January 2016 - 09:19 AM.

OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#13 Guest_GNULINUX_*

Guest_GNULINUX_*

  • Guests
  • OFFLINE
  •  

Posted 27 January 2016 - 09:30 AM

You understand that if you make the Samba Shares accessible from other networks the whole world can access them!

 

The Samba Sharing protocol is not encrypted so running it over a VPN/Tunnel and password protecting and/or restricting user access is a must...

 

Carefully read this and this before you decide!  :wink:

 

Tip: You realize that you can achieve the same (and much safer) by just syncing a folder to a cloud service?

 

Greets!



#14 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:11:12 AM

Posted 27 January 2016 - 11:31 AM

You understand that if you make the Samba Shares accessible from other networks the whole world can access them!

 

The Samba Sharing protocol is not encrypted so running it over a VPN/Tunnel and password protecting and/or restricting user access is a must...

 

Carefully read this and this before you decide!  :wink:

 

Tip: You realize that you can achieve the same (and much safer) by just syncing a folder to a cloud service?

 

Greets!

I feel like one doesn't need to go to that extreme to have two networks on separate domains (but physically on the same network) talk to each other. I don't have an answer. But like you said opening ports to the world is always risky and can be a pretty bad idea.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#15 Guest_GNULINUX_*

Guest_GNULINUX_*

  • Guests
  • OFFLINE
  •  

Posted 27 January 2016 - 12:47 PM

DeimosChaos

Security is always personal but I take it very serious and I'm not going to advice otherwise...

 

DefaultGateway

Just use bridged connection or the cloud syncing solution, they are the most safe and most simple solutions.  :wink:

 

Greets!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users