Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


.NET 4.5.2 install fails - Windows Installer Service error

  • Please log in to reply
1 reply to this topic

#1 LynnBR


  • Members
  • 104 posts
  • Gender:Female
  • Local time:12:20 AM

Posted 14 January 2016 - 12:44 PM

Computer is running Win7 Pro SP1, 64 bit.


MS .NET updates have been failing since June 2015 with error Code 656.


1) Tried .NET repair, updates fail.

2) Tried installing updates after clean boot. Updates fail.

3) Uninstalled .NET 4.5.2 using MS utility (through Control Panel, Uninstall)

4) attempted to reinstall 4.5.2 using downloaded offline installer, got error "The Windows Installer Service could not be accessed".

5) ran a registry edit to fix Windows Installer as found on MS website, still cannot install.

6) ran .NET cleanup tool from MSDN

7) reregistered msiexec for 64 bit, 4 commands.

8) tried reinstall using web installer

 (all work done under administrative network login).

Also tried reinstall when logged in as local system administrator, same error.


I still get "Windows Installer Service cannot be accessed" error when trying to reinstall .NET Framework 4.5.2.


I do have the option to revert to restore point and get back to where this computer was before all this started.






BC AdBot (Login to Remove)



#2 LynnBR

  • Topic Starter

  • Members
  • 104 posts
  • Gender:Female
  • Local time:12:20 AM

Posted 08 February 2016 - 10:49 AM

I had to use System Restore to revert as person returned from vacation and needed to use .NET.


I see that many have viewed this post but no one has replied. Any suggestions welcome, and Thanks!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users