Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Why is "ServiceHost:RemoteProcedure" using most of my memory?


  • Please log in to reply
1 reply to this topic

#1 MaraSweets

MaraSweets

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:56 PM

Posted 11 January 2016 - 05:16 PM

I'm asking this question on behalf of my daughter.  She is using Win 8 and is finding that the process Service Host:Remote Procedure (it is NOT abbreviated like the other svc's are) is using about 80% of her memory and she can barely doing anything with her computer.  When she first starts up her computer it seems ok but very quickly becomes so slow it takes forever to execute a command.

 

Here is the screen shots she sent me.  (I don't know if the top one was in error and the bottom one is correcting it, or if they both apply, as she had to run off to work.)

 

Can you help her with this information, please?

 

 

Attached Files



BC AdBot (Login to Remove)

 


#2 jcgriff2

jcgriff2

  • BSOD Kernel Dump Expert
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey Shore
  • Local time:10:56 PM

Posted 11 January 2016 - 09:22 PM

Hi. . .

 

The highlighted "ServiceHost:RemoteProcedure" in your screenshot is listed as using 4.4 MB of memory - one of the lowest memory consumers listed.

 

Total memory currently being used in the screenshot is listed at 60%. 

 

Given this info, why do you believe that "ServiceHost:RemoteProcedure" is using 80% of RAM and why do you believe it is the cause of the system slowness?

 

I would suggest looking at start-up apps -- disable those not needed. 

 

Use SysInternals AutoRuns.  Download AutoRuns from Microsoft Technet to Desktop; RIGHT-click on autoruns.exe, select "Run as Administrator".  Click on "Logon" tab. To disable an item, un-check the box to the left.

 

https://technet.microsoft.com/en-us/sysinternals/bb963902

 

Regards. . .

 

jcgriff2


Edited by jcgriff2, 11 January 2016 - 09:23 PM.

Microsoft MVP 2009-2015
Microsoft Windows Insider MVP 2018 - Present




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users