Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help using Microsoft PnP Utility to install scanner driver


  • Please log in to reply
2 replies to this topic

#1 EB127

EB127

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:00 AM

Posted 09 January 2016 - 09:58 PM

I recently bought a secondhand hp scanner, a HP scanjet 5200C. It was produced in the 90s or early 2000s, but I thought I would surely find a driver for it for my laptop running windows 8. When I looked into it, HP has clearly said that they no longer make a driver for the newer versions of windows. So, I tried to install a general scanner driver software that supports this scanner. Problem is, it's a series of INF files. I opened command prompt as administrator, and tried installing the inf using the "PnPUtil -a" command but it failed to add the driver package. The command prompt goes: 

 

 

 

C:\>PnPUtil -a c:\users\Admin\downloads\newfold\scanner.inf

Microsoft PnP Utility

 

Adding the driver package failed : Invalid INF passed as parameter.

 

Total attempted:                           0

Number successfully imported:    0

 

 

 

 

 

the general scanner driver is from this url : http://www.driverscape.com/download/hp-scanjet-5200c, the download link on the bottom left side of the page. I will also attatch it to this post here: Attached File  489769da1af87b22e8fb09438dc3b733.zip   43.82KB   0 downloads

 

If anyone could help, it would be greatly appreciated. With either installing the scanner driver, or with another driver for that scanner. Thank you!


Edited by EB127, 09 January 2016 - 10:00 PM.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:00 AM

Posted 10 January 2016 - 10:20 AM

http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c03477149


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 jcgriff2

jcgriff2

  • BSOD Kernel Dump Expert
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey Shore
  • Local time:07:00 AM

Posted 11 January 2016 - 01:44 AM

Did you try just running the EXE that you downloaded with Admin perms?

 

You provided this link in post #1 --> http://www.driverscape.com/download/hp-scanjet-5200c

 

It lists Windows 8.1 as a supported OS.

 

Clicking on "download" downloads a file called DriverToolkitInstaller.exe

 

RIGHT-click on DriverToolkitInstaller.exe, select "Run as Administrator"

 

However, going to the HP Support page for the HP Scanjet 5200C shows XP x86 as the last supported OS - http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?cc=us&lc=en&product=61254

 

Regards. . .

 

jcgriff2


Microsoft MVP 2009-2015
Microsoft Windows Insider MVP 2018 - Present




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users