Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SumatraPDF not registering as default PDF reader


  • Please log in to reply
5 replies to this topic

#1 Sintharius

Sintharius

    Bleepin' Sniper


  • Members
  • 5,639 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:The Netherlands
  • Local time:01:32 AM

Posted 09 January 2016 - 05:17 PM

So I decided to switch from Foxit Reader to SumatraPDF for reading pdf files - but Sumatra did not register as the default program for pdfs. I have to open Sumatra, then navigate to the file I need to read instead of directly launching the reader via the file.

Does anyone have a solution for this?

I'm on Windows 7 Ultimate x64, using the latest installed version of SumatraPDF.

BC AdBot (Login to Remove)

 


#2 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,696 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:32 PM

Posted 09 January 2016 - 05:24 PM

Right-click on the PDF, select Open with... then Choose a program from the list. Select SumatraPDF in the list, if it isn't, click on Browse then navigate to it's executable and select it. Also, make sure to check the box below that says something along the lines of Always use that program to open this type of file.

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#3 Sintharius

Sintharius

    Bleepin' Sniper

  • Topic Starter

  • Members
  • 5,639 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:The Netherlands
  • Local time:01:32 AM

Posted 09 January 2016 - 05:28 PM

Tried that, did not work. :ph34r:

#4 JohnC_21

JohnC_21

  • Members
  • 24,613 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:07:32 PM

Posted 09 January 2016 - 05:59 PM

Open a command prompt.

assoc .pdf

What is the output?

 

In the following registry key is Sumatra listed in both sub-keys?

 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.pdf\

 

Have you tried a reinstall?


Edited by JohnC_21, 09 January 2016 - 06:00 PM.


#5 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,696 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:32 PM

Posted 09 January 2016 - 06:00 PM

You could manually associate SumatraPDF to PDF files via the Control Panel, under Program and Features.

http://www.thewindowsclub.com/change-file-associations-windows

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#6 Sintharius

Sintharius

    Bleepin' Sniper

  • Topic Starter

  • Members
  • 5,639 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:The Netherlands
  • Local time:01:32 AM

Posted 10 January 2016 - 07:23 AM

I just realized that by default SumatraPDF does not assign itself as the default PDF reader. A reinstallation of Sumatra with "Use SumatraPDF as the default PDF reader" checked in Options before installation worked.

Thanks for the help though :hug:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users