Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Roguekiller found 1 PUP and 4 PUM.Dns


  • This topic is locked This topic is locked
7 replies to this topic

#1 Miikka1

Miikka1

  • Members
  • 4 posts
  • OFFLINE
  •  

Posted 07 January 2016 - 11:59 AM

Hello! Today i started to scan my computer with next programs, just to be sure that my computer is clean as always:
 

1.   Rkill
2.   Malwarebytes Antirootkit
3    TDSSkiller 
4.   ADWCleaner
5.   CCleaner
6.   Malwarebytes Anti-Malware
7 .  Hitman pro
8.   Super ANTI-spyware
9.   Avira
10. Roguekiller
 

Everything was clean, logs were clean and nothing was found, only cookies etc. in CCleaner. Then i run Roguekiller and it found next objects:

 

RogueKiller V11.0.6.0 [Jan  4 2016] (Free) by Adlice Software
 
Operating System : Windows 10 (10.0.10586) 64 bits version
Started in : Normal mode
User : (i deleted this) [Administrator]
Started from : C:\Security kamaa\RogueKiller.exe
Mode : Scan -- Date : 01/07/2016 18:04:34
 
¤¤¤ Processes : 0 ¤¤¤
 
¤¤¤ Registry : 5 ¤¤¤
[PUP] (X64) HKEY_LOCAL_MACHINE\Software\Partner -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\ControlSet001\Services\Tcpip\Parameters | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{6677ce2b-2eba-4832-8106-7369befe2a03} | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\ControlSet001\Services\Tcpip\Parameters\Interfaces\{6677ce2b-2eba-4832-8106-7369befe2a03} | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
 
¤¤¤ Tasks : 0 ¤¤¤
 
¤¤¤ Files : 0 ¤¤¤
 
¤¤¤ Hosts File : 0 ¤¤¤
 
¤¤¤ Antirootkit : 0 (Driver: Not loaded [0xc000036b]) ¤¤¤
 
¤¤¤ Web browsers : 0 ¤¤¤
 
¤¤¤ MBR Check : ¤¤¤
+++++ PhysicalDrive0: Crucial_CT256MX100SSD1 +++++
--- User ---
[MBR] e45f32c11933c48ebf0e4eff73e95168
[BSP] 8a06798a6c7d9561a48fade1f937e8f5 : Windows Vista/7/8|VT.Unknown MBR Code
Partition table:
0 - [ACTIVE] NTFS (0x7) [VISIBLE] Offset (sectors): 2048 | Size: 500 MB [Windows Vista/7/8 Bootstrap | Windows Vista/7/8 Bootloader]
1 - [XXXXXX] NTFS (0x7) [VISIBLE] Offset (sectors): 1026048 | Size: 243696 MB [Windows Vista/7/8 Bootstrap | Windows Vista/7/8 Bootloader]
User = LL1 ... OK
User = LL2 ... OK

 

 

I didn't delete anything yet if those are false positive detections, My computer is doing fine and this Windows 10 is only 3 months old, i just want to know what these objects are and why RK is only program that detects them.

PS: 62.241.198.246 62.241.198.245 <----- that is my current internet address ( DNA, Finland) and i use Avira atm.

I hope you see this fast as possible :) ty.

 

Edit: FRST. logs attached.

Attached Files


Edited by Miikka1, 07 January 2016 - 12:47 PM.


BC AdBot (Login to Remove)

 


#2 nasdaq

nasdaq

  • Malware Response Team
  • 38,925 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:07:33 PM

Posted 08 January 2016 - 10:56 AM

Hello, Welcome to BleepingComputer.
I'm nasdaq and will be helping you.

If you can please print this topic it will make it easier for you to follow the instructions and complete all of the necessary steps in the order listed.
===

Press the windows key Windows_Logo_key.gif+ r on your keyboard at the same time. This will open the RUN BOX.
Type Notepad and and click the OK key.
Please copy the entire contents of the code box below to the a new file.
 
start

CreateRestorePoint:
EmptyTemp:
CloseProcesses:

HKLM\...\Run: [hola] => C:\Program Files\Hola\app\hola.exe --silent
ShellIconOverlayIdentifiers: [00avast] -> {472083B0-C522-11CF-8763-00608CC02F24} =>  No File
FF Plugin HKU\.DEFAULT: @hola.org/FlashPlayer -> C:\Users\Kynis\AppData\Local\Hola\firefox_hola\app\flash\NPSWF32_18_0_0_232.dll [No File]
FF Plugin HKU\.DEFAULT: @hola.org/vlc -> C:\Users\Kynis\AppData\Local\Hola\firefox_hola\app\vlc\npvlc.dll [No File]
C:\Program Files\Hola

End
Save the file as fixlist.txt in the same folder where the Farbar tool is running from.
The location is listed in the 3rd line of the Farbar log you have submitted.

Run FRST and click Fix only once and wait.

Restart the computer normally to reset the registry.

The tool will create a log (Fixlog.txt) please post it to your reply.
===

Please download AdwCleaner by Xplode onto your Desktop.
  • Close all open programs and internet browsers.
  • Double click on AdwCleaner.exe to run the tool.
  • Click the Scan button and wait for the process to complete.
  • Click the LogFile button and the report will open in Notepad.
IMPORTANT
  • If you click the Clean button all items listed in the report will be removed.
If you find some false positive items or programs that you wish to keep, Close the AdwCleaner windows.
  • Close all open programs and internet browsers.
  • Double click on AdwCleaner.exe to run the tool.
  • Click the Scan button and wait for the process to complete.
  • Check off the element(s) you wish to keep.
  • Click on the Clean button follow the prompts.
  • A log file will automatically open after the scan has finished.
  • Please post the content of that log file with your next answer.
  • You can find the log file at C:\AdwCleanerCx.txt (x is a number).
===

Any remaining issues?

#3 Miikka1

Miikka1
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  

Posted 08 January 2016 - 02:01 PM

Ok there is Fixlog.txt and Adwcleaner log files attached.

Then I disabled Avira and used next programs again(All log files attached):

1. Rogue killer:

 

Same 5 objects detected, i think those PUM.Dns files are just my own internet but what is that "[PUP] (X64) HKEY_LOCAL_MACHINE\Software\Partner -> Found" ?
 

¤¤¤ Registry : 5 ¤¤¤
[PUP] (X64) HKEY_LOCAL_MACHINE\Software\Partner -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\ControlSet001\Services\Tcpip\Parameters | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{6677ce2b-2eba-4832-8106-7369befe2a03} | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
[PUM.Dns] (X64) HKEY_LOCAL_MACHINE\System\ControlSet001\Services\Tcpip\Parameters\Interfaces\{6677ce2b-2eba-4832-8106-7369befe2a03} | DhcpNameServer : 62.241.198.246 62.241.198.245 ([-][X])  -> Found
 
2. Rkill:
 
It found those same [Missing Service] objects like always since windows 10 installation, i guess those are nothing?
 
 
 * fcvsc [Missing Service]
 * HyperVideo [Missing Service]
 * netvsc [Missing Service]
 * wfpcapture [Missing Service]
 
 * CompositeBus => \SystemRoot\System32\DriverStore\FileRepository\compositebus.inf_amd64_912dfdedc3d2f520\CompositeBus.sys [Incorrect ImagePath]
 * NgcSvc => %SystemRoot%\system32\svchost.exe -k LocalSystemNetworkRestricted [Incorrect ImagePath]
 * swenum => \SystemRoot\System32\drivers\swenum.sys [Incorrect ImagePath]
 
3. TDSSKiller
 
4. Hitman Pro:
 
Detected "C:\Security kamaa\FRST64.exe" so that is false positive

5. Malwarebytes Anti-Malware
 
6. Avira
 
PC is working fine, Avira and Windows Firewall are enabled, what i need to next?
 
 
 

 

Attached Files



#4 nasdaq

nasdaq

  • Malware Response Team
  • 38,925 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:07:33 PM

Posted 08 January 2016 - 02:37 PM

Run the RogueKiller tool and delete only this.
 

[PUP] (X64) HKEY_LOCAL_MACHINE\Software\Partner -> Found


===
 

fcvsc [Missing Service]
http://www.systemlookup.com/search.php?type=name&client=malwaresearch-chrome&search=fcvsc
===

HyperVideo [Missing Service]
http://www.systemlookup.com/search.php?type=name&client=malwaresearch-chrome&search=HyperVideo
===

netvsc [Missing Service]
http://www.systemlookup.com/search.php?type=name&client=malwaresearch-chrome&search=netvsc
===

wfpcapture [Missing Service]
http://www.systemlookup.com/search.php?type=name&client=malwaresearch-chrome&search=wfpcapture
===

If all is well then these are not installed and not required.


CompositeBus => \SystemRoot\System32\DriverStore\FileRepository\compositebus.inf_amd64_912dfdedc3d2f520\CompositeBus.sys [Incorrect ImagePath]
http://www.herdprotect.com/compositebus.sys-804913ab09357667efc976069713279728249dfe.aspx
===

NgcSvc => %SystemRoot%\system32\svchost.exe -k LocalSystemNetworkRestricted [Incorrect ImagePath]
http://systemexplorer.net/file-database/file/ngcsvc-dll
===

swenum => \SystemRoot\System32\drivers\swenum.sys [Incorrect ImagePath]
http://www.systemlookup.com/contribute/editlist.php?list=12&item=7479
===

These files are normally in the \Windows\System32\drivers\ or the Windows\System32 folder.

If you want to check further run this Farbar search.

Please run the Farbar Recovery Scan Tool. Enter CompositeBus;NgcSvc.sys;swenum.sys in the Search Box and hit the File Search button.
Post the content of the Search.txt in your next reply.

The operating system may be able to find these drivers even if the path is not correct.

#5 Miikka1

Miikka1
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  

Posted 08 January 2016 - 03:22 PM

I scanned with Roguekiller and deleted [PUP] (X64) HKEY_LOCAL_MACHINE\Software\Partner

Restarted my computer and scanned again, only 4 PUM.Dns objects found. Log file attached.

 

I also runned FRST with CompositeBus;NgcSvc.sys;swenum.sys file search, log file attached.

 

 

My computer seems clean now? Was there any malicious files or registry keys at all? Thank you for very fast replies also, i really appreciate that. :)

Attached Files



#6 nasdaq

nasdaq

  • Malware Response Team
  • 38,925 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:07:33 PM

Posted 09 January 2016 - 07:53 AM



Windows 10 was installed correctly. If all is well will leave it at that.

To learn more about how to protect yourself while on the internet read this little guide best security practices keep safe.
http://www.bleepingcomputer.com/forums/t/407147/answers-to-common-security-questions-best-practices/
===

#7 Miikka1

Miikka1
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  

Posted 09 January 2016 - 10:47 AM

Ok, thank you :)



#8 nasdaq

nasdaq

  • Malware Response Team
  • 38,925 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:07:33 PM

Posted 15 January 2016 - 11:06 AM

It appears that this issue is resolved, therefore I am closing the topic. If that is not the case and you need or wish to continue with this topic, please send me or any Moderator a Personal Message (PM) that you would like this topic re-opened.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users