Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Today C Drive showed up in Safely Remove Hardware


  • Please log in to reply
2 replies to this topic

#1 d2produce

d2produce

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:12:22 AM

Posted 05 January 2016 - 03:02 PM

I upgraded to windows 10 a few weeks ago and I've used harddrives and the safely remove hardware program a bunch of times.  SRH always disappears when I have no external HDD plugged in.  But just today my C drive and my internal 4gb sata drive are showing up as removable hardware.  What the heck is going on and how do I make it so that doesn't happen?



BC AdBot (Login to Remove)

 


#2 RolandJS

RolandJS

  • Members
  • 4,525 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:06:22 PM

Posted 05 January 2016 - 03:40 PM

Are you using any 3rd party utility that helps with Safe to Remove External Device?  Reason for asking:  I was trying a couple of such utilities and had to remove for the same reason.


Edited by RolandJS, 05 January 2016 - 03:40 PM.

"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#3 d2produce

d2produce
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:12:22 AM

Posted 05 January 2016 - 10:17 PM

It's funny you say that because I did temporarily install a Safe Removal tool made by the same people who make Unlocker and after uninstalling it Safe Remove was acting weird, not showing up when I would plug in drives.  It worked eventually and was working for a month or so and this just started happening.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users