Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 - wifi connects but no internet access - no internet, secured


  • Please log in to reply
58 replies to this topic

#1 dejavou42

dejavou42

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 12:17 PM

Hi all, I am having an issue with wifi on my laptop after upgrading to windows 10. Wifi worked perfectly before the upgrade.

 

Laptop model: dell inspiron 1090 (duo mini)

 

I can connect to ethernet (on docking station) just fine. When I connect to wifi, dhcp returns an ip address to the laptop, and wifi shows connected (no internet, secured). Pinging the router results in timeouts, as does google. wireshark shows tcp and udp packets on wifi. If I run windows network diagnostics the results vary from can't detect proxy settings to missing necessary protocols. 

 

If I connect to hotspot on iphone, and then connect to access point, wifi works for 15-20 min. then drops out again. It still shows connected, but again, I can't ping the router, and the connection shows no internet, secured. I have tried everything from resetting winsock, ip stack, cleared arp tables, flushed dns to no avail. 

 

I was using a vpn client on the laptop, but it has since been removed per someones suggestion as a test. The vpn adapter was also removed. 


Edited by dejavou42, 02 January 2016 - 01:11 PM.


BC AdBot (Login to Remove)

 


m

#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:22 AM

Posted 02 January 2016 - 01:00 PM

Hi :welcome:

 

Please Copy & Paste the Minitoolbox log to your topic.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 01:08 PM

Attached is the mtb log in txt format - pastebin link removed.

 

Thanks, I did not realize the pastebin link wasn't working.

Attached Files


Edited by dejavou42, 02 January 2016 - 01:11 PM.


#4 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 01:08 PM

double post **oops


Edited by dejavou42, 02 January 2016 - 01:09 PM.


#5 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:22 AM

Posted 02 January 2016 - 01:31 PM

Hi,

 

Try with Windows 10 Fast Startup Disabled http://www.tenforums.com/tutorials/4189-fast-startup-turn-off-windows-10-a.html

 

 

 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#6 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 01:53 PM

disabling fast startup (hiberboot) had no effect. 



#7 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:22 AM

Posted 02 January 2016 - 01:58 PM

Lets run a System Check because the log show some errors...

Press windows8_key.png + X and click Open Command Prompt (Admin)
type:

sfc /scannow

If everything is OK it should say something like "No integrity violations found" if not let me know the exact result.

 

Note: The scan can take some time
 

 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#8 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 02:33 PM

sfc /scannow reported no violations. This was on a scan I did earlier this morning.



#9 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 03:53 PM

I think one important clue to this problem is that I am able to trick it as mentioned above by connecting first to my iphone hotspot, and then to my access point.... These are two completely separate networks and ISPs. I've done this over and over again, so I don't think that its a coincidence. Also, I have forgotten the settings for the access point and retyped the network key just to make sure it wasn't a corruption in that configuration.



#10 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:22 AM

Posted 02 January 2016 - 04:41 PM

Can you connect the laptop using a Ethernet cable to see if it works correctly?

 

Try to update the driver for the Wireless https://www.atheros.cz/atheros-wireless-download.php?chipset=31&system=9 after clicking on the button "Click for Download" wait for the Popup to download the file.

 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#11 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 05:05 PM

Hi all, I am having an issue with wifi on my laptop after upgrading to windows 10. Wifi worked perfectly before the upgrade.

 

Laptop model: dell inspiron 1090 (duo mini)

 

I can connect to ethernet (on docking station) just fine. When I connect to wifi, dhcp returns an ip address to the laptop, and wifi shows connected (no internet, secured). Pinging the router results in timeouts, as does google. wireshark shows tcp and udp packets on wifi. If I run windows network diagnostics the results vary from can't detect proxy settings to missing necessary protocols. 

 

If I connect to hotspot on iphone, and then connect to access point, wifi works for 15-20 min. then drops out again. It still shows connected, but again, I can't ping the router, and the connection shows no internet, secured. I have tried everything from resetting winsock, ip stack, cleared arp tables, flushed dns to no avail. 

 

I was using a vpn client on the laptop, but it has since been removed per someones suggestion as a test. The vpn adapter was also removed. 

 

The laptop itself does not have an onboard lan port, but ethernet adapters work fine. I have tried 3 drivers for the wifi card: the dell default drivers (originally for windows 7), the drivers from the atheros site, and the drivers from the microsoft source (i.e update driver - search online).

 

With the default dell drivers, I can't even enable wifi on the laptop. The wifi option is greyed out, but device manager reports that the driver is installed and working properly. 

 

The atheros.cz driver and the driver from the windows source (both the same version) give the results above --> connect to access point --> no internet --> connect to iphone hotspot --> connect to access point --> internet.



#12 dejavou42

dejavou42
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:22 AM

Posted 02 January 2016 - 06:03 PM

EUREKA! I've made a breakthrough. Doing some testing on the router in question, I changed the network from 20/40mhz auto to 40 mhz and reconnected wifi. I got the same result --> connected, but no internet connection, can't ping router.

 

Then, I changed the setting to 20mhz only. --> wifi connected with internet access, and so far, it has stayed connected. I can't leave my wifi set to 20mhz only, and I most definitely can't change the settings on public hotspots or other private networks that I don't own.

 

Diving into the driver settings from device manager, I see the following options:

 

802.11b Preamble

Receive Buffers

Scan Valid Interval

Transmit Buffers

 

So, no easy way, atleast through the advanced driver properties, to force the 20mhz frequency only. Does anyone know of another way to force this? Since this was working fine under windows 7, does this sound like a bug for windows 10?

 

I don't know where to go in my troubleshooting from here, but the best I can tell, connecting to the iphone hotspot forced the 20mhz frequency, then connecting to the access point continued on that frequency for sometime until it switched over to 40mhz.



#13 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:22 AM

Posted 03 January 2016 - 06:49 AM

So, no easy way, atleast through the advanced driver properties, to force the 20mhz frequency only. Does anyone know of another way to force this? Since this was working fine under windows 7, does this sound like a bug for windows 10?

 

Sounds more likely a driver problem.

 

If the wireless adapter properties doesn't provide the option to change the Channel Width I don't know a easy way do archive that, maybe there is something about that setting on the drivers files.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#14 jpayamps

jpayamps

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:22 AM

Posted 17 January 2016 - 10:05 PM

EUREKA! I've made a breakthrough. Doing some testing on the router in question, I changed the network from 20/40mhz auto to 40 mhz and reconnected wifi. I got the same result --> connected, but no internet connection, can't ping router.

 

Then, I changed the setting to 20mhz only. --> wifi connected with internet access, and so far, it has stayed connected. I can't leave my wifi set to 20mhz only, and I most definitely can't change the settings on public hotspots or other private networks that I don't own.

 

Diving into the driver settings from device manager, I see the following options:

 

802.11b Preamble

Receive Buffers

Scan Valid Interval

Transmit Buffers

 

So, no easy way, atleast through the advanced driver properties, to force the 20mhz frequency only. Does anyone know of another way to force this? Since this was working fine under windows 7, does this sound like a bug for windows 10?

 

I don't know where to go in my troubleshooting from here, but the best I can tell, connecting to the iphone hotspot forced the 20mhz frequency, then connecting to the access point continued on that frequency for sometime until it switched over to 40mhz.

I had this same problem with a Dell Inspiron 15, with Dell Wireless 1703 card. After reading dejavou42's post,  I decided to play around with frequencies. So if anyone has this same issue on this same laptop, do the following:

 

1) Go to Network and Sharing Center 

2) Change adapter settings

3) Right click on Wi-Fi adapter, select properties

4) Click on configure, then go to advanced tab

5) Select HT Mode, and change the value to HT Mode 20|40

6) Click OK, then you should be able to ping your router and any site

 

FYI, I tried everything out there. This was the only thing that worked for me.



#15 GongGona

GongGona

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:22 AM

Posted 18 January 2016 - 06:04 AM

I had had the same problem as the OP on a DELL INSPIRON 3521.

I had followed his experience and lowered the speed from 20/40 MHz to 20MHz only. This cured the problem but all the other devices on the network ran slower.

 

Now I have followed your advice and it worked a treat. The menu item wasn't 'HT Mode 20/40', but it was equivalent as the dropdown option included '20 or 40 MHz'.

 

I also changed the Vigor2820n router settings back to 20/40 MHz, Greenfield and replaced Mixed Mode with only 802.11n 2.4GHz

 

Back up to speed, thanks to your posting. Much appreciated.






24 user(s) are reading this topic

0 members, 24 guests, 0 anonymous users