Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 Updater not working


  • Please log in to reply
2 replies to this topic

#1 DerrenAngie

DerrenAngie

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:11:41 PM

Posted 02 January 2016 - 12:39 AM

Hello

I purchased a new desktop in February 2015.  It came with Windows 7 Professional SP1 installed on it.  As far as I can tell, the updater stopped working in the beginning of August.  I didn't notice until November when I started having BSOD issues.  The BSOD issues were fixed by replacing RAM.  I have not been able to get WU to work.  I am receiving a 80070002 error.  I was receiving this error when I had the BSOD problems.

Don't know if it matters, but I have a Dell XPS8700, Intel Core i5-4460, NVidia GForce GT720 video card.

I have downloaded the system readiness tool.  I have the option of WU or BITS.  When running WU, the result is Service Registration is missing or corrupt (fixed) and Problems found installing recent updates (not fixed).  When running BITS, I get the same thing, plus an 8007005 error (not fixed).

I reset my WU components through the automatic FIX It.

I tried the elevated command prompt with the following,

net stop wuauserv
cd %systemroot%
ren SoftwareDistribution SoftwareDistribution.old
net start wuauserv

no luck.

I then tried downloading the latest WU Agent.  It would download and attempt to install, but I got the following message. "Windows Update Agent encountered an unrecoverable error".  I looked up the version I have.  It is 7.6.7601.19016

I then tried the elevated command prompt with the following,

regsvr32 Jscript.dll
regsvr32 wuapi.dll
regsvr32 wuaueng.dll

while they did register, WU still wont work.

I tried reset the WU Components manually.  One error I received was "Module mshtml.dll was loaded, but the entry-point DllRegisterServer was not found.  I also got this error for the following files: shdocvw.dll, browseui.dll, qmgr.dll. 

I also got the following error.  "The module msxml.dll failed to load"  I also got this error on the following files: gpkcsp.dll, sccbase.dll, slbcsp.dll, muweb.dll, initpki.dll, wuaueng1.dll, wucltui.dll and wuweb.dll.

By the way, I restarted my computer between every step, before starting another.

I have run out of ideas of how to get WU working.

Can you help please?

 

Thank you.



BC AdBot (Login to Remove)

 


#2 Brandx

Brandx

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Fort Worth Texas
  • Local time:02:41 AM

Posted 02 January 2016 - 07:40 AM

Try this. I am using Win 7 Home Premium and it worked for me.

 

Windows Updates Failed Error 80007000D

1. Open Services Run as Administrator

2. Stop the Windows Update Service

3. Rename or Delete the Software distribution folder    C:\Windows\SoftwareDistribution

Restart Windows or Update Service

4. Open Windows Update and Check for Updates



#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,757 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:11:41 PM

Posted 02 January 2016 - 11:00 AM

Go to the Microsoft Windows website and follow their instructions to resolve the 8007005 error.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users