Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Graphics Card Dying? (Weird Graphical Issues)


  • Please log in to reply
No replies to this topic

#1 Negativenine

Negativenine

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:23 AM

Posted 01 January 2016 - 02:09 AM

Hi guys. So spontaneously today whilst playing Rocket League my game froze with a really weird screen glitch. Since then, it repeatedly happened, and I think its getting even worse by the second. It happens randomly when playing any game on my PC, and is completely fine for browsing the internet and doing other tasks. After doing a lot of research I found that one of the problems could be overheating so I cleaned the dust out of my PC and monitored the temperatures. All temps were normal and I didn't see anything out of the ordinary. After reading a lot on the topic i'm starting to believe that my graphics card may simply be dying, which is disappointing because I only got it last Christmas.

My graphics card is a AMD Radeon R9 270. If it is my graphics card i'm fine with buying a new one, but I just want to make sure that there isn't something else causing the damage, that could do the same to a new one, but like I said I have had no problems with my PC for an entire year and today it spontaneously decided to pull this on me. Sorry if this is a little bare in terms of background info but I feel as if I have narrowed it down to being a problem with my graphics card, but I could easily be wrong so I just want a second opinion. 

Some basic info:

*Running Windows 10*

Graphics Card: AMD Radeon R9 270
Processor: AMD FX™-4300 Quad-Core Processor 
RAM: 8gb
System: 64bit
PSU: Corsair HX650 

(All drivers are up to date)

Im hoping the attatched video will be a clear indicator.

Video of the glitch: https://www.youtube.com/watch?v=-j03Gu59j0I

Anyways thanks for your time.

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users