Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Missing Network Driver/Controller


  • Please log in to reply
7 replies to this topic

#1 YaphetKotto

YaphetKotto

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:11:06 AM

Posted 30 December 2015 - 08:55 PM

Hi guys,

 

I recently reinstalled Windows 7 x64 on to my HP Pavilion dv7 and went to install my usual drivers, ethernet/lan, finderprint ect all of which worked, when i got to the wireless driver i installed the "Broadcom Wireless Lan Driver for Microsoft Windows 7 x64" after installing it popped up with install not succesful, I went to device manager in hopes of manualy installing but to my surprise found no network controller other than the successful ethernet/lan driver.

 

What is going on?

 

My previous network controller id was "PCI\VEN_14E&DEV_4727SUBSYS_1795103C"



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,657 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:36 PM

Posted 30 December 2015 - 09:07 PM

Try the following.

 

http://h20564.www2.hp.com/hpsc/swd/public/detail?swItemId=ob_107849_1

 

Edit: Is this the driver you tried to install?


Edited by JohnC_21, 30 December 2015 - 09:08 PM.


#3 YaphetKotto

YaphetKotto
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:11:06 AM

Posted 30 December 2015 - 09:33 PM

yeah that is the same one. I installed it just then and it popped up with "This Program might not have installed correctly"



#4 JohnC_21

JohnC_21

  • Members
  • 24,657 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:36 PM

Posted 30 December 2015 - 09:42 PM

That's not a very common Vendor and Device ID for Broadcom. It seems the only driver for it is available through HP. If you look at the Vendor ID again is it 14E4 and not 14E as you posted? I am going to try and find another source but it may take awhile. 

 

Edit: Extract the contents of the sp57965.exe using winrar or 7zip to a folder. Right click the setup.exe file and select Run as Administrator. Does that work?

 

 

Edit Edit: If right clicking and running as Administrator does not work, try installing using Device Manager. Right click the WIreless device and select update driver then Browse My Computer for driver Software. Point it to the bcmwl6.inf file in the unzipped folder.

 

http://www.sevenforums.com/tutorials/97061-driver-install-device-manager.html


Edited by JohnC_21, 30 December 2015 - 10:07 PM.


#5 YaphetKotto

YaphetKotto
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:11:06 AM

Posted 30 December 2015 - 10:09 PM

the id was PCI\VEN_14E&DEV-4727SUBSYS_1795103C



#6 JohnC_21

JohnC_21

  • Members
  • 24,657 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:36 PM

Posted 30 December 2015 - 10:23 PM

Everything in the inf file of the file you downloades references a Vendor ID or 14E4 and not 14E as you can see here.

 

%BCM4313NG_DeviceDesc% = BCM43XNG2022_NT60, PCI\VEN_14E4&DEV_4727&SUBSYS_145C103C
        %BCM4313NG_DeviceDesc% = BCM43XNG2022_NT60, PCI\VEN_14E4&DEV_4727&SUBSYS_1483103C
        %BCM4313NG_DeviceDesc% = BCM43XNG2022_NT60, PCI\VEN_14E4&DEV_4727&SUBSYS_1795103C
 
I  am not sure if this is the reason for the failure or not. See if installing the driver using Device Manager as I linked to in my edited post works.


#7 YaphetKotto

YaphetKotto
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:11:06 AM

Posted 30 December 2015 - 10:54 PM

I tried to install as admin, this briefly popped up with a small tab displaying broadcom at the top as if it was about to install but was gone within half a second. In the device manager I can't see a wireless network controller. It's as if the harware itself is unplugged.

#8 JohnC_21

JohnC_21

  • Members
  • 24,657 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:36 PM

Posted 31 December 2015 - 09:09 AM

It would be the device you right clicked to get your vendor and device id. Is there a device with a yellow exclamation mark next to it?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users