Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Black laptop screen after installing arch linux


  • This topic is locked This topic is locked
3 replies to this topic

#1 LinkTree

LinkTree

  • Members
  • 30 posts
  • OFFLINE
  •  
  • Local time:10:35 PM

Posted 29 December 2015 - 05:43 AM

Hi,

My laptop is an old Samsung R540 with an AMD Radeon HD5470 GPU.
I followed this installation guide: https://www.youtube.com/watch?v=Wqh9AQt3nho
Everything went fine until I restarted the laptop and noticed the screen didn't turn on. I was quite confused and worried so I quickly shut it down and tried to restart it again. It didn't work so I tried connecting it to an external Monitor and this time I got an image on the external monitor but it was strange because it seemed like it was skipping the Samsung BIOS entirely and goes to the GRUB screen. After selecting an option in the GRUB screen it starts loading Arch but then fails with lots of errors similar to "[drm:uvd_v1_0_start] *ERROR* UVD not responding trying to reset the vcpu"(please note I don't remember exactly the errors but it was very similar to this)
I assumed that maybe Arch has no built in drivers supporting that GPU and that's why it gives errors and doesn't turn on the laptop screen and since I don't know enough about this distro or linux in general I decided to install a different distro I am a little bit more familiar with and I know it worked 100% on that laptop in the past. This fixed the Samsung BIOS not showing at startup but didn't fix the screen issue.

I then went on and tried to install other different linux distros and windows 7 multiple times but the problem persists I can't get the laptop screen to turn on.

I tried using the function keys for switching displays and changing brightness levels but it had no effect.

I tried shutting down the laptop, taking off the battery and holding down the power button for 1 min and then connecting the battery again and turning it on.

I tried removing and reinserting the RAM even though I don't really think it has anything to do with the RAM because the computer runs fine when connected to an external monitor. The Reason I decided to try removing and reinserting the RAM is because I noticed a weird behavior in DOS applications. There are many quotation marks(") displayed all over the screen and some words have wrong letters in some places. I have taken a few photos of that issue and attached them so you could see what I mean. This also shows when I am loading my bootable windows 7 disk in the screen where it asks you to press any key to boot from the disk drive.

 

In windows 7 I tried to install amd catalyst 15.7.1 but it resulted in my laptop not even booting into windows and going to a BSOD with an error in atikmpag.sys instead.

After formating and reinstalling windows 7 I tried disabling the display adapter in the device manager. Needless to say It didn't fix the screen.

 

Please help me!

Thank you.

Attached Files


Edited by LinkTree, 29 December 2015 - 08:56 AM.


BC AdBot (Login to Remove)

 


#2 OldPhil

OldPhil

    Doppleganger


  • Members
  • 4,019 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Long Island New York
  • Local time:04:35 PM

Posted 29 December 2015 - 08:51 AM

IMO post a link to this post in the Linux section, that may bring more assistance.


Honesty & Integrity Above All!


#3 LinkTree

LinkTree
  • Topic Starter

  • Members
  • 30 posts
  • OFFLINE
  •  
  • Local time:10:35 PM

Posted 29 December 2015 - 08:54 AM

IMO post a link to this post in the Linux section, that may bring more assistance.

Thank you for the suggestion, I wasn't sure if this was allowed on this forum so that's why I didn't do it.



#4 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Staff Emeritus
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:03:35 PM

Posted 29 December 2015 - 10:13 AM

I see that you did start a new topic in Linux.

For future reference, there was no need to start that topic.

The report function should have been used to let the moderators know that this topic should be moved to Linux.

This topic is closed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users