Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Keyboard opening shortcuts instead of typing letters ( soft&hard keyboard )


  • Please log in to reply
3 replies to this topic

#1 bustawidemove

bustawidemove

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:06 AM

Posted 26 December 2015 - 06:15 AM

Windows 10

Start - Settings - Ease of Access - Keyboard

 

Everything here is off. If i turn on the On-Screen Keyboard no keys are Highlighted (indicating they are depressed/stuck )

When I use the hard keyboard and sometimes even the onscreen keyboard its as if either Ctrl, Alt Win or something are pressed down as it just types shortcuts.

EG:

 

-H- typed into chrome browser address bar via onscreen keyboard types as normal

-H- typed into chrome browser address bar via hard keyboard brings up -Chrome://history-  But now also on the onscreen keyboard Ctrl is Highlighted.

I click on the onscreen keyboard to deactivate the now highlighted Ctrl button and try again. Now things are different, as now both the onscreen keyboard and the hard keyboard both bring up –Chrome://history- when -H- is typed ( Shift is not depressed )

 

This seems to randomly cycle one min onscreen keyboard works fine, next the keyboard works fine or they either work or none of the work rendering the computer useless.

 

I cant help feel it’s a software issue but im no pro and I don’t have an additional external keyboard to try but as the onscreen and hard keyboard work ok for a while sometimes I assume something is up and that’s what brought me here.

 

Hopefully this is clear enough to be understood and to help others who may have the same issue.

 

Thank you so much for your time.

 

OTHER NOTES:

In -Device Manger – Keyboards-

The keyboard driver is dated 2006 so tried to update the driver but says I have the best driver software for my device is already installed.  Noticed there are 2 entries for the HID Keyboard Device both are the same driver version.  Maybe I should delete/uninstall one?  Both (under event tab) ,  dated 310715 Device migrated, Device configured(keyboard.inf) and Device started (kbdhid).  It was prob around this date I first started having probs.

 

Pressing Ctrl on hard keyboard highlights Ctrl on onscreen keyboard only whilst being pressed.  Let go of the hard key, the soft key turns off.

Sometimes the 9 gets stuck and does 99999999999999999999999999999 but saying that I just restarted the machine and pressed the key -d-  and it acted like a stuck 9 as in 999999999999999999999  not dddddddddddddddddddddddddddd.  Very odd.

 

Ive NOT tried the following: 

System restore (seems harsh)

Rolling back the keyboard driver (not sure how on win 10 )

Deleting the keyboard from System (not sure how on win 10 )



BC AdBot (Login to Remove)

 


#2 wfallon

wfallon

  • Members
  • 52 posts
  • OFFLINE
  •  
  • Local time:08:06 PM

Posted 27 December 2015 - 03:33 AM

Don't worry about the driver being 2006, a lot of them are. First thing is to uninstall and reinstall the Keyboard driver. Maybe more than once. 

 

If you have a Hot-Key driver do that one too.

 

You could have a stuck Shift, Ctrl, or FN key. New keyboards are kind of flimsy. Get some canned air (cleaning duster), and blow out your keyboard.

 

See where that gets you.

 

Bill



#3 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,316 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:11:06 PM

Posted 27 December 2015 - 11:14 AM

If what Bill has suggested doesn't fix the issue my next step is to disable Fast Boot/Fast Startup.  This is most easily accessed via Control Panel->Power Options->Choose what the power button does link.

 

If you do not have access to the Fast Boot/Fast Startup checkbox there will be a link at the top of the screen, "Change settings that are currently unavailable," that will give you access to them.

 

I have no idea why, but recently a client had some really weird keyboard issues crop up on a Windows 8.1 machine that were similar to yours and that carried over from the keyboard on his laptop to any external keyboard that was plugged in.  There was apparently some corruption in the mini-hiberfile that gets used by Fast Boot because the moment I turned that setting off, after having tried everything else that's "more logical" first, the problem resolved itself.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1809, Build 17763 

     Presenting the willfully ignorant with facts is the very definition of casting pearls before swine.

             ~ Brian Vogel

 

 

 

              

 


#4 bustawidemove

bustawidemove
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:06 AM

Posted 28 December 2015 - 08:28 AM

Thanks Bill,

 

I uninstalled both listed drivers for the keyboard and crapped myself thinking i may have totally disabled the keyboard rather than it just being weird. I didnt notice a "Hot-Key driver" tho.  I decided to do a windows update and so restarted the machine etc.

 

Both drivers came back in the list in device manager, the key board was fine for a while then the issue came back.  I need to purchase some canned air to try that.

 

Thanks Brian,

 

That is a random one thanks.  Found it turned it off and restarted.  Pressed a random key y in this instance it then types y9999999999999999  but as before after a restart, quite often its back to normal for a while, so ill give it a while but not to hopefull because of the y99999999999999 buisness.

 

Just incase anyone else tries this in windows 10 its Windows button-Settings-System-Power & Sleep- Additional Power Settings (link) - then maximize the window that pops up as you may not see the tick boxes that Brian mentions.


Edited by bustawidemove, 28 December 2015 - 11:05 AM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users