Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Elgato Game Capture HD Driver Problems Code 52


  • This topic is locked This topic is locked
9 replies to this topic

#1 POKEGAMERZ

POKEGAMERZ

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Local time:06:57 PM

Posted 25 December 2015 - 06:46 PM

Just today I got an Elgato Game Capture HD so that I could record myself on YouTube playing XBOX 360, XBOX 1 and Retro Game Consoles. I installed the latest version of the Elgato Game Capture software which required me to install Microsoft .NET Framework 4.5 and also required some sort of update for Windows 7. I also downloaded the latest version of the Elgato Game Capture HD Driver. I then opened up the Elgato Game Capture software only to find that it didn't recognize my Elgato Capture device. I went into the Device Manager only to find that there was a yellow ! under the Elgato Game Capture device. I double clicked it to see what the issue was and it gave me the Code 52 error. I tried typing something in CMD to solve the problem but that didn't help. I tried uninstalling and reinstalling the driver but that didn't help. I know that the Device itself is not broken because when a console is hooked up to it then it would show on my HDMI monitor and Retro consoles are included.
Here are some pictures that explain my situation-
Attached File  IMG_20151225_183727667.jpg   64.89KB   1 downloads
Attached File  IMG_20151225_183752807.jpg   57.63KB   1 downloads
Attached File  IMG_20151225_183826584.jpg   94.39KB   0 downloads
Attached File  IMG_20151225_183844359.jpg   103.82KB   1 downloads
Attached File  IMG_20151225_184009929.jpg   72.51KB   1 downloads
Attached File  IMG_20151225_184021240.jpg   53.5KB   1 downloads
Please help me out here so that I could finally record gameplays from all my consoles onto YouTube. I would really appreciate all the help from this thread given the small amount of these threads that are available.

BC AdBot (Login to Remove)

 


#2 POKEGAMERZ

POKEGAMERZ
  • Topic Starter

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Local time:06:57 PM

Posted 25 December 2015 - 08:02 PM

Update- I used Malwarebytes and Adwcleaner to remove viruses in case that was causing the issue. I also used wisecleaner to clean out my registry and here are the results-
Attached File  IMG_20151225_195918695_HDR.jpg   108.55KB   1 downloads
Attached File  IMG_20151225_195928850_HDR.jpg   82.85KB   1 downloads
Attached File  IMG_20151225_195943739_HDR.jpg   130KB   1 downloadsAttached File  IMG_20151225_195957508_HDR.jpg   144.01KB   1 downloads
Let me know if U have any more suggestions for me as WiseCleaner still hasn't solved my problem yet.

#3 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 PM

Posted 25 December 2015 - 09:45 PM

I also used wisecleaner to clean out my registry and here are the results-


warning.gifRegistry Cleaners Warning!
Registry Cleaners are known to be harmful to the system and should not be used for any reason there is. It's a known fact that using Registry Cleaners can easily break a Windows installation, to the point where a complete reinstallation might be needed. Here's a few myths about using these programs, and why they are just plainly false.
  • "Using a Registry Cleaner will improve a system's performance" - False. The Windows Registry is a big database which contains information on everything present on the system, from the boot settings to how your programs looks when you open them. There's so many entries in it that cleaning even thousands of them isn't enough to boost a system performance. Also, there's no studies, tests, benchmarks, etc. which shows that using Registry Cleaners actually improve a system speed;
  • "Using a Registry Cleaner will fix all your errors" - False. Using a Registry Cleaner won't fix any problems at all. In fact, it have more chances to create them if anything. There's no program that can fix every problems in a simple click, and there probably never will. If you have an error, it's better to troubleshoot that error in particuliar by finding what's causing it and fixing it than using a software that might give you more errors;
  • "If you don't use a Registry Cleaner, you'll leave a door open for malware" - False. It is rare that malware will actually hijack orpheans keys and keypairs in the Registry to create persistence or install themself. They'll usually create their own keys/keypairs since they have been instructed (coded) to do so, and the creator cannot expect every system he'll infect to have leftover keys. Also, pretty much only Reg Loading Points in the Registry would be of any interest for a malware to hijack, and these are usually occupied already, or quickly deleted when empty;
  • Registry Cleaners aren't Registry Defraggers - These are two different kind of software who have two distinct function each.
  • On a last note, there's a lot of Registry Cleaners out here that won't create a back-up of your Registry before applying the changes they make. Which means that if you use them and clean entries that prevents Windows to reboot after, locking you out of your computer, you won't be able to restore a precedent Registry back-up via the Recovery PE. This means that if you can't fix the boot issue after that, you'll most likely be forced to reinstall Windows;
Registry Cleaners were used back in the days by developers who were using a OLE-schema for their applications. They used these to clean the Registry after uninstalling their programs, just in case there was traces of it left behind that could affect a reinstallation. These were back in the Windows 95 and Windows 98 days and this practice isn't in effect anymore. Therefore, there's no reason for you to use such programs and quite a few to avoid them instead.

Here's more articles on Registry Cleaners that are worth a read if you want to learn more about them and why you shouldn't use them.This being said, there's a few things I can suggest you:

Reinstall your Game Capture HD software which hopefully includes the drivers: https://www.elgato.com/en/game-capture-hd-support
Disconnect your Game Capture HD device, uninstall the drivers for it, then plug it back in and see if Windows can reinstall them.
Disable Driver Signature Verification (if you read the error message, you'll see that Windows cannot verify the digital signature for the driver, hence why it refuses to load it): http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

The third solution opens a hole in your system for infection, so I would be very careful with it. If Game Capture HD drivers really aren't signed, I would send them an email asking them to rectify this situation ASAP.

animinionsmalltext.gif
unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#4 POKEGAMERZ

POKEGAMERZ
  • Topic Starter

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Local time:06:57 PM

Posted 25 December 2015 - 10:23 PM

Alrightys so I uninstalled the drivers that caused an error and I disconnected and reconnected the Elgato Game Capture HD and here's the result-

Attached File  IMG_20151225_221739107_HDR.jpg   79.87KB   0 downloads
 

Afterwards I went online to search for the Elgato Game Capture HD software and it still won't connect to the software-
 

Attached File  IMG_20151225_221803692_HDR.jpg   67.27KB   0 downloads
 

Could it be because I'm using an older version because that was all I could really find for now.


Edited by hamluis, 26 December 2015 - 01:23 PM.
Removed unnecessary quotbox - Hamluis.


#5 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 PM

Posted 25 December 2015 - 10:36 PM

Didn't you download the software from the link I provided? The link I gave you contain the download link for the latest version of the software.

animinionsmalltext.gif
unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#6 POKEGAMERZ

POKEGAMERZ
  • Topic Starter

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Local time:06:57 PM

Posted 25 December 2015 - 11:00 PM

Alrightys so thanks for all your help, especially you Aura. Here's a picture of Street Fighter on my Elgato-
Attached File  IMG_20151225_225836760.jpg   70.28KB   0 downloads

#7 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 PM

Posted 25 December 2015 - 11:01 PM

Looks good :) So what solved your issue? Installing the latest version of the software from the link I gave you? Or was it something else?

animinionsmalltext.gif
unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#8 POKEGAMERZ

POKEGAMERZ
  • Topic Starter

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Local time:06:57 PM

Posted 25 December 2015 - 11:49 PM

Looks good :) So what solved your issue? Installing the latest version of the software from the link I gave you? Or was it something else?


I already had a setup file in downloads and I installed it from there. If you want to see some gameplays recorded on my Elgato then visit my YouTube channel and my YouTube username is POKEGAMERZ9185. Tomorrow I plan to upload Street Fighter, Galaga and Super Pac Man. Subscribe to my channel and I also plan to do a video thanking you and the Bleeping Computer staff for helping to fix my Elgato. Don't forget to subscribe.

#9 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 PM

Posted 25 December 2015 - 11:51 PM

So a reinstall did the trick. All good, I'll check it out to see the quality :)

animinionsmalltext.gif
unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#10 POKEGAMERZ

POKEGAMERZ
  • Topic Starter

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Local time:06:57 PM

Posted 26 December 2015 - 11:58 PM

So a reinstall did the trick. All good, I'll check it out to see the quality :)


Alrightys so the gameplays are up on my channel. Footage was recorded on my Elgato device and narration was added on Windows Movie Maker. I also did a review on the device. Don't forget to check my channel out for the videos.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users