Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

TP-Link Archer C7 - can only connect to 5ghz, not 2.4ghz


  • Please log in to reply
7 replies to this topic

#1 mreid72

mreid72

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:01:34 PM

Posted 20 December 2015 - 10:58 PM

Hi all.  I have a brand new TP-Link Archer C7 dual band router.  This is my first time to have a dual band router (2.4ghz and 5ghz), so I'm a little confused and having some problems.  The problem may be that I didn't set it up properly since I'm not familiar with it. 

 

When setting it up, I chose to have both bands running concurrently.  I set up the passwords for both bands (chose the same password for both, but each network has a different name).  The way I understand it is I can choose which band/network I want my device to connect to.  Xbox One to one network, phones and laptops to another, etc.

 

However, the problem I'm having is that I can't get ANY device to connect to the 2.4ghz network, only the 5ghz one.  I enter the correct password on my device, but the message I get every time is "Can't connect to this network".  No explanation as to why.  I've double checked and triple checked the password, and everything is correct.

 

So...why can't I connect to the 2.4ghz network?

 

Thanks in advance.



BC AdBot (Login to Remove)

 


#2 moxom

moxom

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:08:34 PM

Posted 21 December 2015 - 11:29 AM

Hi mreid,

 

There are numerous reasons why you could be having this issue, the 2.4GHz band is shared with household appliances - have you tried moving the router to another location and tried to connect from there? If not, try it - you don't need internet connection to connect so for troubleshooting purposes you could it bring to work or something like that.

 

Other things you can try:

 

Disabling the password for your network and see if that changes anything.

Update the Router firmware.

Set up the connection manually from "network and sharing center" -> "set up a new connection" (if you're using windows).

Change wireless channels - the most common 2.4 band channels are 1, 6 & 11.

Scan wifi signals in your area using a wifi scanner (download an app for your phone or search on google) - use the least populated channel.

 

I havn't seen your router configuration, but I find it highly unlikely that you configured something wrong to cause this problem.. If you've established that there are no interference and it's still not working, I would take it back to the store.

 

It should be mentioned that if your devices can connect to the 5Ghz band, there are no reasons to be using 2.4 - 5Ghz delivers better speeds and is generally supported by all new devices today.

 

 

 

Hope this helps,

moxom



#3 mreid72

mreid72
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:01:34 PM

Posted 21 December 2015 - 11:47 AM

Hi mreid,

 

There are numerous reasons why you could be having this issue, the 2.4GHz band is shared with household appliances - have you tried moving the router to another location and tried to connect from there? If not, try it - you don't need internet connection to connect so for troubleshooting purposes you could it bring to work or something like that.

 

Other things you can try:

 

Disabling the password for your network and see if that changes anything.

Update the Router firmware.

Set up the connection manually from "network and sharing center" -> "set up a new connection" (if you're using windows).

Change wireless channels - the most common 2.4 band channels are 1, 6 & 11.

Scan wifi signals in your area using a wifi scanner (download an app for your phone or search on google) - use the least populated channel.

 

I havn't seen your router configuration, but I find it highly unlikely that you configured something wrong to cause this problem.. If you've established that there are no interference and it's still not working, I would take it back to the store.

 

It should be mentioned that if your devices can connect to the 5Ghz band, there are no reasons to be using 2.4 - 5Ghz delivers better speeds and is generally supported by all new devices today.

 

 

 

Hope this helps,

moxom

Household appliances?  Like what?

 

I'll try some of the other suggestions, but if I disable the password and that allows us to get on, how does that fix the problem?  I don't want it unsecured.

 

And there is a very good reason to use the 2.4ghz band - our Chromecast doesn't work with 5ghz.  And we use Chromecast all the time.  Besides, both bands should just work, and not working bugs me. 

 

Thanks, and I'll reply again if it doesn't work.



#4 moxom

moxom

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:08:34 PM

Posted 21 December 2015 - 12:21 PM

Like Microwaves, TV's, Speakers, Phones, Ovens, Refrigiators, Freezers and so on :).

 

If you disable the password and that allows you to get on, at least you know security is causing the problem - then you can troubleshoot from there.

 

Ah yeah, of course - I feel the same way about not working, not everybody is like that though ;)



#5 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:12:34 PM

Posted 21 December 2015 - 01:57 PM

Make sure the 2.4 is enabled in the router and has its own ssid different than that of the 5ghz

 

download and run xirrus wifi inspector and post a screen shot of what it sees for wifi in your area.  This will also show if you have a 2.4 SSID.



#6 mreid72

mreid72
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:01:34 PM

Posted 21 December 2015 - 02:06 PM

Make sure the 2.4 is enabled in the router and has its own ssid different than that of the 5ghz

 

download and run xirrus wifi inspector and post a screen shot of what it sees for wifi in your area.  This will also show if you have a 2.4 SSID.

 

As I said in my OP, each network has its own name (SSID).  I also mentioned that I set it up to run both bands concurrently, meaning 2.4 is enabled.  My devices can see the network, but just can't connect to it.



#7 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:12:34 PM

Posted 21 December 2015 - 03:56 PM

We need to see what channels they are on and what the other local wifi channels being used.  Looking forward to that xirrus screen shot.



#8 mreid72

mreid72
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:01:34 PM

Posted 22 December 2015 - 06:37 PM

FYI...Changing the channel on the 2.4ghz from channel 1 to channel 6 made the difference.  Everything's working now.

 

Thanks.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users