Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't format SD card


  • Please log in to reply
3 replies to this topic

#1 Izzye

Izzye

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Norfolk
  • Local time:10:32 AM

Posted 20 December 2015 - 01:07 PM

I bought myself a 64GiB Kingston class 10 SD card the other day, put it in my camera to see if it worked, which it did, so I forgot about it. Unfortunately I then forgot to take it out before using the camera and my computer spent yesterday running a file recovery programme because I hadn't formatted it. When it finished I tried to format it with the computer running XP but after a minute of trying it informed me I couldn't format it, formatted it through the camera, back in the computer, same error. Ran a virus scan to check there wasn't anything untoward happening on my computer, but I've just tried it on my laptop (Linux Peppermint) and when I try to mount it I get back this message;

 

Error mounting /dev/sdb1 at /media/izzye/LUMIX: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdb1" "/media/izzye/LUMIX"' exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'

 
Tried to access it through terminal but got back; 
 
fdisk /dev/sdb1
fdisk: unable to open /dev/sdb1: Permission denied

 

Anyone got any idea how to fix this?

 



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,849 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:32 AM

Posted 20 December 2015 - 03:21 PM

I believe the issue is the exfat file system. Fat32 normally has a 32GB limit and it's necessary to use third party partition management to format Fat32 past 32GB. ExFat supports a partition over 32GB but it's possible your computer has trouble with it even though Windows should be able to mount the file system as read only. Linux can detect but not read ExFat.

 

See if your computer and camera can access a Fat32 partition of 64GB. Download and run Partition Wizard with the SD card attached to your computer. Delete any partitions currently on the SD card. Make sure you are doing this you your SD card and not your HDD. Create a Fat32 partition of 64GB and make it Primary. Does your camera recognize the full 64GB?

 

All steps in Partition Wizard are virtual. Nothing will be done until you click Apply. This lets you cancel an operation.

 

If you have experience with Gparted on linux you can format the SD card with it.



#3 Platypus

Platypus

  • Global Moderator
  • 15,805 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:09:32 PM

Posted 20 December 2015 - 05:00 PM

I'd suggest trying the card in a current system, since older systems can have a hardware problem where the SD card reader doesn't understand SDHC (SD High Capacity), and if XP is not fully updated, it also may not understand exFat, although that would be an unusual situation.

If anyone you know has a laptop running Windows 7 or later, chances are it should handle both SDHC and exFat, and give you correct handling of the card. That would let you work out if there is actually any problem with the card, or if it's just the old XP system that's having trouble with it.
Top 5 things that never get done:

1.

#4 Bailifei

Bailifei

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Local time:05:32 AM

Posted 21 December 2015 - 01:40 AM

Partition Wizard, Partition Manager, Partition Master, Partition Disk, seem all works in the same way.  :bubbles:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users