Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Networking Question


  • Please log in to reply
3 replies to this topic

#1 szesteve

szesteve

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:26 AM

Posted 25 July 2006 - 08:05 PM

Hello,

I have 2 laptops ( A & B ) that connect to a wireless network. Until recently, these laptops were only accessing internet via the network/router.

Today, I finally figured out how to share files (thanks to this forum). BUT, I can only access the shared folder which exists on B from A without any problems.

A can see B, and vice versa. However, if I use B to try to access a shared folder that exists on A, I get a logon screen that asks me to type in a username and password.

How can I avoid this logon? Both laptops are using XP Professional SP2.

Thank you!

Edited by szesteve, 25 July 2006 - 08:06 PM.


BC AdBot (Login to Remove)

 


m

#2 szesteve

szesteve
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:26 AM

Posted 26 July 2006 - 06:50 AM

Okay, I found this site that describes the problem I'm encoutering: http://www.practicallynetworked.com/sharin...ientconnect.htm

More specifically to XP:

When a user on another computer on the network attempts to access a shared disk or folder, Windows XP Professional checks to see whether that user has permission to access it. The client computer sends the user name and password of the user who is currently logged in, and the XP Professional computer checks them. If those ‘credentials' match an account on XP Professional, then it checks the ACL for the shared disk or folder. If the ACL permits access by that user, access is granted; if not, access is denied.

On a client running Windows 2000 or XP, there's more to the story. If XP Professional doesn't recognize the logged-in user name and password, it causes the client computer to prompt the user to enter a different user name and password.

If Windows XP Professional doesn't recognize the user name and password presented by a Windows 2000 or XP computer which wants to access a share, you can enter different credentials. Here, we're logged on to another Windows XP computer as a user which doesn't have an account on the computer named RONS-PC. Entering a valid user name and password grants access


Now...what I don't understand is what does a valid user name and password mean? Is it a valid user name and password of an account that exists on the client computer?

Any help is much appreciated!

#3 szesteve

szesteve
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:26 AM

Posted 26 July 2006 - 06:28 PM

:thumbsup:

Ok, I managed to figure this out. I'm posting my solution here.

Note: By no means am I a technical person and my solution worked for me but may not work for you. Please refer to this only as a guide and nothing more.

Okay, to get rid of the login prompt, you have to modify the Local Security Policy on the computer that's asking for the prompt. i.e. Assume you have 2 computers, A & B. A tries to access B's shared folder but gets a login prompt. So, you have to change the Local Security Policy on B.

To do so, perform the following:
  • Go to Start > Control Panel > Administrative Tools and select Local Security Policy.
  • In the left window, expand Local Policies, and click once on the User Rights Assignment folder.
  • Double click on "Deny access to this computer from the network". You should see a "Guest" account.
  • Click on "Guest" and remove it.
  • Apply the settings and exit the local security policy
Well, that was how i got around the login screen.

Cheers!

#4 Snapper

Snapper

  • Members
  • 550 posts
  • OFFLINE
  •  
  • Location:Newfoundland
  • Local time:07:26 AM

Posted 27 July 2006 - 11:14 PM

that may leave you a bit more open as far as security goes. you may also want to try creating a username and a password that are the same on computer A and computer B. and logging into it that way.
Google...Google.....browse..read




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users