Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Permission problems


  • Please log in to reply
13 replies to this topic

#1 JoeContois

JoeContois

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 18 December 2015 - 10:45 AM

Hi,

A friend was throwing their computer away because it didn't work, so I took it and got it to work. It wouldn't power on so I unplugged it and held the power button down to 'refresh' the motherboard and it worked. So I get on it and am able to change the volume, open mouse settings (although it didn't change the pointers to 3d like I commanded), and I didn't receive any permission errors. Now, said friend has a bunch of pictures on the hard drive so I took it out so it was ready to be given to her, but then decided to put it back in and just burn the pictures (~30gb) to cds. After booting the computer back up it started showing permission errors for just about any changes. The computer also somehow had 3 updates it decided to install, despite not being connected to the internet, and the system had been turned on and off several times without it doing any updates, but all of a sudden it had updates shortly after I put the hard drive back in (within a couple of boots). Another thing that has happened today is that I took the cmos battery out to try to get the MB to recognise my usb keyboard before booting so I could get into safe mode. That didn't work, but I found a usb to p/s adapter so I got into safe mode with command prompt. I added every possible user to the administrator list. When I boot up normally, I only have one option to log in and that's Desktop.I added this user to the administrator group in safe mode and it says I was successful, however i still get permission errors for just about everything. I'm sorry for the super long text but I am just trying to give all information to try to expedite getting this resolved. Thanks so much.

BC AdBot (Login to Remove)

 


#2 RolandJS

RolandJS

  • Members
  • 4,533 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:10:32 AM

Posted 18 December 2015 - 11:01 AM

Do I read correctly that you have sometimes your harddrive and your friend's harddrive together in the computer? Exactly what folders are giving permission problems?  Do you have restorable backups of your OS and data partitions just in case a rollback is needed? 


"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#3 JohnC_21

JohnC_21

  • Members
  • 24,312 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 AM

Posted 18 December 2015 - 11:06 AM

When booting into Safe Mode you should see a user called Administrator. If you login to that account, do you still get permission errors?



#4 JoeContois

JoeContois
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 18 December 2015 - 03:41 PM

Roland, no, just the one hard drive. I don't think I have folder restrictions, it's all stuff in the control panel, and volume and clock on the desktop. Also, no backups. John, no user called administrator when i boot into safe mode. It is there when I boot into safe mode with command prompt though.

#5 JohnC_21

JohnC_21

  • Members
  • 24,312 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 AM

Posted 18 December 2015 - 04:00 PM

Type the following command at a command prompt.

 

explorer.exe   <enter> 

 

It will ask if you want to stay in safe mode. Say yes and minimize the command prompt window. You should be at the desktop with the start button.

 

Can you access the files you need?



#6 JoeContois

JoeContois
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 18 December 2015 - 04:04 PM

I'm not home. I'm trying to change things like time and mouse settings. File access is fine.

#7 JohnC_21

JohnC_21

  • Members
  • 24,312 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 AM

Posted 18 December 2015 - 04:08 PM

You should be able to access time and mouse settings in Administrator. It's possible the user profile became corrupted. You can add a new user in Administrator. See if the permissions issue is still there. If not you can delete the old user profile after backing up the user data.



#8 JoeContois

JoeContois
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 18 December 2015 - 04:32 PM

Thanks john. Do you know why the administrator account doesn't show up at the welcome screen?

#9 JohnC_21

JohnC_21

  • Members
  • 24,312 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 AM

Posted 18 December 2015 - 04:51 PM

I am not sure but you can do the following command the prompt. If this does not work there is a program that you can download to create a bootable disk. Using it you can enable the Administrator Account.

 

Type

 

net user administrator /active:yes

 

Reboot. If this does not work then use the bootable iso. You can burn the iso on a Windows 7 computer by right clicking and selecting Burn Disk Image.

 

The program you need is here. Here is a guide on it's use. It shows for Vista 7 and 8 but the procedure is the same. Also see this video.

 

Is this XP home or Pro?



#10 JoeContois

JoeContois
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 18 December 2015 - 05:17 PM

Home. Thank you for the suggestions!

#11 JoeContois

JoeContois
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 05 January 2016 - 06:56 PM

Hi, sorry for the late reply. I've narrowed down what I think the problem is. When I delete all user accounts, the administrator account does not show up on the welcome screen when I boot normally. So I hit ctrl alt del twice and get the log on to windows screen. I type administrator along with the password I created and it says, unable to log you on because of an account restriction. There's a "person" named 'owner' that isn't on the list of accounts. Could this be where my problem is?

Edited by JoeContois, 05 January 2016 - 06:57 PM.


#12 JohnC_21

JohnC_21

  • Members
  • 24,312 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 AM

Posted 06 January 2016 - 02:22 PM

I would download the program I linked to and let it enable the Hidden Administrator Account. Reset the password if needed. You deleted all user accounts? How did you add an account then? The only owner I am familiar with it the one on the tab as shown here. You may want to try taking ownership of the drive. It may be a better option to do a full factory reset if you have a recovery partition on the drive. There is a Windows all in one repair utility that will reset your file and registry permissions.

 

You use the net user command to add a user, correct?

 

5.jpg?resize=636%2C482



#13 JoeContois

JoeContois
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  

Posted 06 January 2016 - 02:51 PM

Yes I used the net user command to add a user and it said it was successful but still no accounts showed up on the welcome screen when I booted normally. The administrator account shows up in safe mode though so I can log in and create accounts. I guess the administrator account is supposed to be hidden when there are other accounts, but it's supposed to show when there isn't other accounts. It doesn't, and I want it to. I looked in the registry and didn't see an administrator account listed. I think I need to add the account and set it to 1, but I don't understand why it doesn't just show up when I delete all other accounts. I think it may have to do with not having ownership of the drive. The computer was the 'downstairs computer' so maybe it was 'controlled' by another computer? I'll have to search how to take ownership of a drive, or perhaps you could tell me :) I'm guessing I'll be right clicking on the c:? Also, there isn't a recovery partition. Thank you!

#14 JohnC_21

JohnC_21

  • Members
  • 24,312 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 AM

Posted 06 January 2016 - 04:26 PM

In Home the Administrator Account is normally hidden but you can edit the registry as you posted to unhide it. 

 

Here is a PDF that should get you started on the permissions problem. Is it possible to do a factory reset on the computer? That would be the best option.

 

By the command line taking ownership of a drive where X is the drive letter.

takeown /F X:\ /r /d y      
icacls "X:\" /reset /t





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users