Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


WON'T TURN ON: Lenovo Flex 2.14 HELP!

  • Please log in to reply
No replies to this topic

#1 lucyjude


  • Members
  • 1 posts

Posted 16 December 2015 - 01:00 PM

The other day my lenovo flex 2.14 (running on windows 10) went into what I can only assume was sleep mode: the power light was flashing (which the usermanuel says indicates sleep mode).


I read somewhere that taking the battery out and holding the power button for 30 seconds would help (something to do with draining charge or something). I couldn't get access ot the battery as I didn't  have any screws so I took the charger out and tried the same thing, put the charge back in and hey presto it seemed to work.


- Then the same thing happened again a few days later, but the same solution didn't seem to work. This time I managed to take the back off - but then didn't know where the battery was. I carried on pressing the power button and disconnected any wires that I could see (turns out these were the ones to the wireless card) and reconnected them. At some point the sleep button turned off and wouldn't turn on again, at this point I put the charger back in and the computer started working again.


- Then , a few days later, the same thing happened AGAIN, this time I worked out where the battery, but couldn't work out how to disconnect it. While I was fiddling with it trying work out how to do so (I should point out that I never managed to disconnect it) the sleep light turned off and wouldn't turn on again. I plugged the charger in, still nothing would turn on or off, I screwed the battery back in place and HEY it turned on.


- I had to travel to London the next day, turned my laptop off (or so I thought), put it in a soft shell case, put that case in my suitcase and set off. When I next got my laptop out and tried to turn it on the power button was flashing again like it was in sleep mode. I took the back off, took the battery out (but didn't connect the wired because I didn't know how), put it back and then left it over night.


When I woke up the sleep light was still blinking. I took the battery out, worked out how to disconnect the wire, pressed the power button for thirty second, reconnected the battery and plugged the charger in. Now it won't turn on at all.


The only thing that happens is when i put the charger in, the battery charge light shines solid white.




I've detailed everything I've done because I'm not really sure what has fixed this problem the first few times.


CAN ANYONE HELP ME. I realise I would be best to take it to PC World, but I have 2 assignments due over christmas and can't really spare the two weeks that they will take it away from me for.


currently borrowing other people's computers and its very stressful.


Everything I have is saved on onedrive so losing content isn't a problem - thankfully.

BC AdBot (Login to Remove)



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users