Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't save files to folders


  • Please log in to reply
No replies to this topic

#1 Bulgaristan

Bulgaristan

  • Members
  • 294 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bulgaria
  • Local time:04:23 PM

Posted 16 December 2015 - 10:38 AM

 

Anyway, this is good that you are administrator and the sole user. This is how it should be.  So to fix the problem I think you just need to reset the security options on that folder. I can't really say how it got messed up, but this should fix it.  These steps are a bit involved, but just take it step-by-step (some users print them and mark off what step they've done).  If you get stuck, just let me know what step you're on.

 

  1. Press Windows+R to show the Run box.
  2. Type (or copy/paste)  %userprofile%  (including the percent signs) into the box and hit OK to open your user profile folder.
  3. Right-click the Documents folder and go to Properties.
  4. On the Security tab, click Advanced.
  5. At the top, make sure the "owner" is set to your account.  If it already is, please skip to step 6.
    • A.  If the owner is not you, click Change.
    • B.  Click Advanced
    • C.  Click Find Now
    • D.  Select (highlight) your account in the list (it may be a name or email address depending on your setup), then click OK to close the search box.
    • E.  Click OK again to close the "select a user" box.
    • F.  Turn ON checkbox for "replace owner on subcontainers and objects" (this makes sure you are the owner for everything under your documents folder also).
    • G.  After the checkbox is on, click OK close the "advanced security" box.
    • H.  Click OK again to close the Documents Properties box.  At this point, you should be back where you were after step 2 when you opened the User Profile folder.
    • I.  Right-click the Documents folder again, and go back to properties,
    • J.  On the Security tab, click Advanced, then continue with step 6 below.
  6. Click "Add"
  7. Click "Select a principal"
  8. Click Advanced
  9. Click Find Now
  10. Select (highlight) your account in the list (it may be a name or email address depending on your setup), then click OK to close the search box.
  11. Click OK again to close the "select a user" box
  12. Turn on "Full Control" checkbox.
  13. Click OK to close the Permission Entry box.
  14. Click OK again to close the "Advanced Security" box.
  15. Click OK again to close the Documents Properties box.  At this point, you should be back to where you were after step 2 when you opened the User Profile folder.

 

Now, double-click the Documents folder to go inside.  Try opening any file you have, making a minor change and clicking "Save" to see if it saves properly now that you have "full control" over everything.

 

 

Again I know these are long steps.  As a word of caution, please do not try to do this on a larger scope (for example, if you tried this on your whole C: drive, you could destroy your OS, so only do it on Documents/Pictures folders and such to be safe).  Also, never use the "Deny" options when setting permissions because those take precedence over the allows, meaning that you can permanently lock yourself out of a folder and never get back in.
-Shawn Keene

All of this caused of the OneDrive.......

Incredible Microsoft overtake my files just for fun? 

Should they warn the clients an upgrade will literally change your file permissions?


Edited by Bulgaristan, 16 December 2015 - 10:39 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users