Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Realtek HD Audio (ALC1200), sound stuttering


  • Please log in to reply
No replies to this topic

#1 SkyOfOverflow

SkyOfOverflow

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:26 PM

Posted 14 December 2015 - 07:50 AM

Hello,

I have this internal sound card in my system which more or less works as expected. However, there seem to be a few programs where the audio is stuttering/crackling. One is the PPSSPP emulator, another one is Beepola cross-tracker; I suppose there might be more of them which I haven't found yet.

Now I've noticed a weird pattern in that with both of these programs, the sound only comes out distorted if there's NO hard disk activity. If say I try to unzip a large archive, copy some files or simply view the properties of a folder with lots of files/subfolders, the audio becomes OK as long as the hdd is busy.

Here's why I think it must be sound card related: I've been using an 'external' SB Live card until recently and never had this problem, at least I know for a fact that Beepola used to work just fine all the time (regarding PPSSPP, I haven't tried it with SB Live but from the fact that the stuttering is similarly alleviated when the hdd is active I assume it has to be the same issue). It can't be CPU either I believe because taskbar shows minimal activity in both cases.

The PC is rather old: ASUS P5Q3 motherboard, Intel Core 2, Windows XP. Realtek drivers are of version 5.10.0.5859 downloaded from ASUS, so it's not the latest version but the latest one has this issue as well.

Some things I've tried:

- Measuring latency with DPC Latency Checker: didn't show anything suspicious, with mostly low values of 5-25 in the green
- Checking for a possible IRQ conflict: "Microsoft UAA bus driver" is using IRQ 22 and it's not used by anything else
- Checking sample rate/bit depth compatibility: seems to be OK for as high as 96000 Hz/32 bit

(Logically, there has to be some sort of difference between the 'normal' and the 'problematic' programs in how they are doing the audio; I wonder is there exists some tool that could help investigating the exact manner in which an application interacts with the sound interface/drivers..?)

Anyone else had this problem? Can you suggest something?



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users