Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Ports not working


  • Please log in to reply
4 replies to this topic

#1 Weaponsmith

Weaponsmith

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:00 AM

Posted 12 December 2015 - 03:22 AM

Hi guys,

 

I am currently using an ASUS G750jh laptop.

 

So earlier today I plugged in my IPhone to sync it with Itunes but a few seconds after plugging in my mouse (which was connected by USB) stopped responding. The Iphone also did not sync in the end.

Afterwards I did some checking and found that all my USB ports were not working. My mouse lights up when plugged in but it does not respond. My printer that is also connected to another USB port could not be read as well.

 

I tried plugging in my iphone and now it does not even charge on the laptop. I looked at device manager, and under Other Devices - Unknown Devices - I found that all 3 were located at the USB Ports, and they have a yellow exclamation sign next to them. I tried uninstalling them and restarting my laptop to no effect.

 

Could the USB controller be fried? Or is it likely that it is a software issue.


Edited by Weaponsmith, 12 December 2015 - 03:38 AM.


BC AdBot (Login to Remove)

 


#2 technonymous

technonymous

  • Members
  • 2,499 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:00 AM

Posted 12 December 2015 - 05:27 AM

load bios defaults see if that fixes it. Check bios battery voltage inside the bios too.



#3 Weaponsmith

Weaponsmith
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:00 AM

Posted 12 December 2015 - 05:32 AM

Thanks for your reply technonymous, I will try it out.

 

Just an update, I realise I have the same problems as these guys:
 
 
Which was caused by a Windows Update. This was back in 2014, and perhaps a new update has caused the problem. I am now going through them and uninstalling them. 
 
If you guys are aware of any recent Windows Update that leads to USB problems, please do upate me!


#4 Weaponsmith

Weaponsmith
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:00 AM

Posted 12 December 2015 - 05:45 AM

OK I uninstalled a bunch of Updates that came in during the last 24 hours - and my USB port is finally working!!



#5 technonymous

technonymous

  • Members
  • 2,499 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:00 AM

Posted 12 December 2015 - 06:32 AM

So it was a MSFT USB update that broke it. I suggest you adjust your MSFT updates. lol






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users