Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Minor Issues With Linux Mint 17.3


  • Please log in to reply
18 replies to this topic

#1 Tamimwm

Tamimwm

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:05:13 AM

Posted 10 December 2015 - 08:01 AM

Hey everyone,

As some of you may know I recently installed Linux mint 17.3 on my device.

I had faced these issues after the installation process:

 

1 Sound is completely gone; I cannot get my pc to produce any sort of sounds. It started acting up when I connected my headset but the speakers still worked but now my pc is not producing any sounds whatsoever. I tried them out in windows 8.1 both my headset and speakers worked fine. Thus I suppose it is a linux issue rather than hardware

 

2 Harddrive unmounted; If I started up my pc with linux system first my harddisk partition which contains the windows 8.1 and other files Is " unmounted " my other partition which contains pdfs , music , and videos is suffering from the same issue. As a result I have to boot up my pc in windows first and restart it in linux to get them to work.

 

3 Linux reseting : I have been fighting with linux for a while now, everytime I change some settings it resets them. This include basically my theme and background and any files I put up on the desktop. It looks like it is in deep freeze state which is really bothersome.

 

So far that is all. Thanks to all for any possible help.

Regards

Tamim



BC AdBot (Login to Remove)

 


#2 pcpunk

pcpunk

  • Members
  • 5,476 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:11:13 PM

Posted 10 December 2015 - 06:32 PM

Not sure about these specific issues, but did you Activate your firewall and do all your updates?  Sometimes Updates will fix some issues, either way you need to do them.

 

Question #2.  Did you open the file manager to see, and click on the drive you wanted to access?

 

I did a little research but couldn't find anything, it looks as though MadmanRB was looking also.  It might be an issue of checking the md5sum of the iso that you downloaded to create install medium.

 

This might look complicated, and you might not want to install the tool to do this in windows that's up to you.  You could also wait for better advice on this as some don't check them at all, I always do in case I get a bad connection and a skip in the download.

https://help.ubuntu.com/community/HowToMD5SUM

 

To Activate Uncomplicated Firewall: Copy Paste into Terminal:  sudo ufw enable  Then Password, and hit “Enter”.  Note: You will not see Password – that is for security.
 
Optional: To check status of Uncomplicated Firewall - Copy Paste in Terminal:  sudo ufw status verbose   Then password and hit “Enter”
 
Status should look like this:
youruser@yourcomputer:~$ sudo ufw status verbose
[sudo] password for youruser:
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing)
New profiles: skip
youruser@yourcomputer:~$
 
The Updates will take a while so make sure you have the time, maybe 30min give or take.
To Update from Terminal:  sudo apt-get update && sudo apt-get upgrade

Edited by pcpunk, 10 December 2015 - 06:41 PM.

sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#3 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:13 AM

Posted 10 December 2015 - 06:44 PM

Hi Tamim,

 

I'll begin with the 2nd issue because that's an easy one and something you need to know anyway, then go onto the third issue because at the least that will require more information to get to the bottom of. Then when we've done that we can move onto the first issue, if it doesn't fix itself as we fix the third issue.

 

2nd issue

 

By default and for security, Linux only automatically mounts the partitions it needs, although we can change that (by editing a file) if you want, once we have fixed your third issue. The easiest way to mount partitions in Mint is to:double click on your file manager desktop icon, then click on the partition you want to mount in the column on the left. When you've done that, the partition is mounted.

 

3rd issue

 

What device did you install Mint on? I suspect it was a partition on your HDD, but need to know for sure. Also, did you remove the DVD or USB from your computer that you burned the Mint ISO to, after you installed Mint?


Edited by Al1000, 10 December 2015 - 06:44 PM.


#4 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:13 AM

Posted 10 December 2015 - 06:48 PM

I have to boot up my pc in windows first and restart it in linux to get them to work.


I don't understand what is happening here, but hopefully it will become apparent. When you reboot your computer (regardless of operating system), all mounted partitions unmount.

#5 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 11 December 2015 - 01:14 AM

A bit off-topic, but quick reminder, if you are dual-booting Linux Mint 17.3 with Windows 8.1, and intend to save data to your Windows partition, make sure that you either shutdown Windows manually (eg: using the Command Prompt), or disable fast-startup (if you haven't already). Currently you are achieving the same effect by booting up Windows, and using restart (which is unaffected by fast-startup). By default on Windows 8/8.1/10 fast-startup is enabled. This means when you click the "shutdown" button, Windows doesn't shutdown, it does a minimal hibernation. This means you shouldn't mount the partition with write privilidges in other operating systems, because when Windows is hibernated, it is depending on the filesystem of the system partition to remain unchanged between that shutdown and Windows's next startup. If you do write to a hibernated filesystem, I honestly cannot say what the concequences will be as I've never done it. Some people say it will damage the filesystem (and you'll lose data), others say the new data will simply be discarded. Regardless of whom is correct, I suspect neither results are desirable to you. So if you need both read & write privilidges on the Windows partition, make sure to disable or avoid fast-startup.

Steps To Disable Fast-startup On Windows 8/8.1/10:
1. Login as an Administrator.
2. Open the Start screen.
3. In the Start screen, search for "Control Panel", and click on it in the search results.
4. In the Control Panel, click on "System and Security", and click "Change what the power buttons do" (its under "Power Options").
5. In the Control Panel, click on "Change settings that are currently unavailable", and then uncheck "Turn on fast start-up (recommended)".

Related Links:

- https://msdn.microsoft.com/en-us/library/windows/hardware/jj835779%28v=vs.85%29.aspx



#6 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 2,604 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!

Posted 11 December 2015 - 02:44 AM

The first issue can be solved by left clicking your volume icon and going to "sound settings" and from there change the source of your audio (for example if you are using HDMI it should be there)

 

the second issue seems to be related to fast startup, which can cripple windows file access in linux

 

The third issue however sounds a bit bizarre, I suspect this is due to updated software however.

It could be a driver issue, its hard to tell, maybe you can give us your specs?


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#7 pcpunk

pcpunk

  • Members
  • 5,476 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:11:13 PM

Posted 11 December 2015 - 11:19 AM

Hi Tamim,

 

3rd issue

 

What device did you install Mint on? I suspect it was a partition on your HDD, but need to know for sure. Also, did you remove the DVD or USB from your computer that you burned the Mint ISO to, after you installed Mint?

 

Just trying to help out Al, he said to C: Drive on HDD that was used to make space for Linux 60GB Partition.

 

http://www.bleepingcomputer.com/forums/t/597954/which-linux-system-is-suitable/page-3#entry3882072


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#8 nuna

nuna

  • Members
  • 155 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:13 PM

Posted 11 December 2015 - 07:37 PM

1st issue: agree with MadmanRB.

 

2nd issue: agree with AI1000 (manual mounting or auto-mount with fstab), MadmanRB, and the answer by hollowface (which I consider on-topic and what is probably causing the issue)

 

Depending on the type of partition Linux Mint is installed to, 3rd issue might get solved when you get rid of 2nd issue.



#9 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:13 AM

Posted 12 December 2015 - 12:20 AM

Hi Tamim

 

Do you remember over at your previous Topic I asked a couple of questions? At

 

http://www.bleepingcomputer.com/forums/t/597954/which-linux-system-is-suitable/?p=3877470

 

I mentioned, in part

 

 

If we can see your current partition setup, that may be of assistance. You can call this up, in Windows 8.1, by one of:

  • Pressing the Windows key and X together and choosing Disk Management or

  • Use the Run command and type in diskmgmt.msc and press [ENTER] or

  • If you are familiar with the Command prompt (black screen white text), diskmgmt.msc and press [ENTER]

 

You can then use the Windows Snipping Tool to capture a screenshot for us.

 

If you need to know how to post a screenshot in the Linux Section, you can read, at Linux How-To and Tutorial Section, NickAu's Topic “How to post a screenshot Linux style”. Or click

 

http://www.bleepingcomputer.com/forums/t/558714/how-to-post-a-screen-shot-linux-style/

 

or for more choices in Image Hosting sites, see Moderator Stolen's Post here:

 

http://www.bleepingcomputer.com/forums/t/536686/how-do-i-post-a-screen-shot/?hl=%2Btinypic+%2Bimgur+%2Bphotobucket#entry3386653

 

… #2 refers.

 

... and you were able to post a link to a screenshot of your partitions, which I then reproduced in a later post.

 

But I hope you also read the links on how to Post, as they are important.

 

In the later Post, #26, at

 

http://www.bleepingcomputer.com/forums/t/597954/which-linux-system-is-suitable/?p=3881616

 

... I said, in part -

 

 

For the benefit of others, and until the OP gets access to a compatible image hosting site/learns how to post images directly here, I have reproduced below his Windows Disk Management setup:

 

 

oQRZFvX.png

 

 

From the looks of your setup:

 

  1. Your HDD is formatted to GPT - The GUID Partition Table, not MBR (Master Boot Record)
  2. You appear to have perhaps a Western Digital My Book, 4TB in capacity, perhaps not on or connected when you took your Piriform Speccy shot?

Both these elements make for a very, VERY, friendly Linux setup for you.

 

So what I have done is, perhaps briefly, joined your image posting site, postimg.org, and established that its content IS compatible with Posting screenshots directly to this forum, rather than just links.

 

Take a look at my screenshot below:

 

Screenshot_Image_codes_3floppy_unmount_M

 

 

You can see where I have highlighted that field "Direct Link". Right-click in it, select Copy and Enter.

 

Back in BC, at your "Reply Pane", 2nd line in the toolbar, 11 from the left, icon looks like a picture in a frame.

 

Click it, paste the URL (internet address), press Enter and the screenshot will appear in your Post.

 

It doesn't matter if the shot you saved with the Windows snipping tool is .png or .jpg I have tried and both work.

 

Now you are set to make use of "a picture is worth a 1,000 words"!

 

Having said all that, can you please now revisit Windows Disk Management, capture a current screenshot of your Partition setup, and post it here?

 

Thanks.

 

 

@MadmanRB, @others

 

The OP's specs are here, unless more recently updated:

 

http://postimg.org/image/96copsrbt/

 

 

Cheers all

 

:wizardball: Wizard



#10 Tamimwm

Tamimwm
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:01:13 PM

Posted 12 December 2015 - 04:47 AM

Hey Guys Thanks for all of your replies.

 

@ pcpunk I activated my firewall and used the terminal to update linux. Appreciated the linux update through the terminal, I am not sure how to update using the

" other way " yet.

@ AI @ hollowface @nuna It seems the issue was Windows, As hollowface explained windows was blocking ( it seems ) linux from accessing those partitions as a result I had to log into windows and restart to log into linux to get it to work , or that is what I think I really have no idea . Issue 3 got solved somehow after I disabled " Fast start Up "

 

@MadmanRB Got sound back and yes it is windows.

 

Windows existed to make some lives harder.

 

@ Wizard

Capture.png



#11 Tamimwm

Tamimwm
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:05:13 AM

Posted 12 December 2015 - 05:06 AM

@ AI I looked into auto mounting the hard drive , but I don't know how to edit it into fstab. But I also found this http://community.linuxmint.com/tutorial/view/92

 which has a program that does it. Shall I use it ?



#12 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 2,604 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:05:13 AM

Posted 12 December 2015 - 05:41 AM

Pysdm is long dead, a more modern equivalent is gnome-disk-utility


Edited by MadmanRB, 12 December 2015 - 05:42 AM.

You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#13 nuna

nuna

  • Members
  • 155 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:13 PM

Posted 12 December 2015 - 09:01 AM

As per MadmanRB recommendation (gnome-disk-utility):

 

ExscOvV.png

 

 

Most relevant mount options will be already filled. Basic edits in red:

4jxHu7P.png



#14 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:13 AM

Posted 12 December 2015 - 05:03 PM

@Tamimwm:

 

 

But I also found this http://community.linuxmint.com/tutorial/view/92

 which has a program that does it. Shall I use it ?

 

There are a plethora of Linux articles out there, some very dated. With the one you referenced, the giveaway is that it was written 5 years ago, last edited 5 years ago. If it was edited eg in the last 12 months, it might still have some merit. You did the right thing by asking first.

 

Thanks for the updated screenshot. Now that you are "packing pistols" with shooting, you can also use the gnome-screenshot (there is another called Shutter a lot of people like, but you can install that later) tool which ships with Mint, to capture your environment for us under Linux.

 

You can find it under Menu-Accessories, it may say "Take screenshot". If you right click it first, you can add to Panel or Desktop, I suggest Panel, and you can drag it to its own space on the Panel. Default save is to .png format.

 

You're doing fine, Tamim :thumbup2:

 

Last comment:

 

 

Windows existed to make some lives harder.

 

Windows is like a greedy child that won't share its toys or its candy, at least, not by choice. And it closes its eyes (in its File Manager, Explorer) and says "I can't see you, therefore you don't exist".

 

Enjoy Linux

 

:wizardball: Wizard



#15 Tamimwm

Tamimwm
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:01:13 PM

Posted 14 December 2015 - 11:33 AM

Thanks a  lot MadmanRB & nuna , that is a great guide. I should take note of dates more. Much appreciated wizard for all the guidance so far .

I hope I don't face anymore issues.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users