Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trouble launching programs - Won't even show on screen


  • Please log in to reply
2 replies to this topic

#1 AntonBerlin

AntonBerlin

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 08 December 2015 - 10:00 PM

Hi,

 

The problem I am experiencing is kind of hard to explain, so I'll do it by giving a few examples of what I am experiencing. Before I begin to explain, I want to say that I had these problems on Windows 7, and I tried alot of things, and for reasons I will cover later, I tried installing Windows 10 to see if that would change anything. So I'm currently on Windows 10 Pro 64bit, but my problem started out in Windows 7.

 

Example 1: I am a composer, so I regularely use a program called Cubase. One day when I was trying to launch it, it just didn't launch. It didn't show anything on the screen, and was just silent. I was on Windows 7 at the time, and when I looked at the task manager, I could see Cubase6.exe, but it only had about 120kb allocated memory. I solved this by installing an update to Cubase. Why that worked, I have no idea. It just stopped working one day, and I hadn't made any changes the days (or probably weeks) before. It's also worth noting that if I tried to open Cubase multiple times before I updated it, I could not force all of the instances to terminate (not even using taskkill /F -- that command said it terminated successfully, but the process was still running). A few would shut down but one or two would never terminate, no matter what I tried.

 

Example 2: I am also a programming, and I regularely program using two langauges; C++, and BlitzMax. BlitzMax is a Basic-dialect that uses gcc to compile some of it's core libraries, as they are written in C++, so both use gcc. Everything worked fine until a few days ago, when the same thing started to happen here (I am still running Windows 7 at this time). I was going to sit down and work on a program I am developing, and suddenly, the same thing started to happen to the program I was developing. The compiler compiled the code, and linked it to an executable, and tried to launch it. It's a command-line tool, and I got a cmd-window to open, but nothing showed. I tried to write a new program with nothing in it, just an empty int main() function, and nothing else. The same thing happened. And like with Cubase, I could not terminate all instances. The program would use around 120 kb of memory, and then just freeze.

 

Example 3: I tried to write a very small program in BlitzMax instead. I wrote a simple Hello World program. The same thing happened here. It would compile, but it would not run, and it used around 120kb of memory.

 

At this point I was thinking maybe it was my hard drive that housed the g++ compile and the blitzmax compiler that was acting up. So I reinstalled all of my compilers on another drive (removing them first from the original drive), and reconfigured everything to use the new paths for both compilers. Still the same problem. Then I tried moving the code to another harddrive, or even writing new code and saving that on another harddrive, and still the same problem.

 

This made me think that maybe there was something wrong with my RAM or something, so I used the Windows Memory Diagnostic tool from Windows 7 to check the RAM for errors. It took 2 days (I have alot of RAM and did 2 passes), and no errors were found. No other program has ever exhibited this weird behaviour. Only Cubase before I updated it, and now the programs generated by the c++ compiler and bliztmax compiler.

 

Then I thought that maybe because Cubase worked when it was updated and the executables and libraries were exchanged with new ones, that maybe something was broken in Windows, so I thought "Hey, then this is probably a good time to take advantage of the fact that Microsoft is letting me update to Windows 10 for free!", so I did just that (after I installed all the updates in Windows update first).

 

Now I am in Windows 10, and the problem remains, however now it reads 0,5MB memory, and now I can't see the processes themselves, but rather the programs that compile the processse and try to run them, and now I can shut down the processes if I want to. However, when I program, nothing launches. Not even empty programs or simple Hello World programs. So it seems to me the problem is still here, but that it acts another way in Windows 10 because of changes in how the OS handles applications or something.

 

Anyway, this is the best I can explain my problem. Hopefully this is a good enough explanation for you guys to understand what I am experiencing.

 

Can someone help me? I am taking a course in programming right now in a university that I am required to take, and I am required to write alot of code at home. Right now I can't do that, and it is starting to become quite a problem.

 

Thanks in advance,

Anton


Edited by AntonBerlin, 08 December 2015 - 10:06 PM.


BC AdBot (Login to Remove)

 


#2 AntonBerlin

AntonBerlin
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 09 December 2015 - 06:44 AM

UPDATE: I realized that if I try to run my compiled programs outside of the IDE in Windows 10, they don't even show up in the task manager. They did show up but using around 120kb of memory in Windows 7, but in Windows 10 they don't even show up. All that happens is that Explorer.exe starts to load indefinitely (it still works, just has that loading circle next to the normal mouse pointer).

 

UPDATE 2: The process shows up when using the command "tasklist", and they use 76kb of memory, no matter which of programs I've compiled I try to run. When I try to use "taskkill /F" it says it terminates the process successfully, but it is still in the list when I use "tasklist". If I try to use taskkill again it just says that no instance of the process is running. But I still find it in the list when I use "tasklist".

 

NOTE: This problem happened with other applications in the past. Now it only happens with applications that I have compiled myself.


Edited by AntonBerlin, 09 December 2015 - 06:46 AM.


#3 AntonBerlin

AntonBerlin
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 09 December 2015 - 07:10 AM

This is the output I get from windbg when I use the command "kp 20" to get the call stack:

00000000`000df320 00007ffa`21f9f976 ntdll!LdrInitShimEngineDynamic+0x360
00000000`000df360 00007ffa`21fd1525 ntdll!EtwEventProviderEnabled+0x17d6
00000000`000df750 00007ffa`21f86a8e ntdll!memset+0x15f25
00000000`000df7d0 00000000`00000000 ntdll!LdrInitializeThunk+0xe

I only get this output from some of the frozen processes though. Most of them won't even work in the debugger. All it does is show a blank Command window with the text "Debuggee not connected" when I try to attach the debugger to one of the processes. Randomly it lets me attach it though, and that is when the above text is shown.

 

Also, if I try to use the "Open executable" option in the debugger, it shows a Command window with only the following text:

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: J:\Work\Dropbox\Programming\Libraries\GUI2\UnitTests\Main.exe

And the text "Debuggee not connected" is where the command line should be shown. And I can't start the debugger from the Debug menu either.

UPDATE: At this point, when I have opened the executable from inside the debugger, and then go to "Attach process" fro mthe File menu, the debugger crashes.


Edited by AntonBerlin, 09 December 2015 - 07:12 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users