Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Certain file associations not working


  • Please log in to reply
5 replies to this topic

#1 johnsig

johnsig

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:15 PM

Posted 05 December 2015 - 04:01 PM

On my desktop computer, when I click on a .ods file in File Explorer, the splash screen for Open Office shows briefly but the file is not opened. Most other associations seem fine. If I check the association for an .ods file it shows Open Office Calc.

 

I would post this in an Open Office forum except I also have it on my laptop configured the same and the laptop opens .ods files fine.

 

Both computers are running the current verrsion of Windows 10. I feel like I may have a service turned off on my desktop but have been unable to find it.

 

Any ideas?



BC AdBot (Login to Remove)

 


#2 Wolverine 7

Wolverine 7

  • Members
  • 746 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bournemouth,UK
  • Local time:07:15 PM

Posted 05 December 2015 - 05:24 PM

Has a .~lock..odt# file been generated?If so delete it.Also (especialy if you deleted a .~lock..odt# file),try to open the file by opening a blank writer and inserting the file that way rather than clicking on it to open,that may alow it to open.Sometimes this will open a glitchy .odt file.

 

Also you could try deleting or renaming your User Profile,in win 10 you can type  %appdata% Open the folder,- Roaming - on this system,find the Open Office folder and rename it (To something like Open Office Old..(If that works we know a profile issue is involved,if not it isnt).

 

The Open Office profile isnt where it was last time i looked,which might have been on xp,so try renaming rather than deletion for now,you can always rename it

back if nessesery.



#3 johnsig

johnsig
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:15 PM

Posted 06 December 2015 - 09:56 AM

Thanks for trying to help

 

I searched C: for .~lock..odt# without finding anything. Where would this file be located?

 

I renamed the OpenOffice folder and clicking on the .ods file resulted in a wizard appearing which created a new OpenOffice folder but after that clicking on .ods resulkted in same activity as above.

 

I can easily open the .ods file by going through the open menu in Calc but I would like to be able to do it from file explorer as well.



#4 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 7,482 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:03:15 PM

Posted 06 December 2015 - 01:13 PM

I know this sounds stupid, but I've seen "stupid" work for some of these really odd errors before:  try resetting the file association to something like notepad, restarting the computer, and seeing if that change sticks.  If it does, then try changing the association back to Calc by browsing for the program, then see if that sticks.

 

I've done this sort of thing, which amounts to a parallel to "completely shut down and restart your system," which often mysteriously cures any number of ills.


Brian AKA Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

 

     In a modern society where everyone thinks their opinion deserves to be heard nothing annoys me more than individuals who mistake their personal preferences for fact.

         ~ Commenter TheCruyffGurn on the The Guardian website, 8/13/2014

 

              

 


#5 Wolverine 7

Wolverine 7

  • Members
  • 746 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bournemouth,UK
  • Local time:07:15 PM

Posted 06 December 2015 - 03:30 PM

I searched C: for .~lock..odt# without finding anything. Where would this file be located?

 

I renamed the OpenOffice folder and clicking on the .ods file resulted in a wizard appearing which created a new OpenOffice folder but after that clicking on .ods resulkted in same activity as above.

 

I can easily open the .ods file by going through the open menu in Calc but I would like to be able to do it from file explorer as well.

 

 

Ok,it didnt create the ~lock..odt# file (its supposed to stop other people editing your file,but it can interfere with opening sometimes),so scrap that,i havnt had a blip out of Open office since xp,it used to do all kinds of odd glitchy things,so yes try britechguys suggesstion..on xp it used to do strange file opening things and i would fiddle about for ages,get nowhere and  then reinstall it and that would fix it...you could try that.

 

Dont know if this makes any sense to you,but i think i might  try the troubleshoot compatability option from the right click menu,i havnt had this issue on 10 with Oo

but its worked for people on win 8.



#6 johnsig

johnsig
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:15 PM

Posted 06 December 2015 - 03:46 PM

OK, big discovery. This situation occurs only with Open Office Calc and Writer. Not with .jpg, .mp3, .pdf, .paf. Moreover it only occurs on files in the Public area in my Network folder. Open Office works fine everywhere else and all other applications work with the Network folders. I'm back to thinking its an Open Office issue and will post in their forum..

 

I did try Brian's suggestion and the associations I set are sticking fine.

 

Thanks!!!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users