Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't setup ICS, sharing (null) error when enabling, invalid IP, can't bridge


  • Please log in to reply
1 reply to this topic

#1 ace1234

ace1234

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:30 AM

Posted 05 December 2015 - 05:29 AM

I have been banging my head against a wall here.. Last night I was up until 4 am trying to setup an ICS so I could share my internet from my laptop's wifi to my desktop PC via an Ethernet cable. I have spent the entire morning trying some new things after a fresh nights sleep, but I keep getting issues and no solution.

What I have done so far:
I have made sure that ICS is enabled on both PC's
All dependent services for ICS are enabled
Firewall enabled
flashed BIOS
Reinstalled ethernet driver
Reset IPV4/6
set both IPV4/6 to auto IP and DNS
Removed adware and malware


When I attempted to share my main wireless Wifi connection and allow ICS to share it with the ethernet I got "An error occurred when enabling internet connection sharing. (null)"

Google results said to enable all dependent services, and then firewall, which I did, but I still got the error and could not share my connection.

I tried to bypass or try another solution so I tried to bridge the two connections, but I got another message, not necessarily an error: "To create a Network Bridge, you must select at least two LAN or High-Speed Internet connections, that are not being used by Internet Connection Sharing."

I am not sharing my connection and I don't believe ICS is actually being used so this really confuses me. I even disabled ICS and tried to bridge the connections, but I received the same message.

Originally I had tried to troubleshoot the ethernet connection via Windows troubleshooter and it told me that the connection has an invalid IP configuration.

The network shows up as a public "Unidentified Network". I am able to see both computers and share files, but I have no access to internet.

 

Any help would be appreciated. I am at a loss.


Edited by ace1234, 05 December 2015 - 05:31 AM.


BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:09:30 PM

Posted 05 December 2015 - 05:13 PM

"I have made sure that ICS is enabled on both PC's"

 

Only do the pc with internet access

 

Make sure the firewall allows ICS.  Post the results of a ipconfig /all  [note the all] from a command prompt and post the results for review.  This is only from the machine hosting the internet via ics which you mention as the laptop.


Edited by Wand3r3r, 05 December 2015 - 05:14 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users