Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Knoppix Not Working Through My Router


  • Please log in to reply
7 replies to this topic

#1 Heretic Monkey

Heretic Monkey

  • Members
  • 1,122 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NCSU
  • Local time:11:43 PM

Posted 24 July 2006 - 10:42 AM

Well, there hasn't been any activity here in almost a month, so hopefully this will be seen/replied to....

Anyway, i recently downloaded Knoppix 5.0 for my windows-less box, and it's an awesome live distro, EXCEPT it won't connect to the internet through my router. I can connect the computer straight to the modem and have it recognized after i restart the computer, but then my other computer is SOL regarding internet connection.

I know my router worx with the knoppix computer (as i used it when windows was still installed), and the router was working when knoppix couldn't connect with it. I've tried going into the control center to change the connection settings, but nothing i saw seemed like it'd be any help.

So, how can i get knoppix 5.0 to recognize the internet connection through my router? I'm not on a proxy, and 3.6 recognized it without any hassle....

BC AdBot (Login to Remove)

 


m

#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:43 PM

Posted 24 July 2006 - 11:49 AM

I think the first step is to make sure knoppix is recognizing your computers ethernet adapter. Do you use dhcp there or is it static ip addresses?

#3 Heretic Monkey

Heretic Monkey
  • Topic Starter

  • Members
  • 1,122 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NCSU
  • Local time:11:43 PM

Posted 24 July 2006 - 01:01 PM

I'm pretty sure it's just a static IP configuration. I'm not real familiar with "dhcp", and haven't really come across anything about it in setting up the router/connection settings for my 2 computers.

#4 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:43 PM

Posted 24 July 2006 - 01:06 PM

If you get to a shell and type /sbin/ifconfig -a, it should list any ip addresses configured to the ethernet card. Can you ping any other machines on your network?

#5 Heretic Monkey

Heretic Monkey
  • Topic Starter

  • Members
  • 1,122 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NCSU
  • Local time:11:43 PM

Posted 24 July 2006 - 01:16 PM

Wow..... not quite sure what to make of the results that came up..... so, uh, i'll just post them :thumbsup:
eth0	  Link encap:Ethernet  HWaddr 00:13:D3:0D:61:0D
		  inet addr:66.57.109.213  Bcast:255.255.255.255  Mask:
255.255.252.0
		  UP BROADCAST RUNNING MULTICAST  MTU:576  Metric:1
		  RX packets:153828 errors:0 dropped:0 overruns:0 frame
:0
		  TX packets:25121 errors:0 dropped:0 overruns:0 carrie
r:0
		  collisions:0 txqueuelen:1000
		  RX bytes:23101708 (22.0 MiB)  TX bytes:2045811 (1.9 M
iB)
		  Interrupt:17 Base address:0xa000

eth1	  Link encap:UNSPEC  HWaddr 00-10-DC-00-00-A5-60-59-00-
00-00-00-00-00-00-00
		  BROADCAST MULTICAST  MTU:1500  Metric:1
		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
		  TX packets:0 errors:4 dropped:4 overruns:0 carrier:0
		  collisions:0 txqueuelen:1000
		  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo		Link encap:Local Loopback
		  inet addr:127.0.0.1  Mask:255.0.0.0
		  inet6 addr: ::1/128 Scope:Host
		  UP LOOPBACK RUNNING  MTU:16436  Metric:1
		  RX packets:38 errors:0 dropped:0 overruns:0 frame:0
		  TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
		  collisions:0 txqueuelen:0
		  RX bytes:1900 (1.8 KiB)  TX bytes:1900 (1.8 KiB)

sit0	  Link encap:IPv6-in-IPv4
		  NOARP  MTU:1480  Metric:1
		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
		  collisions:0 txqueuelen:0
		  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Right now i'm on my knoppix box running straight to the modem. My other computer is disconnected from the internet. If i were to try and run this through the router, i couldn't even get to the router setup page for some reason. A while ago, i was thinking it had something to do w/ the router settings, but i couldn't even get to 192.168.1.1 ....

#6 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:43 PM

Posted 24 July 2006 - 01:30 PM

Ok ..i see it was assigned an ip address from the router (66.57.109.213).

And I am able to ping that ip address. SO it appears to be live as you said previously.

Now I guess the question is whether or not the windows machine gets ip address from the router or if one is statically assigned. If you actually statically assign the ip address then you need to statically assign it to the Knoppix config as well.

Set it up so its behind the router again, run netcardconfig, and assign a static 192. address to it. Then see if it works. Use the same dns and gateway as the windows box, but a differen 192.168.1.X address than the gateway or windows machine.

#7 Heretic Monkey

Heretic Monkey
  • Topic Starter

  • Members
  • 1,122 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NCSU
  • Local time:11:43 PM

Posted 24 July 2006 - 01:50 PM

Alright! It works. I just ran the "netcardconfig" like you told me to and transfered the same numbers from the "ipconfig" on the windows box. Well, all except for the individual ip address.

Thanx for the help grinler :thumbsup:

#8 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:43 PM

Posted 24 July 2006 - 02:06 PM

My pleasure :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users