Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't access external HDD.


  • Please log in to reply
2 replies to this topic

#1 Alice8

Alice8

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:49 PM

Posted 27 November 2015 - 01:40 AM

Hi,
I can't access my WD MYBook Esssential 2TB thru "My Computer" on Windows Vista.
The external HDD is displayed in "Device Manager" under "Disk Drives" but not shown in "Disk Management"
I also can't access the external HDD on another dekstop running Windows 7.
I've tried a different USB & power cable with no success.

WD Diagnostic Tool is out of the question as drive is not recognised at all.
Please advise. Thanks.

 

 

 

 



BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,236 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:01:49 AM

Posted 27 November 2015 - 02:55 AM

The drive is broken or corrupted, sorry.

 

To try and rescue your data (if you wish), download and burn Parted Magic then boot your machine with it. Use the "file manager" application to copy your files over to another hard drive.

 

This isn't your only option to try, but the best first option.



#3 KCJay

KCJay

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:49 AM

Posted 29 November 2015 - 06:55 PM

Try and uninstall it in Device Manager, then go back to Disk Management and assign it a drive letter.  That has worked for me before.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users