Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How to fix Privacy Error on Chrome & Certificate issues?


  • Please log in to reply
5 replies to this topic

#1 helpmecomputer

helpmecomputer

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:07:39 PM

Posted 26 November 2015 - 03:08 PM

Hi,
 
I've been having an issue for a while where I'm unable to use Internet Explorer or Google Chrome (I'm using Firefox right now, for some reason that works perfectly) to access many sites because I get the error:

Your connection is not private.
Attackers might be trying to steal your information from www.google.com (for example, passwords, messages, or credit cards). NET::ERR_CERT_AUTHORITY_INVALID
 
 
This isn't only a browser issue, however. I've also been having problems connecting to lots of applications on my computer like Windows OneDrive and online games like League of Legends (more on that below).
 
 
I was wondering how I can fix this issue. Here's some more info about the exact error I'm getting:

-Sites like Google.com, Youtube.com, Yahoo.com, etc. give me the error above when I use the chrome browser.
-Some sites work. Sites like Amazon.com, Weather.com, etc. seem to work just fine when I use the chrome browser.
-I don't get this error on Firefox. I think this is because Firefox stores its own certificates.
-When I try to use many other programs (Skype installer, Windows OneDrive, etc.), I get a popup error message, "This page requires a secure connection. The Certificate Issuer for this site is untrusted or unknown. Do you wish to proceed?" and no matter how many times I click "yes" it keeps popping up again.
-I'm also getting connection errors on a lot of online games I try to play. For example, I get a similar issue trying to log in to League of Legends, receiving a lot of the Certificate Issuer error messages and then one along the lines of "Cannot connect to pvp.net servers."
-Connecting to "www.google.com/?gws_rd=ssl" works, but connecting to "https://www.google.com/?gws_rd=ssl" doesn't.
-Connecting to "www.website.com" and "http://www.website.com" works, but connecting to "https://www.website.com" doesn't.
-The certificate information listed for 'www.google.com/?gws_rd=ssl' is *.google.com, which I believe is correct, but for 'https://www.google.com/?gws_rd=ssl' it is www.google.com.
 
Here's what I've tried so far:

-Synchronizing date and time, including Internet date and time
-Changing my public DNS server to Google's DNS server (IPV4 and IPV6)
-Ran a MalwareBytes scan, showing no malicious items
-Cleaning cache through Google Chrome settings and through CCleaner
-Flushing DNS through Command Prompt
-Updating Google Chrome and re-installing Google Chrome
 
Site note:
I have a vague suspicion that something's messed up with firewalls interfering, since I currently have Windows Defender active (since upgrading to Win10) and McAfee Security Scan Plus (leftover from Win7) installed on my computer. I've tried to uninstall McAfee but can't seem to do so (I've tried using "Add or Remove a Program", the RAR tool from the McAfee website, and CCleaner's uninstall tool as well as running the registry cleaner tool from CCleaner). For some reason, McAfee won't uninstall. I can provide more information about this problem if needed.
 
I just want to get these issues fixed. They've existed since I upgraded to Windows 10 about a month ago, and they're really annoying to deal with.
 
Currently I'm using Firefox version 42.0, and I'm using a wireless connection.
 
I'll provide any more information needed as requested.

Thanks in advance!


Edited by helpmecomputer, 26 November 2015 - 07:06 PM.


BC AdBot (Login to Remove)

 


#2 ChuckPasadena

ChuckPasadena

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas, TX
  • Local time:06:39 PM

Posted 26 November 2015 - 03:55 PM

Actually been such a constant issue there's the thread for it. The following link takes you directly to it, Follow the steps in the post and if you still have issues or further questions just add a reply to the thread and one of the people with more experience with browsers will reply as soon as they spot it.

 

http://www.bleepingcomputer.com/forums/t/41067/cant-access-secure-sites/



#3 helpmecomputer

helpmecomputer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:07:39 PM

Posted 26 November 2015 - 07:06 PM

This isn't only a browser issue. Thanks for the referral, though. I've posted there and am hoping for a response.



#4 ChuckPasadena

ChuckPasadena

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas, TX
  • Local time:06:39 PM

Posted 26 November 2015 - 07:20 PM

This isn't only a browser issue. Thanks for the referral, though. I've posted there and am hoping for a response.

Not a problem. I happened to glance at the topic of the thread and didn't what you to end up waiting.

 

And they should get you straightened right out. My experience with Chrome amounts to seeing the top of it running on someone's laptop 10 feet away.



#5 helpmecomputer

helpmecomputer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:07:39 PM

Posted 28 November 2015 - 10:44 AM

Hello, and thank you so much for all your help. I went back to win 7 from win 10, and that fixed the problem. I can now connect to https://www.google.com with no issues.

I think it may have had something to do with a system registry error or a firewall issue, but either way, it's fixed now.


#6 Lvlpost

Lvlpost

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:hawai
  • Local time:06:39 AM

Posted 19 October 2017 - 05:11 AM

This solution is just a temporary method to bypass the SSL connection error. You can’t fix this problem permanently, but this will make you don’t see all warnings that related to SSL errors in Google Chrome browser. To do that, you need to start Chrome with the parameter –ignore-certificate-errors.

Step 1. On your desktop, you right-click on the Google Chrome shortcut and choose Properties.
Step 2. In Target box, you add this after quotes –ignore-certificate-errors
It’s look like this: “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” –ignore-certificate-errors
Step 3. Click OK to apply changes.

Hope this helps you https://windows10freeapps.com/fix-your-connection-is-not-private-error-google-chrome/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users