Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Enlarge Grub boot text?


  • Please log in to reply
45 replies to this topic

#1 MalwareMutilator

MalwareMutilator

  • Members
  • 931 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:54 PM

Posted 26 November 2015 - 02:19 PM

Hi all,

 

I just finished installing Mint 17.2 on my old Dell XP desktop for dual-boot.  It works great and I love Mint.  Only problem is my old eyes are having trouble with the small text during the boot selection process.  Is there any easy way to enlarge the text, or maybe even add a simple GUI?  I saw one program on the web somewhere, but I didn’t think it works with XP.

 

Thanks  :thumbup2:



BC AdBot (Login to Remove)

 


#2 Agouti

Agouti

  • Members
  • 1,548 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 26 November 2015 - 02:59 PM

Grub Customizer

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer



#3 MalwareMutilator

MalwareMutilator
  • Topic Starter

  • Members
  • 931 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:54 PM

Posted 27 November 2015 - 06:32 AM

I’m very, very new to Linux.  Never knew what a PPA was or how they worked.  In fact, I’ve never even heard of them before.

 

Thank you very much.  I learned something new.  :thumbup2:



#4 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:54 AM

Posted 27 November 2015 - 07:52 AM

You can also do this without installing anything.
 
1) At your dual-boot Grub menu, press c to bring up the Grub command prompt.
2) Type vbeinfo and take a note of the resolutions listed.
3) Type reboot and boot your computer into Mint.
4) In Mint, open a terminal and type:
sudo nano /etc/default/grub
(This command will open the Grub global configuration file in nano text editor)
 
5) Using the directional arrows on your keyboard scroll down to where it says:
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=1280x1024

 
6) Using your backspace key, delete the # from the line that says # GRUB_GFXMODE (deleting the # symbol is known as "uncommenting the line." (The # at the start of the line tells the computer to treat the line as a comment. Uncommenting the line means the computer will do what it says))
7) In place of the 1280x1024 (your resolution may not be the same as mine) type a lower resolution that you noted down in step 2.
8) Save and exit nano (hold down Ctrl and press x, then press y)
9) Update Grub (open a terminal and run this command: sudo update-grub)
 
Now reboot your computer and see if you like the size of the text in your Grub boot menu. If not, repeat steps 4 - 9 and use a different resolution.

Edited by Al1000, 27 November 2015 - 08:01 AM.


#5 MalwareMutilator

MalwareMutilator
  • Topic Starter

  • Members
  • 931 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:54 PM

Posted 28 November 2015 - 07:44 AM

Thanks to both of you for your help.  I haven’t tried to correct the fonts yet because I am still struggling with my printer issues.  I will post back after I (hopefully) resolve my printer.

 

Thanks again.  I really appreciate your help.  :thumbsup:



#6 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 6,987 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:08:54 PM

Posted 06 December 2015 - 05:08 AM

I had this issue after installing a nVidia graphics card, only mine was the opposite, the print was in XXL letters, and had to reduce the size of the print to 1920x1080, it was at like 800x600 (or similar) setting. Still, I don't see the normal Linux Mint splash screen (the Linux Mint logo), rather four green dots, if that many, if starts so fast. I'm not going to worry over that, considering the rest of the OS is fine. 

 

Hopefully when Mint 18 is released, there will finally be inbuilt support for nVidia GTX series graphics cards, at least enough to install the OS, and afterwards install the native driver from a PPA. Xorg drivers are OK for some computers, though not for anything less than 5 years old & powerful, though could see it with a budget computer & card, may be the best option. 

 

Feel free to let us know if further assistance is needed. :thumbup2:

 

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#7 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:54 AM

Posted 09 December 2015 - 02:52 AM

Hi MalwareMutilator

 

@Al1000:

 

Hate to set a cat amongst the pigeons, but vbeinfo may have gone the way of the Dodo. Apparently it was headed that way towards the end of the original GRUB (now renamed Grub Legacy), and is no longer in the latest GRUB2.

 

Sources I have checked show varying lists of the CLI commands from pressing "c" at the initial Grub entry point, and they vary markedly.

 

They include but are not limited to the following:

 

http://www.binarytides.com/ubuntu-fix-nvidia-graphics/

 

http://askubuntu.com/questions/577486/how-do-i-run-vbeinfo *

 

http://askubuntu.com/questions/103516/grub2-use-maximum-detected-resolution

 

These from a Google search under "grub2 boot linux command".

 

* Note that I got the same errors as the participant, under my Grub2 boot CLI attempt.

 

At that point, I went into my own Grub2 and hit "c". From there, I pressed the Tab button, which reveals a list of Grub CLI commands. vbeinfo was not included.

 

I googled under "grub2 export command list at boot" and "grub2 cli commands export to file", but to no avail, as I expect that there are no files then available to grub to export to?

 

So I took a snap on the old mobile (cell) phone, couldn't get the full picture clearly, but here it is:

 

# you can see them in real GRUB with the command `vbeinfo'Zxe1ohV.jpg

 

 

No vbeinfo in the "v's".

 

http://members.iinet.net/~herman546/p20/GRUB2%20How%20To%20Boot%20From%20CLI%20Mode.html

 

and

 

http://members.iinet.net/~herman546/p20/GRUB2%20CLI%20Mode%20Commands.html

 

also formed a part of my travels, but ultimately I could not find a definitive answer.

 

Note too, that my own "/etc/default/grub" features the same "# you can see them in real GRUB with the command `vbeinfo' " as yours does.

 

I haven't a current Linux Mint running, but if I could ask of the OP:

 

  1. Can you reboot and at the Windows/Linux option press "c", then Tab, and tell us if vbeinfo is there or just the video references?
  2. Can you tell us what desktop of Linux Mint 17.1 you are running, eg Mate, Cinnamon or KDE?

If you are not sure on the latter, you can enter Terminal via Ctrl-Alt-t and type and enter

env | grep DESKTOP_SESSION=

and press Enter.

 

I have to skip but if answers are available, I would like to bump my Posts at

 

http://www.bleepingcomputer.com/forums/t/570703/linux-for-the-visually-challenged/

 

to include the outcomes, or Al might wish to contribute there.

 

Later

 

:wizardball: Wiz



#8 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:54 AM

Posted 09 December 2015 - 02:16 PM

Hate to set a cat amongst the pigeons, but vbeinfo may have gone the way of the Dodo. Apparently it was headed that way towards the end of the original GRUB (now renamed Grub Legacy), and is no longer in the latest GRUB2.

 

 

It works for me.

 

vbeinfo_zpsfqvp8vtl.jpg



#9 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:54 AM

Posted 09 December 2015 - 05:04 PM

Hard to dispute a screenshot, Caledonian one (or is that only the North?).

 

You are a better photographer than I, might I trouble you for the list of commands output when you press Tab at grub> ?

 

As I say, I am extremely interested in this subject, not just because the OP and I are visually challenged, but for others, as well.

 

Al, with your Kubuntu, LXLE, Lubuntu &c - are they all on the same machine? If not, can you take a snap from the other/s as well?

 

Thanks muchly

 

:wizardball: Wizard

BTW I will be interested to hear what the OP finds if he does likewise.



#10 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:54 AM

Posted 09 December 2015 - 07:21 PM

Here you go:

grubtext_zpsyb146iyq.jpeg

LXLE is on my laptop which I'm repairing so can't use it now, and Lubuntu boots from Grub2 in Kubuntu which is what my screenshot is of. It might be helpful to compare grub versions. Mine is:
al@my_desktop_pc:~$ grub-install --version
grub-install (GRUB) 2.02~beta2-9ubuntu1.4

Edited by Al1000, 10 December 2015 - 03:23 AM.


#11 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:54 AM

Posted 10 December 2015 - 01:37 AM

Mate can you re-post that image?

 

I get

 

4XXQYi7.png

 

... sweet, but not very helpful. Right-clicking on the image and copying location takes me to Photobucket album but says picture removed or moved. However the earlier one with the vbeinfo output was fine.

 

On the upside, I ran vbeinfo on Elaine's old Compaq and the output was similar to yours posted.

 

Elaine's (which has LXLE 32-bit and Peach 32-bit) has just been updated yesterday, and is running Grub  (GRUB) 1.99-21ubuntu3.18

 

Output from the Toshiba Satellite on which I am based is:

grub-install --version
grub-install (GRUB) 2.02~beta2-29

Mine is taken from within Ubuntu Mate 15.10 Wily Werewolf, as the other Distros on it are Mageia 5 (RPM-based) and Sabayon 15.10 (Gentoo-based) and I am still learning their command syntax.

 

With Elaine's output, you are probably aware that Grub2 started at v1.98 (don't ask me), so they're all Grub2 but mine may be the most recent?

 

I would also be interested to learn of the OP's output from

grub-install --version

...can you do that for us, MalwareMutilator?

 

I have Linux Mint 17.2 Rafaela, Cinnamon, the 32-bit, on the Acer AIO, but it is out of commission at the moment.

 

Al, you are in a better position to judge whether differences between Grub point versions is a Topic for elsewhere, but if you rely on the "vbeinfo" output as being a plank in your advice to the OP, then perhaps we have not strayed. What is your call?

 

Ta for the input, though

 

:wizardball: Wizard



#12 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 6,987 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:08:54 PM

Posted 10 December 2015 - 02:43 AM

 

 

6) Using your backspace key, delete the # from the line that says # GRUB_GFXMODE (deleting the # symbol is known as "uncommenting the line." (The # at the start of the line tells the computer to treat the line as a comment. Uncommenting the line means the computer will do what it says))

 

:bananas: :bounce: :guitar:

 

Al, following that instruction, for the very first time since installing my GTX 960 in April, am now able to see the Linux Mint logo after the Grub boot screen! :)

 

For 8 months, was looking at 4 green dots only, unless Mint booted before all were shown. 

 

This was exactly what the doctor ordered for those with nVidia cards that won't show the natural LM logo at boot, and the last thing that I couldn't fix during my install in the Topic created when purchasing/receiving the card in mid-April. There is no question that Al knows what he's speaking about here. That is, if the instructions are followed. Last night, I misunderstood & ended up with (as when I got the card) an XXL Grub boot menu (very low resolution). Actually was very close to fixing this when installing the card in my Topic, only didn't know to 'uncomment'  # GRUB_GFXMODE when finishing. 

 

Thanks a million! :thumbup2:

 

Cat


Edited by cat1092, 10 December 2015 - 04:44 AM.

Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#13 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:54 AM

Posted 10 December 2015 - 03:22 AM

I don't know why my screenshot isn't showing up as it works for me:
 
temp_screenshot1_zpsre3mvfvb.jpeg
 
I'll repost the link in post #10 anyway in case it makes any difference.

Al, following that instruction, for the very first time since installing my GTX 960 in April, am now able to see the Linux Mint logo after the Grub boot screen!


Cool. I'm not sure why that would affect the logo, but I'm pleased to hear it does. :)

#14 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 6,987 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:08:54 PM

Posted 10 December 2015 - 04:36 AM

I'm soon going to clean install MInt 17.3 MATE, as the upgrade from 17.1 to 17.2 didn't pan out well, so will keep this Topic, in addition to my own months back where both you & Nick assisted me greatly, to help with the install. 

 

As well as the recent added content that Nick provided in his Topic in regards to installing nVidia drivers. There's lots of ways to fix common issues, especially when there's those who knows these solutions & makes them available for all of our members to see. :)

 

Actually there were two lines that I uncommented, the one below the resolution as well. At any rate, it worked. :thumbup2:

 

 

GRUB_GFXMODE=1920x1080

GRUB_GFXPAYLOAD_LINUX=keep
 

 

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#15 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:54 AM

Posted 10 December 2015 - 04:15 PM

@cat1092:

 

 

 

:bananas: :bounce: :guitar:

 

Al, following that instruction, for the very first time since installing my GTX 960 in April, am now able to see the Linux Mint logo after the Grub boot screen! :)

 

... so you understand my interest in seeing this Topic through, and having its content covered at Visually Challenged as well?

 

@Al1000:

 

 

I don't know why my screenshot isn't showing up as it works for me:

 

... and it works for me, now. Thank you. I had with with someone else's post the other day, will track down whether it was Photobucket, but PM you if I find anything rather than take this issue off-Topic.

 

@cat1092:

 

 

Actually there were two lines that I uncommented, the one below the resolution as well. At any rate, it worked. :thumbup2:

 

... quite so. Apparently you can try it with the one line uncommented, and if that does not "take" or "stick", the line

GRUB_GFXPAYLOAD_LINUX=keep

... will likely do the trick.

 

In any event, there is more to this than meets the eye (no pun intended), as below:

 

@Al1000:

 

 

Cool. I'm not sure why that would affect the logo, but I'm pleased to hear it does. :)

 

This is because the changes effected apply not only to the GRUB menu itself, but also affect

  1. the Splash Screens both in and out of boot/shutdown, and also
  2. the default size and resolution of text in a Terminal window

There may be more that I have not found yet.

 

As you can see from my screenshot at #7, I have no vbeinfo in my Toshiba Satellite's GRUB. Any number of other users may find the same. Brief research I have done indicates that the solution is not supported under grub-efi.

 

I think, though, that the vbeinfo output may not be necessary to achieving the rest of Al's method. In Al's case, the last resolution listed for him was:

 

1600 x 1200 x32

 

This is the resolution GRUB "prefers" to use, but as we understand, this can be changed.

 

Also, in the line, now uncommented:

GRUB_GFXMODE=<my resolution>

... you can string together a number of resolutions, separated by semicolons, and have GRUB try them one by one.

 

Apparently, a number of changes have been made to GRUB since October. Launchpad.net list a plethora of point version issues, and I am still wading through release differences to see what effect these may have, and what happened to vbeinfo.

 

Once again, input from the OP, MalwareMutilator, would be of considerable assistance here, and I will summarise what I asked of him.

 

@MalwareMutilator:

 

Could you please let us know:

 

 

  1. Can you reboot and at the Windows/Linux option press "c", then Tab, and tell us if vbeinfo is there or just the video references?
  2. Can you tell us what desktop of Linux Mint 17.1 you are running, eg Mate, Cinnamon or KDE?

If you are not sure on the latter, you can enter Terminal via Ctrl-Alt-t and type and enter

env | grep DESKTOP_SESSION=

and press Enter.

 

and

 

 

I would also be interested to learn of the OP's output from

grub-install --version

...can you do that for us, MalwareMutilator?

 

Thanks.

 

:wizardball: Wizard

BTW - "grub-install --version" is performed at the Terminal prompt, not at boot in the grub> session.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users