Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer won't turn on when attempting to use new GPU


  • Please log in to reply
15 replies to this topic

#1 SammyJamew

SammyJamew

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 26 November 2015 - 01:33 PM

Recently I've attempted to replace my old graphics card (AMD Radeon HD 6450) with a new one (AMD Radeon R7 250), did exactly what all those tutorials I've read about it said. Uninstalled old drivers, turned my computer off, took out the old car, put the new one in, turned my computer back on, everything was working fine, installed new drivers, turned my computer back off and on, but there was no beep and it shut itself off after a few seconds. Took the new card out and put the old one back in and the computer turned on normally, been keeping a close eye on it for a few days now and nothing unusual has happened yet.

 

Tried again last night and got the same result as a couple of days ago. I'm wondering what could be causing it.



BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 26 November 2015 - 01:37 PM

What is the make and model of this computer?

 

Please download and install Speccy to provide us with information about your computer.  Clicking on this link will automatically initiate the download. 
 
When Speccy opens you will see a screen similar to the one below.
 
speccy9_zps2d9cdedc.png
 
Click on File which is outlined in red in the screen above, and then click on Publish Snapshot.
 
The following screen will appear, click on Yes.
 
speccy7_zpsfa02105f.png
 
The following screen will appear, click on Copy to Clipboard.
 
speccy3_zps1791b093.png
 
In your next post right click inside the Reply to Topic box, then click on Paste.  This will load a link to the Speccy log.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 29 November 2015 - 08:56 AM

http://speccy.piriform.com/results/B1PVSomF4SZA51Oad0D4FFA



#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 29 November 2015 - 12:24 PM

What is the make and model of the PSU?

 

The new GPU requires a PSU with 400W  @ 20A on the 12V rail.


Edited by dc3, 29 November 2015 - 12:28 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 29 November 2015 - 07:18 PM

Wasn't really sure of the model of the PSU, so here's a picture of it instead.

 

tumblr_nylq4j1Dk71r3eanzo1_1280.jpg



#6 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 30 November 2015 - 09:14 AM

The total wattage is 420W, and 12V rail amperage is 15A.  This could be your problem since that card requires 20Amps on the 12V rail.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#7 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 30 November 2015 - 09:20 AM

Got any advice on what kind of PSU I should buy then?



#8 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 30 November 2015 - 09:39 AM

Here you go...

 

500W with 38A on the +12V rail

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16817139027

 

Edit:  This is a cyber Monday price.


Edited by dc3, 30 November 2015 - 09:39 AM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#9 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 30 November 2015 - 11:42 AM

Would be great and all, but problem is that that site doesn't ship to Slovenia, I'll have to find it elsewhere. But thank you anyway, at least now I know what kind of PSU to look for.



#10 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 30 November 2015 - 12:09 PM

Wow... Slovenia.  Yep, UPS doesn't deliver quite that far.

 

As you posted, at least now you know what to look for.  I wish you be best with this.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#11 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 30 November 2015 - 12:49 PM

Yeah, thank you again for all your help.



#12 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 15 December 2015 - 09:29 AM

The new PSU arrived today and I replaced my old one with the new one and while I was at it, replaced my GPU as well, turned my computer on and the same thing as last time happened, no beep and it shut itself off after a few seconds

 

Bought a 500W Corsair CX500.



#13 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 15 December 2015 - 10:05 AM

Where did you download the graphics driver from?

 

This GPU should have come with a CD containing the graphics drivers.  Have you tried that?


Edited by dc3, 15 December 2015 - 10:07 AM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#14 SammyJamew

SammyJamew
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:27 PM

Posted 15 December 2015 - 10:56 AM

Guess I completely missed that step. But in what order should I try, should I first uninstall the old drivers, replace the old PSU and GPU with the new ones and then install the new ones from the CD?



#15 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:27 AM

Posted 15 December 2015 - 11:20 AM

Yes.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users